KRC2 HDD fail

  • I need support.

    Setup: (v)KRC2 converted to KRC2 . KSS 5.2.x . Two extra 512 MB RAM installed ( if I remember correctly, then its different type than the original).

    Situation: I installed the robot/krc2 a few months ago in an industrial setting. It is used for milling. There are 80+kW motors for other machines on the same main line. There are voltage drops when they start. I have installed a Kemet filter before the VFD of the spindle, but I understood that the KRC2 has built in filters, so I haven't installed one up to it. Three weeks ago I had a HDD fail. The HDD got completely destroyed, I couldn't recover the data. I had backup and installed a second hand old HDD. It worked fine until this also broke. When I checked on the KCP there was an install image. I have kept the KSS installer USB plugged in and it seems it restarted into that when the HDD failed. I took out the USB and restarted the KRC. It said NTLDR is missing. Checked the USB in my laptop and it didn't show up on the drives list. I can't read data from it but I can see it in device manager. Also the two times that this happened I had really large .SRC loaded into memory. First HDD failed during runtime of the program and the second failed after finishing the program but not canceling it and staying that way for a few days. I have made the pagefile registry tweak so I can load larger files into memory. Visually the motherboard and KRC2 internals look good. No dust, dirt, I can't see swollen/damaged capacitors. It looks OK.

    I am on the way to setting up a new HDD. I would like to keep this one healthy.

    How could I make this system more robust?

    What are the steps I should take from a preventive maintenance standpoint?

    What would be the most likely culprit that I can start to troubleshoot?

    I am grateful for any help that you can offer.

  • How could I make this system more robust?

    Check why you had the problem with the old ones:

    1. clone the hard drive sector based instead of file based

    sector based copy

    file based copy


    sector based:

    1:1 copy of your hard drive with all problems (time consumed: about 60 min)

    file based:

    while copying all files will be defragmented and most of the time lost clusters are found (chkdisk) and fixed (about 30 min)

    will be cont ...

  • How old where the hard drives ? maybe buy a new hard drive and install in on that then take an image so you can recover quickly . I assume its a non ed05 that you have upgraded

    Old. Both of them. I have bought a 30 GbTranscend PATA SSD. It is an ed05.

    I am trying to install Windows but I ran into several problems. Everytime, no matter what HDD, it fails when factory -winpe starts and it gets to "Formatting and partitioning drives" . I have tried to manually extract .cab and run it that way, but it says "Operating system not found". I have extracted the .cab file to the previous wiped HDD and Windows installation loading screen appears, but gets stuck after a while and I am forced to shut down. I guess the wiped HDD still had a matching MBR but has other problems. Could be something totally different. I have also tried swapping RAM, but it seems the RAM modules are fine.

    I will be trying sector cloning.

    Please share if you have any ideas.

    Thanks The LEG(nice arm you got there;), DannyDJ and last but not the least, thanks MOM! :smiling_face:

  • Thank you Hermann.

    I am currently installing winpe. I've got the SSD to work after a cluster clone of the defective HDD and extracting the on it. I've also changed the MBR to work with WinXP machines in the software AOMEI. I hope this helps someone. Also it is of importance to jumper the ssd or hdd to master.

    It seems the second HDD got some bad sectors and broke down.

    Next would be to find the bugs that fry the HDD s and get rid of them. I suspect its the voltage/current fluctuations somehow get to the HDDs.

    Could it be that I have a DevNet module connected to the MFC and the Devnet module gets the power from a 24 DC supply connected to one of the 220 V lines coming from the mains filter?

    Or maybe its just pure coincidence that the old HDDs are giving up and one of the USBs got fried. Bare in mind that when the HDDs got fried the system rebooted into the USB windows setup and stayed in it for a day.

    Edited once, last by mbalazs ().

Advertising from our partners