Boot stops in Kuka cross

  • Protip: now that your robot is working, make a complete hard drive image backup BEFORE doing much anything else. Especially if you do not have the Windows re-install disk. It may be the only thing between you and a paperweight KRC2 if anything goes wrong (like the hard drive developing a corrupted sector).

    As Panic said, you can access the Windows menu via CTRL-ESC, if you're logged in as Expert or higher. Attaching a VGA monitor, mouse, and keyboard can be handy, or else you'll need to learn the Windows shortcuts for navigating w/o a mouse. Keep in mind that the TAB key (which you'll use a lot this way) is part of the Numeric Keypad on the pendant, and you'll have to keep switching NUM LOCK on and off to get access to TAB, ESC, PgUp, PgDn, etc.

    Edited once, last by SkyeFire ().

  • AD
  • Hi again !

    I did log as expert and used CTRL-ESC to reach the Windows desktop.
    Then, I used a mouse and keyboard to fiddle around.
    I had already done that in the past, but at reboot, the HMI used to pop up without any problem.
    I guess I'd better follow Skyefire's advice about the backup.
    Any cloning software to recommend ?


  • Any cloning software to recommend ?


    You can use Clone zilla, Norton ghoost or better to use Hiren's Boot CD as it is more easier.

    Also check your system RAM, I offen saw this same stage as you mentioned in earlier picture.
    I replaced its RAM and rebooted system, it was working fine (system was KRC2 ed05).

  • I used bootable CloneZilla CD-ROMs with great success on KRC2s in the past. If your KRC2 is new enough, you might be able to use a bootable USB stick.
    In an extreme case, you could (CAREFULLY!) remove the hard drive from the robot, connect it to a computer, and use cloning software to make a backup or even a full physical HD clone, before returning the HD to the robot. On early KRC1s, the "normal" way to make these kinds of backups was actually to open the cabinet, plug a new IDE HD in place of the CD-ROM drive temporarily, then boot a floppy disk using Norton Ghost or similar, clone the drive, then put all the hardware back to normal.

  • Hate to kick an old thread, but expierened the same issue and disabling the windows firewall on the network interface with address 192.168.1 2 solved it for me.

  • I also have a similar problem, I tried to change the IPs but it didnt work.

    Kuka-cross 3 displays an error "Library FTP not loaded (LoadDLL = 0)".

    How do I fix this?


  • martcerv

    what kss version do you have?

    The base system does not have any driver in order to talk to the hard drive directly.

    On the kss versions up to v5.x the data transfer was done using the ftp server.

    On version from kss v3.? to kss v4.0 the ftp server was a trabant of cross3.

    On kss v5 IIS was used as ftp server (not on OL)

    Kuka-cross 3 displays an error "Library FTP not loaded (LoadDLL = 0)".

    With this command you were able to not use the cross3 trabant but the IIS (There is only one FTP Server allowed)

    Getting the KSS version allowes to figure out whether your message is an error message or not



  • so if i understand you had working system, then you changes some settings and now it does not work...

    also assuming you did not try to change it back and you don't have a backup?

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • vxworks is not able to download the files to the base system (because there is not FTP Server available) and cross will stop at 10%

    FTP Server of cross3 is disabled and the FTP Server of IIS is not accessable (maybe wrong ip address)

  • I also have a similar problem, I tried to change the IPs but it didnt work.

    Kuka-cross 3 displays an error "Library FTP not loaded (LoadDLL = 0)".

    I'm guessing you changed the IP of the "VxWorks Shared Memory Driver"? You cannot change that, it breaks the entire KSS. You need to put that IP back to its original value.

    Most "stock" KRC2s will show two network interfaces under the Windows network settings -- the "Shared memory driver", which is a virtual network interface between Windows and VxWorks and must never be tampered with, and one other, which should be the ethernet port on the motherboard. The latter is the only one you can manipulate, and you must never put it into an IP/Subnet combination that overlaps with the Shared Memory Driver.

  • Hello Wall-E,

    Can you please let me know how can I re-install the KUKA System Software.

    I am working on VKRC1 , Recently I had an issue with the IDE( Transcend 4gb card) , So backup the image from the old disk.

    Now I am trying to use a different hard drive to reboot the VKRC1, but I am getting the boot error.

    It is showing that the hard disk is inserted and but it is not booting further.

    Please some one give me some guidance!


  • Hello Panic mode & MOM,

    Thank you for your response!

    I used the Macrium reflect tool to make backup the image and the same image I write to the new SSD ( PATA 32gb transcend) , another hard disk.

    Here you can have a look at the attached pdf, the pictures are in this pdf file.

  • hmm... i have no idea what you are doing...

    there is no clear description of process or what is functional, just that "you are doing some hdd swapping" and "using Macrium reflect tool". details matter...

    cloning HDD may have options... to backup data only... or MBR only... or specific partition....

    are you sure that IMAGE you have was complete and taken from WORKING hdd?

    if the HDD was not bootable, then cloning content to another media will not fix the problem.

    does your system boot with ANY hdd at all? (with or without KSS)

    if not, your boot drive is not really bootable or motherboard is toast.

    for drive to be bootable it need several things:

    must be recognized by motherboard (supported type)

    must have MBR

    must have primary partition with valid OS

    must have primary partition marked as Active so it can boot.


    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now