Boot stops in Kuka cross

  • So this morning in booting up one of our robots did not start up past kuka cross. There where no messages and windows seem to work, at least it was not frozen. After turning af power the robot boots normally without any problems. So it is up and running again

    Robot in question is a Vkrc2 with kss 4.97 with a KR150 attached.

    Is this something that can happen sometimes? Or should i start looking for problems somewhere?

    if someone can give some insight in why the kuka software did not load, or what could prevent it from loading. that would be much appreciated.

    Every problem has a solution, that isn't the problem. The problem is the solution.

  • Place your Ad here!
  • When turn off the cabinet, the robot saves an "image" the robot in this moment and when the robot reboots , it takes this "image" and load to memory and the robot can start the job in the same place. If the file where the robot saves this "image" gets corrupt, or the backup batteries doesn't have capacity to finish the "image", when the robot starts again the robot isn't able to reboot because it isn't able to load the "image".
    When the robot reboots the second time, it loads from "system", not from the "image".

    Your problem may be so, but only it's a possibility.

  • using a keyboard press ctrl at the windows logo when booted it stops the krc from loading

    go to windows explorer and under c:krc/bin i think it is but you need to be in the bin folder you will see a .freeze file delete this pop the power out of the pc and then back in job done

  • JoseMi:
    I am certain there was nothing wrong with the "image", simply because when it booted the second time it loaded the program exactly where i left it the day before.

    the leg:
    This .freeze file you mention, could you explain what it is? i don't like deleting files if do not understand what the purpose of the file is.

    Every problem has a solution, that isn't the problem. The problem is the solution.

  • On that generation of KSS, the purpose of the .Freeze file was to record the robot status at the moment of shutdown -- position, active programs, program pointer, etc. This allowed (when it worked properly) the robot to be shut down in the middle of a process (say, due to a loss of power in the plant) and resume from where it had left off.
    However, if the Freeze file became corrupted for some reason, it could cause the robot to reboot with "amnesia," requiring an operator to jog it home manually and start from scratch. More rarely, a problem with the .Freeze file could cause the robot to fail to boot at all, until someone manually deleted the .Freeze file.

    Newer versions of KSS use a variant of the Windows "Hibernate" option to achieve the same affect, with greater reliability.

  • Thanks for the explanation.
    Am i right to assume that when a cold boot is preformed that the .freeze file is automatically deleted? Or does it just ignore it during boot.

    Every problem has a solution, that isn't the problem. The problem is the solution.

  • IIRC, .FREEZE file is created during a "warm" shutdown, then loaded and deleted during the "warm" reboot. A "cold" shutdown does not create the .FREEZE file. Any boot where a .FREEZE file does not exist, proceeds as a cold boot.

  • Hi there,

    I have a similar problem : I exited the KRC2 program (in Expert mode) to Windows to try and connect the computer to the network.
    I rebooted from there, and now, the KRC2 program fails to launch properly.
    I get the splash-screen with a "10%" indication, but after a while, it goes back to the Windows desktop and I see a "KUKA - Cross 3" window , and I have no idea what this is.

    Why did this happen, and how can I get back up and running ?


  • Hi Hermann,

    The IP adress of the "VxWin/RTAcc Shared Memory Network" device is still ; submask ; it is used by "Local Area Connection 2".
    I read on the forum that this is the correct IP.

    Now for the ethernet port on the motherboard :
    The IP adress of the "INTEL(r) Pro/1000 CT Network Connection" device is "obtained automatically" (Current : ; submask; it is used by "Local Area Connection".

    I am able to see the Robot controller computer on my network now, although I haven't figured how to access the drives yet.

    HMI still struck at 10%... and reverting to Windows with that "KUKA-Cross 3" window :frowning_face:

  • I tried setting fixed values for the IP adress and submask settings of the motherboard's ethernet.
    Still stuck...

    I am starting to think that my troubles are not related to a network problem, but simply to the fact that the computer wasn't shut down from the HMI, but rather from Windows.
    Therefor, he wasn't able to save the current configuration properly.

    What is the procedure in this case ?
    Recycle the robot's frame into soda cans ?

    Edited once, last by Wall-E ().

  • Re-installing KSS should fix it. The installer for KSS in on the D drive.

    If that doesn't work, possible hardware causes could be a sector failure on the hard drive, RAM aging, or it might be one of those robots that got bad capacitors on the motherboard (that last seems pretty unlikely, though)

  • Hi there Skyefire,

    Does that mean I will need to re-master the robot ?
    It seems to require a special tool which I have no idea where to borrow...

    By the way, is there a dictionnary of all the KUKA acronyms ?


  • No, re-installing KSS should not require the robot to be re-mastered.

    Mastering can be carried out without the EMT, if one is quite careful and isn't using Absolute Accuracy.

    Acronyms... I dunno. I've just spent 20 years reading KUKA manuals -- they kind of sink in by osmosis.

  • As I recall you get same scenario if MFC/DSE is missing, in wrong slot or defective.
    Reloading KSS does not affect mastering as long as MADA is for the robot with same number of axis...

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners