WorkVisual - Closes without warning

  • Has anyone else a problem with WorkVisual (V6.0.18_Build0748, Buildtime 16 july 2021 09:42) that when left unattended it closes and your non-saved work is gone? ;(

    Besides all the times it crashes when you try to deploy, edit, save, load, modify, click, change, download, type........:cursing:

    I know that different factors are at play here, like my PC, RAM, storage....but for a piece of software that is at V6, should not be this unstable!

    Thanks in $ADVANCE=1 :P


  • Lookup WorkVisual.log in WoV installation folder and send it to KUKA with a description what goes wrong. What should we do about it? We do not write the software. If it is unstable there is only one natural destination for your problems: KUKA.

    In the meantime you could try a different version.


  • How do You installed WoV on this machine?

    Running WorkVisualSetup.msi, or Setup.exe?

    The right way is using Setup.exe, and I saw WoV behaving strangely in the past because it was installed with WorkVisualSetup.exe.

  • #2 Already done that :) Waiting for their reply.

    I actually thought I had the newest (newest is not always better). Downloading it now to see if it helps, or else I'll have to revert to an older version.

    #3 Can't remember exactly, but I try using .exe installers when installing new software.

  • MSI installer only installs WoV ... without any of several required dependencies, hence use EXE installer.

    another thing worth checking is crash report folder (if something got recorded).

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • I'm still emailing back and forth with KUKA. I've tried all V6 revisions.

    .13, .16, .18, .20 with the same result. KUKA says that the can't replicate my issue.
    While this has been an issue I've been working offline, not on site.

    As of today I'm back at the site and I already had the software close without warning. I'm online and I am able to see all controllers (8 robots).

    One thing I have not tried is a new project file. But my superior is not paying me to test the software, so I'll have to deal with the issue until a new project comes up.

    Thanks for the responses.


  • it is not clear what exactly you are doing. i guess you are trying to install different versions on same machine but it is not known what the target OS is, compatibility with WoV, type of install, the way install is performed, if and what options are integrated, if and what crash report is generated, etc.

    in other words there are way too many unknowns to offer any concrete advice.

    doing same thing over and over and expecting different results is not ... efficient.

    my suggestion is to try things differently. over the years i had many complain about WorkVisual install. in the end, 99% were user errors.

    so here is a short list of tips:

    1. make sure to extract downloaded WoV into a folder, then run installer. do not try to run installer that is not extracted yet.

    2. make sure to install using Setup.EXE and not MSI file. MSI only installs WoV but not dependencies (which are required).

    3 make sure that path where installation files are extracted is short. normally things would arrive on CD/DVD and setup.exe would be in the root of that drive (something like D:\Setup.exe). in this case dependencies (also compressed files or self-extracting archives) will be ok despite using long names.

    for example D:\DotNetFX461LanguagePack\NDP461-KB3102436-x86-x64-AllOS-DEU.exe will be extracting bunch of files too - and directories (all of which will make path even longer), before they are copied to target folder C:\Program Files\...

    and if the total path length exceeds 260char limit for ANY file, your installation will fail and you may not even know it. then you get to see weird results when you least expect it. and in some cases there are no warnings if this happens. i have seen this and mentioned it before. So do NOT try to install from something like

    C:\Users\MyItAssigmendVerlyLongUSerName\Desktop\My Files\KUKA Downloads\2021\WorkVisual Installations\6.x\00311617;03;KUKA.WorkVisual 6.0;WorkVisual_V6.0.2_Build0287\workVisual\Setup.exe

    that is "only" 186 characters but .Net the language pack (just an example) is already at some 240 characters and that is before anything is extracted yet. guess what happens if that language pack contains something like, i don't know... \Languages\1033\64-bit\SetupResources.dll

    suddenly that 240 is grown to 280 characters and would definitely exceed the Windows limits.

    so if you want to install software, install it from a short path, so that installer executable is close to root. I use something like:





    i guess you are getting the point. Just ask yourself, why Microsoft always installs the operating system into folder that follows DOS 8.3 naming convention? it's been 30 years since DOS. but they will happily let you have your documents in a folder using long file names...

    4. maybe everything so far is all fine but something is simply not right with your machine. maybe something got corrupted so reinstalling different version of WoV6.x does not make any difference. did you consider installing it as a portable version? that should isolate good deal of resources and potentially reduce chance of running into same problem. Or try installing it in a virtual machine.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now