Advertising

Software Request to KUKA - the robot forum bugs and wish list

  • 49. WoV need feature to wrap long text lines. for example spline ILFs and declarations are monsters

    50. And a way to see in WV how the code will wrap when displayed on the pendant. It's a minor thing, but it really affects code usability by amateur users, when you're trying to create deployable software packages.


    51. Autofill in WV that actually works. Half the time, when I start typing a variable, the "auto-fill" box pops up blank and empty.


    52. Search (and replace) functions in WV's KRL editor that work reliably. Far too often, I can see the variable I'm searching for, and the Search function will keep reporting "not found." The Search also doesn't reliably wrap about at the bottom of a file, either. And the Replace function often leaves several instances untouched, while also replacing partial matches in the wrong places, even with "Whole Word Only" checked off.

  • AD
  • 53. provide a way to declare SIGNAL with inverted state. maybe by using negative index:


    SIGNAL STOP_PB $IN[-6] ; STOP_PB is true when $IN[6] is false

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • 54 - WorkVisual: a red cross over files with syntax errors, like happens in the robot itself. Nowadays we need to open files individually. Even with some false positives, this would help debug programs faster.


    55 - WorkVisual: a front end to edit Automatic External variables, like the one we have in Smartpad.

  • 56 -- consistent indenting. This is a pet peeve of mine. I rely on indenting a lot, and WV will even auto-indent KRL code on command. But inline forms don't indent! Even if you do it by hand, they always appear on the pendant display at the left margin. This is a huge pain when mixing inline forms and raw KRL code, and breaks the visual organization of program code.

  • 57. one of my pet peeves is constantly changing code line numbers when opening/closing folds. the whole point of using line number is to track, reference and communicate with others. making line numbers change dynamically when fold is open or closed completely defeats the main purpose. this makes helping someone over the phone so much harder. please provide option or HMI setting to freeze line numbers so that line 2000 is always line 2000 - regardless what number of folds before it are open or closed. and count header lines too with prefix &. This way they will match error messages and whatever one can see offline when looking at the same file in some text editor.


    58. please provide cross reference plugin on the HMI, so one can easily see if some variable or constant or sub or function is already used and where.


    59. document all program module attributes (&....).

    &ACCESS RVOP; V=Visible, but what R,O,P???

    &REL 7 ; number of times it was compiled or saved using HMI

    &COMMENT Working Program; optional comment, visible in navigator pane of the HMI.

    &USER Expert ; Minimum user level to change module Properties (not content).

    &PARAM EDITMASK = * ; ????

    &PARAM TEMPLATE = C:\KRC\Roboter\Template\vorgabe ; name of initial template


    60. Release updated version of reference documents at the time or release. KSS8.5 and 8.6 are out there for some time and there is no companion manual for System Variables, or Compatibility manual (migration to newer KSS). There are new variables like user level etc. and don't seem to be documented.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • 61. Functions STRLEN() and STRADD() fail for character arrays longer than 2047 elements. Other functions like StrDeclLen() work fine for much longer arrays (test 32k on KSS8.5.8). Since KSS does not have data type BYTE but allows declarations of longer arrays and not limitation is documented, i take it that STRLEN() and STRADD() are faulty.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • i appreciate shared updates but would not mind faster downloads from kuka.com

    even small file such as UsbRecovery upgrade 3.0.4 with just 300Mb or so take forever as trickle is comparable to dialup speeds. i can download from other sites (Microsoft or whatever) many times faster so Flashenhals is definitely not on my end

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Werner Hampel

    Changed the title of the thread from “Software Request to KUKA - the robot forum wish list” to “Software Request to KUKA - the robot forum bugs and wish list”.
  • 63. Get rid of WV's "ghost icon" in the top-left corner of the screen.


    Okay, that sounds weird -- I don't know if anyone else has this, but it's been consistent for me through WV 4,5, and 6. I usually have a lot of windows open, and when I have WV running, I generally get some kind of "ghost" taking up the top-left corner of the screen -- right where most applications have their "File" menu, and above where most browsers have their "Back" button.


    So when I'm in another window, and click anywhere in that region, the window I'm actually using loses focus. But the focus doesn't jump to WV, it just goes... nowhere.


    It took me forever to figure out that it was WV doing it -- for a long time, I thought I'd picked up some sort of malware or spyware. Part of the problem is that it's not 100% consistent -- sometimes it starts as soon as I start WV, sometimes only after I've had WV open a while. The only thing 100% consistent is that, the moment I close WV, the problem goes away.


    It's a minor problem, really, but it's like having a pebble in my shoe all day long.


    I do notice that, when I'm running a multi-monitor setup, the "ghost" stays on the main monitor, even if I move WV to a secondary.

  • i think we have the same pebble. it looks like WoV displays some control in foreground then fails to hide it.

    i guess they have form set as TopMost that stays in foreground and from time to time activate something on it. i usually see leftovers like text box or some label or info tip. closing WoV cleans it up.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • 65: in the WorkVisual KRL editor, I really wish the little drop-down at the top, that lets you "jump" to a specific function/subroutine, would accurately reflect the function/subroutine your cursor is currently in. Also, if there was a way to select if that drop-down sorted the subroutines by name (like OrangeEdit does) or by order in the module (the current way), that would be nice.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now