Continuous error increasing speed on KRC2 KR210

  • Hello all,

    I am programming a KRC2 KR210, #KR2210_2 S C2 FLR ZH210 is the exact machine data. System Version is v5.2.14

    After lots of test on slow speeds without errors, I am having ERROR 2933 "Deviation in absolute position value DSE -- RDC axis <axis> when I am testing it in faster speeds on T2. :uglyhammer2:

    Number of axis isn't the same, I got errors on 4th, 5th and 6th axis, depending of the movement. I was changing some points trying to avoid that, but I think its not normal, and I have that error in a lot of movements. All of them are normal movement not rares or dificult to robot.

    Any idea???? ???

    Thanks to all =)

  • What are the spacing of these points? Are the moves continuous? What approximation radius?

    What is the payload? Do you have your Load Data set correctly? The fact that this error is limited to the wrist axes suggests that it could be a payload issue.

    Have you tried reducing the point speed, acceleration, or approximation radius on the points that are creating this issue?

    The other thing to try would be to run an O-Scope trace on the pendant and capture the Commanded and Actual positions for these axes, to get a good view of how they're deviating.

  • Thanks fo your reply SkyeFire,

    The points are spacing, all of them need to rotate the axis with a high velocity. The moves aren't continuous. I have to change lot of them to CONT, but I would do it when I could fix that error.

    The payload has a mass of 60kg and the load data should be correctly... First of all, I thought the problem was this one, but I was looking load data and I don't see anything weird

    I solved the error in some of these points changing the trace, vel and acc.

    I think it have to be any configuration problem. Maybe is interesting to know that the robot is a SafeRobot.

    Thanks !!!!!

  • After few test, I created 2 different points, changing only 6th axis position. I tried to run it on 100% T2 speed and It continues failing.

    I know robot will have limitations in some traces/movements/etc... but It's having error in normal traces I am used to do in all my programs.

    It's weird and I am not sure what could be the problem. I am thinking maybe machine.dat is not correctly configured or something like that. I will restart v5.2.14 on controller adding the robot and loading my programs. I would check it.

    If you have another idea, please tell me it.

    Thanks =) :merci:

  • :wallbash: :wallbash: :wallbash: :wallbash: :wallbash: :wallbash: :wallbash: :wallbash: :wallbash: :wallbash:

    The error persists, I couldn't fix it. But I have done a lot of tests.

    I can move full speed on T2mode 4th and 5th axis separately from min limit to max limit without error. Error appear doing it in with 6th axis.

    I have changed controller, data and power cables from controller to robot, changed data/power cable from back of to the servo, saferdw changed, and more test I am forgetting.

    Error appears in positions near singularity but it appears too in normal movements to in not dificult movements for robot. Its look like the axis tries to accelerate more than normal. I think robot should limit the fasters axis in a movement according to slower/limited axis.

    I am (bad)fixing my program changing the way of movements where the error appear or slowing so much the movement.

    When I dont want robot stop on singularity, I use the variable $CP_VEL_TYPE=#VAR_ALL. In others robots I don't have error on movements passing trought a singularity, it make movements slower on the others axis to permit 4th axis rotate correctly to reach the point.

    I am changing some variables in Machine.dat trying to limit acc/vel max in 6 axis, but I didn't notice changes on movements. Where is the correct way of do that?

    I don't have much more ideas of what its happening. Dunno if its bad machine configuration (weird coz I have reinstalled sistem, etc etc) or maybe engine transmission is damaged.

    Maybe, this robot isnt real KR2 210. I have seen sometimes sellers add/remove suplement between 3th and 4th axis to make it longer/shorter. When it happens to me, I just change the real model of robot to supposed model with/without the supplement. I never had the error in this kind of robots. They worked fine with the transformation.

    If you have any idea, please tell me it. I am pretty sure its not normal. :censored:(I will cut it with an angle driver soon)

    Thanks to all =)

    Edited once, last by Raltru ().

  • the idea is to efficiently narrow it down as much as possible by making a list of possible suspects and then ruling them out one by one. each test need to produce conclusive result if or not problem is one specific area.... inconclusive tests are to be ignored and replaced by better ones.

    assuming the worst case ths could be hardware or software problem.

    replacing HDD (or KPC or entire controller) could confirm or rule out software. if problem persists, focus on hardware.

    running each axis one at a time, full stroke at fool speed, can confirm if this is related to specific axis.

    message talks about feedback issue so any part of feedback chain could be a problem. again swapping out individual components can be used to narrow it down:
    motor (resolver on the motor to be specific), resolver cable, RDC, data cable X21-X31, cabinet interface wiring X31 to connectorprint A32, internal cable A32 to MFC, and finally MFC.

    again if you have other controller, you can quickly narrow it down to problem being inside or outside of the controller, before proceeding to narrow it further...

    you can swap connections among axes (for example A5, A6) to see if problem follows or stays etc.

    you can use trace tool to monitor those wrist es positions and see what happens and when.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

    Edited once, last by panic mode ().

  • I have changed the controller and it's happening too. I swap connections of A5-A6 and same fail in same axis...

    If you want to limit acceleration just in one axis? How would u proceed??

    What do you mean by trace tool, I never use it on KUKA Robot.

    Thanks you very much =)

    Edited once, last by Raltru ().

  • Have you reset the RWD setting to default ? or exchanged the RDW ?

    No, I didn't exchange the RDW and I didn't reset RDW seeting to default. I have changed the controller and reinstall KSS....

    I am thinking maybe its problem of Saferobot security jumpers?

    Can you tell me, how can I reset the RDW?? I think I never have to do it.

    Thanks =)

    EDITED: I have done $Rebootdse=true, and I continue having errors =S Thanks =)=)

    Edited once, last by Raltru ().

  • So, just to review. you have:

    1. Changed Controllers

    2. Swapped the A5 and A6 cables

    And the error persists on A6?

    Given how it only happens at high speeds, my gut feeling is that the issue is the A6 motor. Possibly there's a mechanical issue inside, between the drive shaft and the resolver.

    The simplest way to test this would be to swap the A6 and A4 motors. This isn't terribly difficult -- just four bolts holding each motor, and the two motors should be identical (check their Article Numbers first just to be sure). The biggest headache is the drive shafts -- when you remove the A4, A5, or A6 motors on that generation of KR, they will pull out the drive shaft with them. That's supposed to happen -- like the drive shaft on a car, it's only fixed at one end, and slips into a spline socket on the far end.

    What makes this annoying is that, to re-install the motor, you have to guide the spline end of the drive shaft into the socket behind the A4 joint. And the only access there is a black plastic plug you pull out to reveal a rather small hole -- if you have big hands, you may want to recruit help from someone with small hands. This is definitely a two-person job -- one person guiding the spline end of the shaft into the A4 socket, while the other person holds the motor body and turns it to get the splines to mesh. It helps to have the "elbow" motors pointing straight up before you shut down the controller.

  • Thanks for answer!

    I am having same troubles in another robot, same robot and controller model. =S

    I have done the cable change on 5th/6th axis.... and error continue .

    My feeling is am not configuring something well or bad electrical connection on wires jumpers on securities... but i don't know what. Coz I have done always the same and I have few robots working.

    Robot looks like not limiting the acceleration to max acceleration on movements and its cracks.

    How is the correct way to avoid singularity and limit max acc (or set the correct acc) on axis??

    I use $CP_VEL_TYPE=#VAR_ALL to avoid singularity and I have tried change few acc variables in $machine.dat without any changes =S=S

    In last post, I answered I didn't change RDW.... It was a writing mistake, I did it on first days and error continue appearing after rdw change.

    Thank you very much.

  • Hello,

    we are talking about a old problem I got few years ago.

    I think the problem was model of robot, It was bad configured. Maybe changing the type of robot u can fix it. Sometimes 2nd hand robots have mechanical changes, like the arm length, u can add or remove a supplement on it. If the robot have been modified, the type of robot of the identification plate doesnt match with the real robot.

    Try to size the robot and look for the model with this measurements and change it.

    I tried to explaining myself on my best, I hope u can solve the problem.

  • So, you could not solve it at that time?

    Our robot size and machine data are matched right now, but there are some modifications on safe robot side.

    What else, thanks for your kind reply.

  • It's a safe robot?

    I was thinking in other way.

    I am pretty sure it's related with wiring on safety plug/connector, coz we fixed it adding a switch to change the modes, but i cant remember it now and i don't have noted the changes we made to fix that. Now i am out of robotics jobs.

    I am so sorry.

Advertising from our partners