X11 standalone jumper on KRC2 ed 2005 108 pins

  • Hi


    Can someone share a clear diagram of wiring X11 to X12 for standalone robot use on kuka KRC2 ed 2005. X 11 socket has 108 pins. I saw the diagram that Panicmode posted here but is not clear if only indicated pins should be bridged while rest of them will be removed or all remain as they are.I have many more already bridged in X11. Neither connection to X12 is not indicated.
    This connection is different than KRC2 older.
    Thank you.


    Signum

    Edited once, last by signum ().

  • AD
  • why not just use schematic and manuals supplied with your robot. circuits of X11 jumper plugs shown in various posts here are just indicating what bare minimum connections of robot safety inputs are needs to be able move robot. detailed schematic is never shown (robot safety outputs for example). this means connecting (at the very minimum) what is shown in such examples is sufficient to get you started, other contacts can be ignored (for now...).


    in my experience krc2 with X12 is a rare sight but again... thats what schematic is for...

  • Thank you Panic Mode. It was solved the problem, I found the diagram for X11, it already had connections on pins inside, there is no link to X 12, is another type as I understood.
    But still have errors when switch on, regarding safety circuit like that:
    448 Operating Mode mismatch with input T1 on SafeRDC



    I found that information from attachment, what should I check?

  • Hi


    Yes is a safe robot as I discovered now. It has a bigger ESC board and RDW box has X40 connection on it which get in controller on X21.2.
    Seller told me that it should be kept plugged this cable from X40 RDC to X21.2 in controller. I use the robot as standalone unit.


    You talk about a jumper on X40, do you think is necessary for standalone use of robot? Do you have a diagram for X40 jumper?


    Because my error continue to appear as in the photo attached here above.
    "Operating mode mismatch with input T1 on SafeRDC"
    I checked pins on all cables connected, I checked all bridges in X11, ...everything seems to be ok.


    Another question is, if a safe robot use standard KCP 2 or there is a special KCP for this special robot. Maybe is a wrong KCP what I have.


    Robot is Kuka KR 210 L150 with KRC2 ed 2005, fabrication year 2007.
    Software KSS 5.5.15


    Thank you .

    Edited once, last by signum ().

  • Hi Signum,
    can you please share how do you solve that standalone jumper? What connections did you make? It seems that i have exactly the same system including this Safe Robot thing...
    What connections you did on X11? Did you make anything on X40?


    Thanks!

  • Hi Signum,
    can you please share how do you solve that standalone jumper? What connections did you make? It seems that i have exactly the same system including this Safe Robot thing...
    What connections you did on X11? Did you make anything on X40?


    Thanks!

    Hi,

    I also faced with that problem,

    Do you study what bridges are needed at x11,x12,x40 for stand alone working?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now