SRVO-068 DTERR alarm all Axis

  • Dear collegues,

    I hope someone can help me.

    I have Fanuc P200E with R3JB controller. Robot was operated with no faults some years.

    Then he was stopped with no power supply for a 8 months.

    And now after switching on i have

    SRVO-068 DTERR alarm (Grp:1 Ax:1)

    SRVO-068 DTERR alarm (Grp:1 Ax:2)

    SRVO-068 DTERR alarm (Grp:1 Ax:3)

    SRVO-068 DTERR alarm (Grp:1 Ax:4)

    SRVO-068 DTERR alarm (Grp:1 Ax:5)

    SRVO-068 DTERR alarm (Grp:1 Ax:6)

    Nobody do nothing on equipment.

    I feel that most likely the encoder battery is dead and this is the problem. But i'm not sure and i'm not too familiar with Fanuc.

    I tried to reset this alarm by

    1. Menus > System > Type > Master/Cal > RES-PCA      = No result.

    May be i should do something else?

    2. Menus > System > Variables > $MCR.$SPC_RESET to TRUE   = Automatically set to FALSE and No result.

    Should i disconnect power supply cable before?

    Looking forward for any ideas.

  • SRVO-068 DTERR alarm (Grp:%d Ax:%d)


    A request signal was sent to the serial Pulsecoder, but no serial data was returned.


    1. Check the connection of the cable between the Pulsecoder and servo amplifier. (If the alarm is occurred at robot axes, check the connection of the robot interconnection cable (for the Pulsecoder)).

    2. Check the shielding of the above cable is connected securely to the grounding plate.

    3. Replace the Pulsecoder.

    4. Replace the servo amplifier.

    5. Replace the robot interconnection cable (for the Pulsecoder). Refer to the Controller Maintenance Manual for more information.

  • Here is a clip from a post I was on 4-5 years ago. After tightening the mentioned shield clamps it never happened again.

    "DTERR alarms can be caused by poor connection of the shield on the RP1 cable to ground at the controller."

    "Yes the shield clamps were all loose in the cabinet. Tightened them and problem cleared. You people are life savers. I thank you."

  • Thank you for your responses

    of course I saw your post written 4-5 years ago.

    And I checked the connection in the cabinet. Everything is fine here.

    This is not my case.

    The equipment worked without errors and was simply turned off for a long time.

    There must be something else.

  • Yes batteries is another alarm code. But what can i did.

    By the way, I would be grateful if you can tell me where this battery is.

    Today I found another remedy in documentation.

    The attach instruction is executed when the tool is not attached

    – Phenomenon

    The tool is not actually attached. So, a communications alarm such as ”SRVO–068 DTERR alarm” occurs

    on the pulse coder. Correct this by Remedy 1 or Remedy 2 below according to the present conditions.

    Remedy 2

    1 Directly change the system variable to detach the tool. To do this, set the following system variable to ”0”:

    $SCR_GRP[servo tool operation group No. (normally, 2)].$AXISORDER[all 1 to 9] = 0

    2 Turn the controller power OFF then back ON.

    3 The robot starts up with the tool in a detached state. Move the robot by manual feed to physically attach

    the robot and tool.

    4 Execute the attach instruction to attach the tool.

    5 The tool can be used as it is after it is attached regardless of the battery type.

    Looks like my case. May be someone did this in the past?

    Anyway i will try on Monday.

  • Don't think that your robot ever had a "servo tool" attached. So this is not your problem.

    Normally the batteries are behind a cover at the robot base, but I don't know where exactly this cover is at those paint robots. Check the manual.

  • The battery box is usually inside the controller mounted to the door.

    There is a DC/DC converter board in the base of the robot, make sure it is getting 24V (labelled 24PG). It then supplies the 5V needed by the PulseCoders.

    The 24PG comes from the Encoder/Brake Module in the controller which also buffers the encoder signals and battery voltage.

    Like hermann, I believe the servo tool procedure is not correct even if you have Servo Bell. Your DTERR alarms are for the robot axes, not extended or auxiliary axes.

  • BRAKE ENABLE OFF is correct position.

    1. To release the brakes, set the BRAKE ENABLE switch to ON (ONLY FOR MANUAL BRAKE RELEASE).

    2. To activate the brakes, set the BRAKE ENABLE switch to OFF.

    Edited once, last by Rees ().

  • Clamps were tightened in control cabinet. Connectors unplugged and plugged again. No reaction.

    Encoder/Brake Module in the controller actually buffers signals from pulse coder.

    But no LED on him. Can anyone tell how to test this module.

  • If you are getting DTERR alarms on 6 axes then the controller is not getting data from the encoders. Not sure why you are looking at the brakes.

    Make sure the connectors at the lower area of the Encoder/Brake Unit are fully seated. Something common to all 6 encoders would be power to the encoders which would come from the 24PG output of the Encoder/Brake Unit. I would also double check the connections to the DC/DC Converter in the base of the robot.

  • Thank you Skooter.

    You showed me the way.

    I think the same. Your idea regarding encoder brake unit seems to be the most correct. I completely agree.

    In documentation says:


    The encoder/brake unit performs the following functions:

    • Shunts all encoder five volt lines to ground when power is turned off or purge is lost.


    Yesterday i checked purge module. But in my version i don't see direct connections between PURGE UNIT and ENC / BRAKE UNIT.

    Simulated errors ROT and HBK. It works.

    Unfortunally i didn't have voltmeter. So can continue only tomorrow.

    Now I'm preparing to check

    PGC24V on the top part of the encoder/brake unit (is this some kind of enable signal??)

    and check 24VPG lower half (power supply for DC/DC ?? i think so).

  • BUT in documentation says "...shunts all encoder five volt lines to ground…" if something wrong.

    So I fear that the power supply is ok, but all signal lines are shunted.

    I don't see any enable/disable signal on the face panel of ENC/BRAKE UNIT.

  • "Shunts all encoder five volt lines to ground when power is turned off or purge is lost."

    If the power is off then not an issue. After purge, if the positive pressure is lost then the 200VAC going to the power supply should also be cut-off and which will also turn off the robot. Either way the power will be off when it's shunted.

  • Just my 2 cents worth..........

    I think the advice offered in post #2 and #8 and what Skooter is advising, would be the logical approach of investigation.

    Paint robots (as a general rule) are Atex rated, and therefore require intrinsic isolation between 'dry and wet' sides.

    So having additional hardware (buffering/barrier modules) in between is expected to ensure intrinsic isolation.

    If these buffering/barrier modules are not functioning then, no power will be made available to 'wet side'.

    It is also probable the Robot requires to be pressurized before applying power to the 'wet' side, therefore purge equipment/purge jumper plugs maybe required in order to pressurize, until pressure is reached, this could also be attributable to the encoder/brake module being disabled.

    Not knowing too much about Fanuc Paint robots, it would be worthwhile checking to see if this is the cause of the problem.

  • Absolutely agree kwakisaki and Skooter :merci:

    The problem has been resolved.

    Below I describe how my investigation proceeded.

    Perhaps it will help someone.

    PURGE UNIT check flow switch and pressure switch (both disconnect 200V to servo amplifier)

    Also it has intrinsic inputs for two sensors ROT (Robot overtravel) and HBK (Hand broken).

    This inputs passed throw servo amplifier and the corresponding error comes out on the screen.

    ENC/BRAKE UNIT has two power inputs on top part and two output in lower part 24VPG (A and B)

    Input 24VPG comes from internal board near main contactor. (24 V - Ok).

    Input PGC24 coms from separated internal power supply unit (unit SOLA SDN 5-24-100P was corrupted).

    As mentioned above 24VPG is a power supply for encoders (No voltage). Оbviously PGC24 = 24PVG.

    So i replaced the corrupted unit.

    SRVO-068 DTERR was replaced by SRVO-062 BZAL all axes.

    Menus > System > Variables $MASTER_ENB >>>> 1

    Menus > System > Type > Master/Cal > RES-PCA

    WELL DONE..:weissbier:

Advertising from our partners