Start Program not enabled during debug session in WorkVisual

  • Hello,

    I have a question concerning WorkVisual debug session on a KR90, I have a KSS with version 8.5.5 (8.5.337) and WorkVisual version 6.0.6 (B542).

    The system is in T1 (o T2) I have established the connection and selected my program.

    1. When I want to start the program, I need to use the start button on the SmartPad, the "Start Program" button in WorkVisual is always disabled

    2. When I run the program (in T1 or T2), it does not seem to stop on breakpoints.

    REM: I see the program pointer moving during debugging, and I can monitor variables and inspect them, but I have to interact with the program/robot via the SmartPad only

    Do you have an idea why this "Start Program" button is always disabled.


    PS: thank you for all the precious information on your forum, it has already saved my day a couple of time.

  • Hello again everyone,

    I did not receive feedback here.

    My question seems maybe obvious, but I do not have much experience with the Kuka environment, and I do not manage to use breakpoints and start the execution from WorkVisual.

    From the SmartPad I can select "Step by step", then I can step in the program from the SmartPad and follow the exection synchronousely on WorkVisual (and monitor variables), but this process is very slow as it steps on every line of the program.

    As shown on the picture in my post above, the "Start Program" icon is disabled, even though in the WorkVisual manual they show it as enabled and say it is possible to start the program from there. I must be doing something wrong, maybe a confirguration or something, but I don't understand what.


  • Hi,

    This is just my biased opinion, but usually members of this forum respond only when they are relatively sure about their solution to a presented problem. You won't find many replies in a form of "Yeah, me too".

    What you have so far described in terms of working with WV is the extent that I use. I haven't seen anyone who figured out breakpoints, thought that would be a very helpful feature. Personally, I use a global bool with a conditional halt in lieu of a breakpoint. Then when I am done debugging- just regex them out.

    Even at version 6, WorkVisual is not quite bug free and feature complete. When it comes to software, Kuka is not the leading robot manufacturer :\

  • you need to describe how to REPRODUCE the problem...

    not just 'this is the situation' but how YOU get there, step by step.

    then someone may pinpoint something you are doing differently.

    by the way KUKA released videos on this subject.

    don't have access to controller at the moment but just tried it using WoV 5.0.10 and OL_8.5.8 (user level can be operator, does not matter):

    1. start WoV then use menu VIEW > 2 Programming and Diagnosis, new perspective is loaded (perspective is a set of windows)

    2. refresh cell tree and place checkmark next to controller you want to use

    3. in the KRC Explorer, right click on controller and ESTABLISH CONTROLLER STATE. This transfers files from controller to a temporary repository on your computer (Ctrl+Shift+D)

    4. in the KRC Explorer, right click on controller and choose START DEBUGGING (F5)

    5. in the KRC Explorer, right click on SRC file and choose SELECT PROGRAM. pay attention to DEBUGGING window. it shows message, program state etc.

    6. optionally - if you want to see the code, open that SRC file (you can run program without seeing it)

    7. in the KRC Explorer, right click on program and use START PROGRAM (F10), RESET PROGRAM (Alt+Up) as you please or click on equivalent icons in the menu bar.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Thank you Mentat and Panic Mode for your replies.

    Panic mode, I was following the same steps you describe. I just followed them once again in the same order to make sure (here I select a program called probe_tst2.src. The problem I have is that when I reach your step 7, I do not have the "START PROGRAM" option in the menu (and in the tool bar, the button is grayed out).

    In the messages I have the "Start key required" message, but that is always the case when you want to start the program, isn't it?

    • Helpful

    I'm a bit chary about using this feature, though. I learned the hard way that, if WV crashes while a debug session is running, the robot keeps going. The good news there is that at least the remote debug only works in T1 (and T2! 8|), so you still have the deadman.

    Also, when WV crashed on me with a live debug session running, the "save report and restart" function ended up trying to open an infinite number of Explorer windows and WV sessions on my computer -- I had to forcibly task-kill them. So, I would suggest unchecking the "save crash report" and "restart WV" options in the "WV Has Crashed!" error window.

  • Thank you SkyeFire, I will remember this "Save crash", because I also have a few crashs per day.

    I think I found the reason for my problem in the manual, they mention that "Start Program" is only available in Offline PC (I suppose this is when WoV is connected to OfficeLite)

    Also I received a reply from the KUKA support and they said this:

    "You can’t start the robot with WorkVisual.

    You need to upload the project and run it with the Smartpad.

    In Workvisual you can follow the active programs that are running."

    I think it closes the subject. Thanks to you all for the support!

  • I think I found the reason for my problem in the manual, they mention that "Start Program" is only available in Offline PC (I suppose this is when WoV is connected to OfficeLite)

    Never tried the debug function before, but this makes sense, at all.

    I imagine that people trying to start a program with movement instructions from WoV while holding the Smarpad and pressing deadman button would cause several unpleasant situations.

  • Hi! I need to understand if I'm the only one having problems with the debugger. Thanks for the clarification about point 1.

    What about point 2. ? I'm setting breakpoints in my code but the execution doesn't stop at them..
    I'm basically new to Kuka programming, but I think that I've used it in the recent past succesfully, but now they are not working anymore.
    Also in my case I see the program pointer moving during debugging and I can monitor variables and inspect them.

    KSS 8.7.2
    KS V8.7.390

    Any suggestions?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now