Error with IP address 172.31.1.147

  • Hi
    I am facing a problem with Kuka LBR IIWA robot. Please see the attached image.
    When we try to synchronize from sunrise workbench, it cannot connect with cabinet with IP address 172.31.1.147. However, Station server IP on smartpad is shown as 172.31.1.147. I pinged with 172.31.1.147 but I didn't get any response. It seems that my PC is not connected to the controller. I am using network with KLI port to synchronize sunrise application.
    Would you please help me to fix the problem?
    Best Regards

  • Hi Ahyan,


    Do you have the correct settings on your notebook network adaptor?


    You need to be in the same IP range e.g. 172.31.1.150 and use the same subnet.


    If so, try turning your wireless adaptor off, I have known this to cause problems for some reason?!

  • Yes. You'll need your laptop network adpater set to Static IP, with an IP and NetMask compatible with the robot's settings. If your network adapter is set to DHCP/Dynamic IP, you won't be able to connect. Also, if you have any other network adapters (like a wifi) that are set to a similar IP range (whether static or dynamic), it can cause the laptop to be unable to choose which adapter to use.

  • Thanks a lot for your responses. I followed all suggestions that you provided in your responses. I setup a network with KLI port and configured my laptop adapter with a static IP of similar range: 172.31.1.150 and same subnet mask. I also pinged the cabinet but didn't get reply. I am also unable to install station configuration. Is it possible that robot controller IP setup has been changed for some reason although station server IP is showing 172.31.1.147 on smartpad? Is there any way to check this?
    Please help me to fix the problem
    Thank you

  • are you SURE you are connecting to KLI port and not to one of other RJ45s (Ethercat and service port)?

  • I had the same problem with one of the Robots we received, The controller was faulty. If you cannot install your config, you won't able to synchronize the project.
    But first, you should succeed in pinging the robot

  • This might be a little late, but I was having the exact same issue on my KRC4 I switched from a Windows 10 PC back to a Windows 7 laptop and it started to work right away. I dont know what type of PC youre using, but hopefully that helps.

  • This applies to all cases where you can't connect to a device. If your ip settings seem to be ok, and you still can't connect to a device or ping it, launch Wireshark and see if any packets are actually transmitted. If no packets are transmitted, disable firewall and try again. If you still can't see any packets being transmitted, there's most likely something wrong with the network or your ip settings are still wrong.

  • Had the same issue. I had the connection through a USB adapter for my ethernet cable. Instead, when I connected the ethernet cable directly and was able to ping the robot successfully.

  • check if subnet mask matches, try pinging, test same cable to connect to or ping something else

    Hi, thanks so mcuh for your help.

    Why my KUKA_Sunrise_Cabinet IP is 172.31.1.10, not the147? Also where can I find Nav_KMR_200_iiwa_7/-R800 server IP address?

  • KMR is a complex product with number of nodes built into one AGV. it is not a single robot - this is an integrated solution that contains many nodes and they are linked by both standard and safety interfaces. As a result addressing scheme is different than for single robot.


    Another issue here is that KUKA chose to set their wireless node as an access point. I have no idea why. In best case that can work fora single unit and only for short range. As soon as one has more than one AGV or then need to move throughout a plant, this network setup is doomed. This means one pretty much has to modify settings of the Scalance unit in the AGV. i am guessing that is the device that you call server. unless you mean Nav server... not clear....

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Advertising from our partners