Advertising

$MOVE_ENABLE Input not allowed or $MOVE_ENABLE Eingang nicht Erlaubt

  • god day


    I have problem with KUKA KRC2 robot. software V3.2.6 SP01
    we used KRC1 teach-pult this pult has 2 test mode , 1 Automatik mode and 1 Extern Mode we used automatik mode. But this teach pult had mal-function.


    And now we use teach pult VKRC1 and this pult have 1 test mode and 1 Automatik EXTERN


    Everything work fine but only on test mode when i switch the button to Automatik Extern in the windows mesage ist this
    $MOVE_ENABLE Eingang nicht Erlaubt


    Please could you help me with reconfiguration Automatik Extern
    http://img835.imageshack.us/i/picture2e.jpg/
    http://img814.imageshack.us/i/beznzvu1.jpg/


    Thank you very much

    Edited once, last by tomasss ().

  • The problem is, that AUTOMATIK EXTERN is the mode where the robot should be controlled from a external SPS. So the SPS has to give the MOVE_ENABLE and the EXT_START signals and they are not allowed to be set to always true/ false (1025/1026).
    So you either have to wire and control those signals from your SPS (or from manual switches) or buy a normal teach-pult so you can use AUTOMATIK again.

  • The problem is, that AUTOMATIK EXTERN is the mode where the robot should be controlled from a external SPS. So the SPS has to give the MOVE_ENABLE and the EXT_START signals and they are not allowed to be set to always true/ false (1025/1026).
    So you either have to wire and control those signals from your SPS (or from manual switches) or buy a normal teach-pult so you can use AUTOMATIK again.


    Could you please describe me what is external SPS?. I dont have so much experiences with KUKA robots
    Thank you very much

  • If you edit the option.dat inside mada steu and change the variable (BOOL $CHCK_MOVENA=TRUE ) to false then you can use 1025 for move_enable :yesyesyes:

  • "SPS" appears to be German-ese for "PLC". In this case, he's referring to any external control system that is starting/stopping the robot remotely, usually a PLC like a Siemens S7 or an Allen-Bradley Logix-5000.


    Setting $MOV_ENABLE to $IN[1025] allows the robot to move without receiving this signal from an external PLC (generally for AUT mode), but for safety reasons, it is usually not allowed to combine this setting with EXT mode. The Leg's setting to circumvent this safety is not something I've ever used myself, but I'd bet he's probably correct.


  • If you edit the option.dat inside mada steu and change the variable (BOOL $CHCK_MOVENA=TRUE ) to false then you can use 1025 for move_enable :yesyesyes:



    When I edit option.dat
    BOOL $CHCK_MOVENA=FALSE
    then windows mesage is clear but the robot dont move on AUTOMATIK EXT

  • Are you sure you want to use Auto external as you have the ext start set to 1026 this is always low ???


    I think you should select Auto then press the drives on button followed by the the green + key (start)


    Do you have a plc or any i/o attached to the robot for ext start ???


  • Are you sure you want to use Auto external as you have the ext start set to 1026 this is always low ???


    I think you should select Auto then press the drives on button followed by the the green + key (start)


    Do you have a plc or any i/o attached to the robot for ext start ???


    I dont have any i/o attached to the robot. In the older Teach-pult KRC1 i dont use Auto-Ext We use only Automatik.
    Have I change EXT_START 1026 for other value?

    Edited once, last by tomasss ().

  • Then if you put in in auto press the drives on button (button by the keyswitch with a 1 on it )
    Then press the green plus until you get bco
    press green plus again and it should start


  • Then if you put in in auto press the drives on button (button by the keyswitch with a 1 on it )
    Then press the green plus until you get bco
    press green plus again and it should start


    This wont work in AUTO EXT, the start button (green plus) is disabled in AUTOMATIK EXTERN and the controller listens on EXT_START instead, which should normally come from the PLC. (Maybe there is also a workaround for that like the $CHCK_MOVENA ?)


    Also you need to get BCO in T1 before you switch to AUT or AUTO EXT.


    So it would really be the best, if you get a normal replacement KCP (no VKCP) , so you can use normal AUT again.

  • You dont need to get BCO in T1 if using AUTO as when you press and the the green plus you will achive bco then press it again to start
    MMm i see from the photo he has it in Ext not Auto


    So you need to use AUTO or setup the signals to use External

  • As Leg said, AUT mode is to run the robot automatically without any external devices controlling the robot via I/O. EXT mode disables the KCP controls and only allows the robot to be started/stopped via external I/O signals. Which mode you use depends on your situation.


    In AUT mode, to achieve BCO it is necessary to hold down the Step-Forward key until the first movement of the program is complete. After that, release and press Step-Forward once and the program will run on its own at full speed until the end.


  • In AUT mode, to achieve BCO it is necessary to hold down the Step-Forward key until the first movement of the program is complete. After that, release and press Step-Forward once and the program will run on its own at full speed until the end.


    If you read the first post, you will notice that the OP has a VKCP as a replacement, so he can not switch to AUT anymore :-)

  • It's been a loooong time since I worked on a VKCP. But if it doesn't have AUT mode, then yes, he's got a problem. Personally, I really hate customers who insist on special custom KCPs, but that's a rant for a different time....


    It ought to be possible to interrupt the selection wiring inside the cabinet and swap the AUT and EXT signal lines. Ironically, this would be much easier on a controller with a bulkhead-mounted selector switch, and I've done it on those in the past. This would, however, make the controller inoperable with a regular KCP without switching the wires back again.

  • I had same problem, customer didn't want to buy a I/O module and also new KCP that's why I had to find a solution. I had disassembled a KCP and than put bridge between AUTO and EXT. Almost I was going to scratch a way of EXT but I noticed AUTO mode is dominant when both of them connected with the signal. I have attached the picture so you can see my terrible work :)

  • Does anyone know if $MOVE_ENABLE is only looked at when in AUT / EXT ? Or does it also disable motion in T1 mode (depending on the state of $CHCK_MOVENA and $I_O_ACT)

  • Mmm? $MOVE_ENABLE can disable motion in ALL modes -- that's why you have to switch it to $IN[1025] in order to jog or run the robot without an external enabling device (and why the system now prohibits having $MOVE_ENABLE set to that input when switching into EXT).

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now