Analogs displayed as 0...10 and "Calibration Factor" usage

  • On my Kuka teach pendants, the display analog I/O page shows the values as 0...10 instead of the 0...1 they actually are as $ANIN and $ANOUT system variables. Is this changeable? Because that's silly and has caused mistakes to be made. Even a 0...100 scale would make slightly (very slightly) more sense, but having everything uniformly as 0...1 would be ideal.


    It looks like the "calibration factor" might be able to adjust that, but I'm really not sure what effects it would have since I can't find any real documentation on it. They're set to 32767 (I guess for 16 bits). I'd be concerned that scaling that up by a factor of 10, if it were actually to change the scale on the display to 0...1 as desired, would also change the $ANIN/$ANOUT to only scale 0...0.1 instead, which would defeat the purpose. It doesn't seem like adjusting the calibration factor would mess up communication to the I/O cards on the fieldbus, but I wouldn't exactly be surprised. Does this sort of thing work?


    Related, I was considering trying to scale one to be the speed of a spindle in rpm (both setting it on output and reading the tachometer on the input to verify), so I wouldn't need to math it out when setting or checking it at the pendent. Writing functions to convert is easy enough when dealing with it in code, but less convenient to check on the HMI. There are workarounds, like tying the I/Os to global variables in the submit interpreter and interacting with them from the display variables screen instead, but that is not a very convenient interface. Anyone come up with a good solution for a similar situation?


    If it matters: using KSS 8.5, workvisual 6.0, on both KRC4 and KRC4 Compact


    Thanks!

  • AD

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now