Deadman Switch Worn?

  • Having never had the pleasure of squeezing a new deadman switch I wonder is (are) my Krc1 deadman switches worn.


    There does not seem to be 3 positions!? Just in and out.


    In T1 when I squeeze switch in and I have "-+" enabled (top left button) I do get my axis appear as option down the right side of the screen. However I'm getting an 'Active Commands Inhibited' notification.


    The 3 position thing seems not there. Is it very subtle or click,click,click? Or am I just too ham fisted?

  • AD
  • Older KRC1s pre-date the 3-pos deadman switches, and have only two positions -- squeezed (safe) and released (unsafe). Your KCP might be one of those.


    The key is if the motors come on. You can try squeezing the deadman very slowly -- if the motors come on, then turn off as you squeeze the deadman harder, then you have a 3-pos deadman that's worn down.


    OTOH, if the motors never come on, then you have some other issue, probably in your safety wiring.


    The fact that the right-edge buttons change to the jog controls when you squeeze the deadman means that the deadman is at least working to some degree, since the KRC is detecting the squeeze.

  • Thanks again SkyeFire for sharing your knowledge!


    This evening I will go through the start up procedure again and see what the last few messages are. I know I have not got to the stage of hearing the squeak of the motors engaging yet but the Deadman issue looks promising!

    I will also reseat those ribbon cables into the relay board on the swing out bit. From my reading it seems they can shift and cause emergency like behavior


    My giant paperweight may yet live!

  • The saga continues..

    I can see that KCP is well used and the key switch is moody. I need to go beyond T1 for T1 to activate.


    I have also been stuck with not getting my little green 'I' which if I understand correctly will happen if the drives are enabled and the deadman is engaged while in T1.


    If I hit 'drives off' I hear a gentle click of a small relay but there is no click or any sound when I press 'drives on'


    Could this be my problem? A damaged cable of worn out switch?


    Incidentally there are no strange error messages when I go into T1 mode.

  • So my KCP switches seem fine:(

    I did a multimeter test both directly on the switch inside the pendent and also on the pins of the plug.


    Is it possible to use X11 43 and 44 to enable motors? They are labeled as external drives on, 1 and 0.

  • In T1, squeezing the deadman should close a couple relays on the FE207 board, which should then (after a ~0.5sec delay) close the big K1 relay (main motor power). You get the green 'I' icon after the K1 relay closes.


    I've never seen X11 signals used to turn the motors on. Even if that's possible, it won't work in T1 or T2 modes, only in EXT mode (maybe in AUT mode, but that's iffy). In Teach, the only way to turn on the motors is the deadman.


    The messages are the important thing. Anything that's blocking the motors from turning on in Teach when the deadman is squeezed should produce a message on the pendant. The X11 safeties need to be wired.


    If the motors don't engage, and there are no messages, then it becomes hardware debug. The most likely issue would be a stuck relay or loose cable on the FE207 board. If you contact KUKA with your robot's serial number, they'll probably be willing to provide you with an internal wiring diagram that includes your specific FE207 board. The nice thing about the old FE207 boards is that every relay has an associated LED, which makes it easy to observe the status of each relay in real time.

  • Thanks SkyeFire,

    Perhaps the X11 pin designations I'm seeing on my paperwork are outputs not inputs. I will go forward with-out investigating that route.


    I'm glad you brought up the relays and LEDs. I have been wondering whether they are all functional. The panel itself was hanging down when I opened the cabinet first. 1 pair of the large relays move but I have yet to see the others budge.


    This evening I will disconnect the board and test the relays directly. Do you think damage can be caused to drive circuitry if I power the coils directly with some external voltage? (Appropriate level of course!)

  • I don't know about damage, but I'd be wary of the test results. The relays on the FE207 board have complex relationships, including some built-in timing delays. For example, each "safety channel" probably has two relays in parallel that have to close within milliseconds of each other, or they get "hung" in a 1-on, 1-off state, plus a 3rd relay (which usually has a red led) that has to open when the other two close.


    I don't seem to have any of those old prints around, but I did find an example of the board layout. CAUTION: there were several generations of these boards, so yours might well not match. Still, KUKA tended to follow the same general pattern, just adding more channels or functions with newer generations.


  • Hi again SkyeFire

    My relays seem ok, as far as I can test they are not fused/welded and all move happily with voltage applied. Visually the contacts look clean also. I did notice evidence of new soldering. All the capacitors associated directly with the relays seem fresh and one of the relays also. (top right in the photo)

    Two curiosities here. Power connector X926 was not connected. In fact the plug doesn't even reach it. Also the plug has but 1 wire!

    Secondly X925 has no ribbon cable associated with it. I don't see any sign of it.


    I just wonder what I am not seeing here. It wonder is there mystery e-stop or safety thing happening that isn't being flagged in the log.


    As I reassemble I will reseat the ribbon cables at both ends. Worth a shot...

  • Well maybe I am barking up the wrong tree altogether..

    On boot up now I saw

    Configuration Error i/o driver INTERBUS.


    Can interbus things stop the robot in T1? I had assumed that PLC related communication would be totally ignored in the T1/T2 position.


    A little background might be appropriate here. This robot was a polishing machine in it's former life. There were 4 interbus PLCs in various cabinets associated with the cell.


    After a little prodding of menus I came across the screen in the attached image. Could this be my mystery Inhibitor of Active Commands?


    I hope remarking some bits of the INI can solve this...


    Thanks again for your attention!

  • you don't have move enable active. if this is controlled by no longer existent PLC, robot will not be able to move - even in T1. so change move enable to 1025 (which is always on).

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Loss of communications can definitely prevent robot motion in T1/T2.


    As Panic says, $MOVE_ENABLE is set to... looks like $IN[9]? Without that input, motion in any mode is blocked. $IN[1025] is a "special" input that is always True (1026 is the always-False input). Setting $MOVE_ENABLE to 1025 is not allowed for EXT mode, but is allowed for T1/T2/AUT modes.


    Another note: There are signals on the X11 that have the same names as some of the "soft" $IN/$OUT signals. I'm not sure why that happened, but those signals are completely separate, even if they have the same names. I'm pretty sure that that generation of KRC1 had a Move Enable on the X11, in addition to the $MOVE_ENABLE "soft" input. While the "soft" input can be changed, the "hard" inputs (anything on X11) cannot be, and the X11 inputs must be wired properly, period. No exceptions. There is no way to bypass anything on X11 other than wiring.


    OBLIGATORY SAFETY NOTE: bypassing anything on X11 presents a SERIOUS risk of injury or death. Especially for T2/AUT/EXT. Unless/until you have some safeties set up, I would advise NOT bypassing the Safety Gate X11 signal, though you can bypass the others. This should allow T1, maybe T2, but block AUT and EXT.


    Also, the "soft" signals are not safety-rated signals, even when they have the same name as the X11 safety signals. You cannot rely on $MOVE_ENABLE for safety, or $DRIVES_OFF, or the others, for reasons that should be obvious.

  • Well that was an interesting evening.

    The monster lives!

    I went Configure>I/O>Automatic External and set $Move_Enable to 1025 and Drives Off to 940. Why 940? Right now I don't know...

    Anyway it seemed to work but POP!

    As soon as I tried to move a now enabled axis the main breaker tripped and cut the power. But being a stubborn type I rebooted and tried again.

    This time on attempting to move an axis I got 1 second of something and then POP again!


    I again rebooted and then tried another axis and found it did not move but I could hear the motors trying. Unsurprisingly, I got over-current errors on the KCP.


    So now I must get my Allen keys out on free up the joints. I suspect my robot had been sitting still for quite a while. Nothing some lard won't fix...


    Again thank you both for your assistance with this journey. I'm optimistic again that this machine will have a second life.


    One last question...what values should be in Drives_On and Drives_Off in the configuration in this situation? They will never receive an external signal as my PLC is gone. What should I type in there to keep it happy?

  • Without an external PLC, or I/O to stand in for the PLC, you're only going to operate the robot in Teach or AUT modes. In AUT mode, you have to satisfy $MOVE_ENABLE, but the rest of the Auto External signals remain unused. You do Acknowledge and Drives On/Off from the pendant buttons.


    Allen keys? What are you planning to do? The "emergency" way to rotate a KUKAbot axis is to remove the small cap on the back of the motor, put a socket onto the (12mm?) hex nut that makes up the back end of the drive shaft, and crank the drive shaft with a long breaker bar. There's a substantial gear reduction, so it'll take a lot of cranking to make the axis move visibly.

    NOTE: there is, IIRC, a smaller hex nut that can be spun off, and that will wreak the resolver. So make sure you're turning the big one.


    Before trying that, though (it damages the servo brakes), I would suggest trying to determine if the brakes are actually opening. I find it unlikely that all of the axes have frozen up.


    There should also be grease-gun fittings on at least some of the axes.


    This video series might be of some use, although that's a KRC2. But aside from some changes to the electronics, KUKAbots haven't changed that much over time.

  • I went Configure>I/O>Automatic External and set $Move_Enable to 1025 and Drives Off to 940. Why 940? Right now I don't know...

    drives off is inverted signal and should be set to TRUE most of the times.

    set drives off and move enable to 1025


    set external start, drives on, and confirm messages to 1026

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Superb info again!

    SkyeFire I will need to remove the existing pneumatic gripper and replace with a VFD router spindle, hence the Allen keys. I will resist disassembling any more until after I watch the video you recommended.


    It seems A1 and A2 have the stacked pair of nuts. The other axes seem just have the small one.


    A1 and A2 seemed to squeak a bit. I suspect this is the servo breaks you mention. All axes are now moving, with some effort, but certainly freed up a bit.


    Ironically this ceased state might have a benefit as the robot was not parked when it travelled...


    I will begin un-caking the wax which encrusts the arm and hunt for these grease nipples.


    panic mode

    Thanks for those calibration settings. I will punch them in later today.


    I intend to use the robot for one-off sculptural carving. In foam and wood primarily. In that respect I'm thinking I will not need a PLC at all. Certainly some safety cut-out sensors but otherwise I think I can keep it simple.


    I will report back with a conclusion to this chapter. Thanks again

  • Indeed there were only threaded plugs, no nipples. All too familiar to me right now.... All axes seemed not to be dry except the A6. I'll oil that next week.


    On another thread.. I'm hanging on 'Downloading System Files' starting KSS. I'll start a new topic for this. Thanks for your assistance getting this far!

  • So to wrap up this conversation I will conclude with a brief recap of what I have learned.


    Very old KRC1 pendants only have two positions on the deadman switches. Not 3 Unlike newer versions and other robot brands.


    T1 mode does not entirely ignore external signals. Some are still needed. In my case ' move enable' was needed to be set as true in the configuration settings. This is done within KSS:(or by PLC)


    Configure>I/O>Automatic External


    set drives off and move enable to 1025


    set external start, drives on, and confirm messages to 1026


    Not withstanding PLCs and internal e-stops this allowed me to get my robot engaged and power to the servos.


    Divide and conquer. A complex problem is just lots of simple problems crammed together. Thanks all for your assistance.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now