KRC5 micro, Connection to controller is invalid

  • Hello everybody.

    This is my first time working with a KUKA robot.

    I used to practice a lot with SIEMENS SINUMERIK.

    I downloaded the project from the WV 8.7 to KUKA controller and after that this message appeared: "Connection to controller is invalid".

    I tried to load INITIAL project and after that KSS 8.6 does not find a connection to the controller.
    KSS starts to load but does not load completely ..... I am not seeing any screens

    1) Are there any ways to establish communication with the robot controller?
    2) Is it possible to connect an external monitor to the C5 micro and set up configuration files in the robot to establish a connection?

    I don't really understand why HMI (KSS) doesn't load.

    Thanks in advance to everyone.

  • have not worked with any KRC5 yet but it should be no different than working with KRC4...

    so here is an attempt to answer your questions:

    if smartPad fails to connect to controller, something is obviously not right. you can connect external monitor and then do a cold start of the KRC. if external monitor is not detected on powerup, normally no image is output - which is why it need to be connected before powering up.

    in some cases there may be a silly thing, some message etc that needs user action before booting completes. smartPad is really another computer and it cannot connect to KRC unless both are ready and working correctly. until that happens you are just seeing local screens from the OS running on smartPad.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • The settings seem to be alright. Never ever change them!

    The settings are not the Smartpad settings, but the settings of the robot system. Remember Kuka has two windows on their robots, one on the robot, and one on the smartpad.

    Why don't you ask in the German robot forum. Da würde ich mich viel leichter tun.


  • Hallo.
    There was an error in the settings: 198 instead of 192

    All ok now

    Danke KUKA support

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now