Minimize HMI w/o Admin?

  • Hey Robot-Forum users,


    KSS 8.5.8

    KRC4 Compact controller

    DVI Monitor + USB Keyboard


    Appears one of our techs locked out Admin credentials on the KUKA HMI and promptly forgot the password. Nice. :rolleyes:


    W/ KSS 8.5, minimizing HMI comes with Admin credentials, no longer in expert. I have access to expert, but I don't have access to Admin. My plan, if I can successfully minimize the HMI or prevent the HMI from coming up, is to regedit the password back to default.


    Reading on a few other threads, it appears there's a key sequence you can use on boot to prevent the HMI from opening. I'm referrring to:

    smartHMI interface

    [SOLVED] KUKA KRC2 Windows fail


    I've given these a go, with no joy:

    - CTRL

    - SHIFT

    - CTRL+ESC


    Any clever ideas?

  • AD
  • well, first thing is to find the culprit and punish him


    then make backup before touching or changing anything else. i normally make archive, diag and image. there is a lot of overlap/redundancy between them but i have seen backup fail too so more than one is a safe choice.


    then simple fix is to restore image using USB recovery stick... assuming you have one and this good backup image.


    another option is to connect HDD to a laptop using USB to SATA interface and edit whatever you like. not in front of robot but i think HMI is started by shortcut in Startup folder of the menu (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup)

    so removing this should stop it from starting.


    if this is not the case you can try remote registry editor but this can be risky, i would rather temporarily rename "C:\KRC\StartKrc.exe" to "C:\KRC\StartKr_.exe" and put the HDD back into robot controller. This should prevent start of HMI and give you access to Windows.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • once connected HDD to your computer, maybe just edit

    C:\KRC\USER\FeatureAuthorization.xml


    and change UserMode to 20 (or lower) for last line

    <FeatureRight ExactMatch="false" UserMode="30" Name="ConfigureAdvancedTP"/>

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

    • Helpful

    Wasn't able to find this specific XML, but I see what you're recommending.


    I did try playing around with C:\KRC\SmartHMI\Config\Authorization.xml, which gives the same user mode levels from 5 to 30. However, this didn't quite do as expected. Modified both "#ExpertProgrammer" and "#Administrator" values between 20 and 30, all it really seemed to do was make these options disappear from the user menu...


    However, I found another interesting workaround.


    From C:\KRC\UTIL\RuntimeTests, there is a DLL and config file that will allow a logging function to pop up on the SmartHMI.


    Copy/paste these files into both C:\KRC\SmartHMI and C:\KRC\SmartHM\Config, and you'll force the HMI to display a logging function on the bottom of the HMI. Will require a reboot w/ file reload, which you can force if you "Restore" a previous KUKA project. Just make sure you back up / image before doing so.


    From there, you'll be able to get into the desktop and use Start > Administrative Tools > Computer Management to reset the password.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now