[SOLVED] KR3/KRC3 ESC failure

  • Hello,


    I'm slowly progressing in my repairs of the KUKA KR3 robot with a KRC3(ed05? Made in 2007) controller, but I have encountered an issue I am struggling to fix.
    When I boot the robot up, there are a few errors I am seeing that I would like to fix, but the two that worry me most are these:



    When I run Monitor -> Diagnosis -> Safetycircuit, instead of the normal window I get this:


    I have no idea where to begin looking at this issue, because there isn't anything in the manuals specifically related to the ESC board.
    To further assist with the diagnosis, here is more information about the controller and robot in screenshots, text comments under images:

    (KR C V5.2.15, GUI 1.2.32.0 B74, Kernal KS V6.74_39, DriveBus item #1 PM 2.24)



    (KRC 3, #KR3 C3A FLR, No position accurate robot., 7123 hours, 6 axes, 0 external axes, all versions V6.6.0/KUKA5.2, DriveBus item #2 PM 2.24 )



    (Windows version 5.1.2600, XPe V1.1.0 Build 10, BIOS version KUKA Roboter GmbH SY-7VBA133U/K V1.4.0/KUKA1030, DSE SW version 4-0, Processor Freq. 59MHz, Version C32)



    (No options installed(?), MFC2 SW Version 4)


    Launching the DSE-RDW tool shows that there's no data on the ESC diagnostics status and state register, and only ESC1 has some data:


    On the hardware side, the backup/UPS batteries are missing(on their way), that fault is signaled in the log.
    The MFC board seems to be functional, as is the DSE board - I can open up the drive bus section in the DSE-RDW diagnostic menu, the drives show up there and provide realtime encoder and voltage stats from the robot when I release the brakes(by pushing the 3 buttons on the robot body).


    I have checked all the fuses in the entire controller, reseated most connectors(including the cards themselves), everything should be fine on that front.
    All supplies except UPS(shows fault, no battery) and 76V(servo supply voltage, just turned off since drives aren't on) seem to be fine, but I don't know if there are any separate supplies on the ESC board I should be checking.
    The ESC board is a "KUKA ESC CI2 V1.20 00-112-112".
    On the ESC board itself, two LEDs are glowing - LED10 and LED11, close together. Nothing else is lit up.


    I've followed the manual(physical) and installed this jumper configuration:

    (6-12, 2-8, 21-27, 3-9, 22-28, 7-1, 26-20, 5-11, 30-24, 10-4, 29-23)


    On the first boot when I got the robot, I also had some "defective brake" errors on A1 and A4, but those went away, and I could acknowledge them - they weren't persistent. That, and I don't care about A1 and A4 brakes, because they're not likely to move without them, and A1 brakes do work despite the error message.


    Also, I should note that I do not have a KCP2 pendant, and I am unable to afford the exorbitant eBay and reseller prices, as that is close to what I paid for the entire robot. [size=4pt]If anyone has one of those for a sane price, let me know.[/size]


    Where do I go from here? KUKA doesn't support this robot anymore(silence on their end), and I really want to get it running with the original controller.
    [size=4pt](Side note: if anyone has the interface description for the Agile Systems servo drives, I would be very grateful)[/size]

  • Some progress: The power supplies at the top of the board, including the 78M05 linear regulator and 34063 switching converter are getting no voltage.
    Using a thermal camera I found a single hot(52-53C) resistor(R116), next to A2/X10:


    There doesn't seem to be a very constant voltage across it.
    Could the ESC be not switching on because there is a backup/UPS battery fault(it's missing)?

  • More info:
    With X14 plugged in, and X11 plugged in, the optoisolator section gets really, really warm(80C-ish):


    Without the plug, but still with X14, only two optoisolator + resistor pairs get hot(62C):


    The 7805 in the top left corner is outputting a stable 5V, 1.6k between ground and output.
    Any clues?

  • More information:


    After installing both batteries, backdriving all the robot axes into the mastering position and remastering the robot, I have managed to alleviate the "Dynamic braking active" message that popped up every 3-5 seconds, and I am only left with this list of blue "(!)" messages:


    Code
    23    KCP Prototype
    274   Check robot number
    275   Set robot number - program robot name
    53    Output state mismatch PM2 (my note - this is the A4/5/6 drive)
    208   Safety circuit has detect an error. Use ESC-Diagnose for further information.
    1     EMERGENCY STOP
    20    External EMERGENCY STOP Pressed
    310   Safety circuit for drives not ready
    200   Drives Contactor off


    Everything points to needing a teach pendant - is there any way to avoid having to buy one? Primarily because I can't afford to dump $2000 on a pendant.

  • Not really? Definitely not without doing some decidedly unsafe hacking to the safety wiring. At minimum, you would have to replace the E-Stop and Mode Select wiring that normally is part of the teach pendant. And even then, you'll be missing the CANBus link to the pendant, which might or might not cause a fatal fault. These controllers were never built to run "headless."


    You also have some other issues -- Errors 1, 23, 208 are due to the missing pendant, and 310 is a side effect.


    However, 20 suggests that your X11 wiring is missing the E-Stop (and would create 310 on its own).


    274 and 275 suggest an information mismatch between the controller and the robot (however, on KRC3s this is different from any "normal" KUKA, since the KR3 is essentially a re-labelled Denso robot with the KUKA HMI and pendant added).


    53... that one I'm not sure about, but I doubt it's related to your missing KCP.

  • This KR3 is the older re-labelled Thermo CRS F3 version, the newer KR3 Sixx is a Denso.


    I was under the impression that since this robot has a rack mount and was running in a factory, it was headless(and the seller said there was no controller with it, only one on the factory floor).


    What worries me about X11 wiring is that when I plug the jumper in, both the diodes and optocouplers next to them get really rather warm(~80-85C), which is a very uncomfortable(but not fatal) temperature for silicon.
    274 and 275 is... odd, since the controller definitely knows what robot it is, and all the data seems to be there, but I have the original floppy - would it be worth trying to copy the MADA over from that? I've never done it, so I'll have to read up more.
    Pushing the "help" softkey in HMI mentions something about calibration, not mastering.


    53 is unknown to both me and the KUKA support people(not Augsburg though, got a local branch), but I'm going to assume it's something to do with the A4/5/6 drive, but with that said, the drive is fully functional and all error/warning fields are 0 in the DSE-RDW tool after mastering, so I think it may go away once the rest is solved.


    Regarding 1, 23, 208, and 310 - can the ESC board fail so catastrophically without the pendant, with the Safetycircuit tool not being able to initialize at all?

  • Wow, the CRS? That's... I haven't seen one of those in ages.


    Unfortunately, I never worked on one (very few people ever did), so I can only extrapolate from the KRC2s that the KR3 was made to emulate. On a KRC2, at least, the hardware buttons on the KCP were an integral part of the hardware safety circuit going into the ESC board, and the soft keys were all handled via a CANBUS connection. The video signal was simple VGA.


    I can't speak to the temperature question, although that does seem rather warm. OTOH, those safety signals were intended to be "shorted" by relay contacts wired to the X11, so the only current limiting is going to happen on the ESC board. So any waste heat generation will also happen there.


    I know there were some compromises made in creating that generation of the KR3 -- for example, I can't say for sure if the robot arm has an equivalent of the RDC board. And in KRC2s, the "robot model" errors normally arise from disagreement between the RDC's memory and the KRC's.

  • I thought that there is some sort of hardware or software setting that would let you switch the robot from T1 into auto without the pendant, but shorting the wires on the ESC board(X4 connector) responsible for the switch has no effect, so it must be disabled somewhere.


    The video signal is a proprietary serial connection from the KVGA via a single differential pair, which is not possible to connect to using a regular VGA monitor.


    The X11 contacts are indeed shorting them, but I guess they're still functional, since they do only start heating up when X11 is there.


    And as far as I can tell, there's no software or hardware RDC equivalent. There are 4 boards inside the robot: The board at the bottom, near the Harting connector, serves as power and signal breakout(don't see much else besides a few LEDs). Then there's two servo drive boards, one in the waist(A1/A2 joint), one in the wrist(one side of A4). The last board is a power distribution and relay board that sits inside the waist(also A1//2).


    Inside the controller the only custom board is the MFC2 ISA card with a DSE-IBS board on it, and that board connects directly to the robot via two RS-485 pairs, but they're also described as RS-422 in other places(electrically similar). The electrical repair manual says that they're actually an Interbus-S(no idea what the -S is) connection, but I am unsure yet. I'm currently working with someone that has a functioning original CRS F3(not re-labelled, but identical) to reverse-engineer the protocol.


    As for the pendant... well, I'm basically out of options at the moment, as nobody will give me a reasonable price for an old, beat-up KCP2. Everywhere I contacted they say that they don't have KCP2s with broken displays and 6D mice(which I really don't care about). I'm open to offers on this, but I doubt I'll have much luck any time soon.

  • So I have a pendant now. Everything works, and I can get both S and I indicators to light up green, I hear the drive contactor click when I hold the enabling switch halfway down, and it turns off if I hit "drives off" at that point.
    I've managed to get rid of all the errors except

    Code
    53 Output state mismatch PM2


    The error is not persistent - it only shows at the start(of HMI), but cannot be acknowledged away unlike the rest. I tried this both in T1, T2, Aut, and Ext(not that this would work).
    In the "safetycircuit" diagnostic tool there are two components, KCP and AUX, both are yellow(not ready).
    In the DSE-RDW tool, when I half-push the enabling switch, the second drive(labelled 02-PM AG0B-06) shows 76.8V on the bus, when I let go it starts to slowly drop, which is totally normal(rated at 76V for the servo bus).
    If anyone has a solution, I.... I don't know, I'll pay you $50 or something. I'm beyond clueless now.


    This is a screenshot when the enabling switch is halfway down, and old notifications are acknowledged(via ack. all):


    This is when I try to jog:

  • did you try disabling any IO drivers to ensure no I/O overlap?
    if problem persists, PM module may need to be replaced or firmware update is needed.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2


  • did you try disabling any IO drivers to ensure no I/O overlap?
    if problem persists, PM module may need to be replaced or firmware update is needed.


    And as I posted this, I checked the MADA, and sure enough - there were two unwelcome things(one of them was STOPMESS) mapped to 4 and 5 of DSEIO, which is used for user GPIO and pneumatics on the servo drives.
    The lesson is this: If you let someone unqualified and untrained touch your robot, you'll wreck your MADA, give you an unhelpful message with no explanation, KUKA will tell you the robot costs a fortune to repair, and you'll sell it to a hobbyist who will revive it in ~2 hours with the help of a friend.


    The second lesson: Check your MADA, even if your output monitor is not showing anything.


    And a tip: It's practically impossible to run a KRC2-KRC3 robot without a pendant, so budget in another $2-3k if you think you're getting a bargain at scrap value, and it won't look like a bargain anymore :icon_mrgreen:

  • hello.

    Because i have the same problem like you

    with esc board in krc2 robot but with kcp2

    pendant connected(before 6 months last tested this robot worked ok).

    How you resolved the problem?

    Also what is the infrared camera you used for debuging?

Advertising from our partners