Fanuc "Robot Position is Out of Stop Tolerance"

  • I receive this alert on the majority of my cells upon restart, especially when we have to move the robot in T1 prior to restart. If this issue occurs, it normally happens if we have to go into the cell to fix any type of issue and then button everything back up and restart it in AUTO. We will hit the cycle start button and the message of "The robot position is out of stop tolerance. Please select action. Choosing CONTINUE will require cycle restart." We always select continue and have to hit the cycle start button again. Again, some times this pops up and then some times it doesn't.

    This isn't prohibiting any type of operation, it is more of a nuisance.
    Is this something that can be rid of or is it an occurrence that everyone has and has to deal with?

    Any input would be greatly appreciated!

  • I had a robot that would occasionally display that same message. It was infrequent enough that I never pursued it. You might check actual position versus program point - especially if the point you step to has a large tolerance zone.

    Edited once, last by Iowan ().

  • From what i remember, this occurs when the robot drops more than it is allowed between the servo power being cut and the brakes engaging. I do not remember how to fix that issue. Are they old robots, such that the brakes could simply be wearing out?

  • This occurrence is happening on all of our cells. They range from being installed in 2004 and all the way up to this summer. I found that if you disable the resume tolerance feature under MENU/SETUP/RESUME TOL will get rid of the popup window. I haven't done this yet but I was wondering if I disable this, I will run into any other issues???

  • I am kind of curious why this is happening. I am pretty new to my position, so i don't have the years of experience to draw on yet. Do your robots stop in a position that is extended away from the base horizontally, or do they have heavy EOAT or payloads?

  • We run welding robots with less than a 7kg payload.

    From what I've gathered looking this up, the points of your program must match the axis's physical position within the system. Example, if you open up a door while the robot is moving, the brakes will engage and all motion will stop. While all of this is happening, the robot may "float" or "settle" and put you outside the measured tolerance of a specific position. And on your older cells, if there is "slop" in your brakes, your position may move and put you outside the measured tolerance. All of this happening will be miniscule to the point that you will not see any movement but the controller will, thus showing you the window.

    I'm not sure if this is correct or not. I plan on disabling the measured tolerance feature next week and see how that turns out.

  • The message is a warning, I wouldn't disable it.

    Is there to remind you that you are attempting to re-start at a different position, far from were the robot was last time it stopped (in AUTO).

    As you explained, sometimes cell stops for any reason, you move the robot in teach beyond the (resume) tolerance, if you attempt to re-start then you´ll get that warning message.

    It could be a nuisance, but it can prevent costly mistakes!

  • I'm working with an R30iB controller and i just integrated this robot, im getting these alarms and in the past i would just select continue, but when i do that on this robot it faults out and says it failed to run task arm is too far out of tolerance, even though the robot didn't move. I went to that menu to modify those settings, but it won't let me select anything to modify, like it's locked out... thinking maybe a variable needs change..? any help is appreciated

  • I've had the same issues on an R-2000iB/210F that I installed. It was used, so very likely the brakes could be worn out. What I usually do is switch to T1 and jog to either the current or previous point in the program using forward/reverse buttons in T1. Then, throw it back in auto and hit cycle start. I usually get the pop-up, and hit continue, hit cycle start again and it takes off. The tolerance warning is based on the DCS principle and having the robot verify it's physical vs programmed positions (or along a path). If the position deviates too much, like if your robot is in the middle of a Linear move at high speed with CNT100 and you're within the "rounding off" section of the move, it frequently thinks it's too far off of the programmed path. Throwing it in T1 and jogging back to the programmed path will allow you to run, but you'll still get the warning. That warning is there for a reason, and I have no plans to disable mine at all. (But I may bump up the tolerance allowance).

    Not sure if this helps anyone or not, just my observation and experience so far.

  • Hello,

    We have the same thing as people discussing above, but we prefer to keep the yellow box as an extra safety feature to make the techs stop and think, problem is the box doesn't always pop up, the screen says it cannot start from a distance. we have to hit select and enter and sometimes it pops up and sometimes it doesn't. or it takes several times, is there a way to make these pop up immediatley when it is required? thank you

  • Hi,

    i have the same massage poping up on three robots i am working with atm.
    usualy when "fence open" is the problem what made them stop, but other reasons for them to stop would trigger that massage aswell...
    one robot is using linetracking and the other two work with rail-tracking.

    everytime one of them is "disturbed" while in the tracking programm, they throw these masage upon atempting to continue their work. that makes it impossible to restart them in the auto-process without taking the TP in my hand to move them in t1/t2...
    i know some said i could disable it, but funny part is that in Menu -> setup -> resume tol. the function is already on FALSE...

Advertising from our partners