Command gear torque A1 error

  • Hello guys,



    I am working with a KRC5 V 8.7.4 with KR150 robot and a linear track KL4000(external axes).



    I was calibrating Tool for which I defined load data of tool and defined the location for Centre of mass and their inertias. Then I was defining transformation using XYZ 4 point method. I successfully touched up 3 points from 3 direction without any errors, then while doing the last touch up point, there was “command gear torque A1” with error code KSS01073. Because of the same error none of the axis can jogged not even the external axes/ linear track. I tried the start-up mode and still get same error.



    Is there any particular reason for this? Since all the other 3 touch up points were fine with the same load data how come the last one has problem? Or is this because of some other reason?

  • Place your Ad here!
  • Copyied from the KSS error manual:


    ERROR 1073 Commanded gear torque

    CauseThe permissible gear torque has been exceeded.
    EfectPath--maintaining braking.
    All active commands inhibited.
    Output “$Alarm_STOP” is set to signal level 0.
    RemedyVerify load data.
    Reduce load if necessary.
    Reduce programmed acceleration.
    Reduce programmed velocity.
    Acknowledge message.

    "Hell...Yesterday it was workinG... I sweaR" :o)

  • Okami i read that error message. i am using a 35 kgs tool and robot supports 150 kg. i have defined the tool as it should be like other cases. it was working for all the 3 touch up point until the last one.


    even after defining the tool it gives error that means there is something i am missing not because of weight but because of possibly something else maybe linear track/KL4000 (E1) axis but i am not sure what is the actual reason.

  • Did you check load data when error happens, $load_c? Is the expected tool active, $tool_c? Does the error happen while jogging or while running a program. How is your KL setup? Is the KL measured in? Does the error come immediatly even with override zero or very small? Whats the holding torque, $Holding_torque[]? Is this value plausible? Is the robot new or was something modified recently? If it was modified whats the difference when comparing machine data to the old configuration, r1/$machine.dat and $robcor.dat? Do the brakes open when you push tbe deadman switch, clicking noise? Are the axis values the robot thinks it has fit approximatly to the actual position, $axis_act? Is the current cartesian position plausible, $pos_act? Is the robot absolute accurate and mounted tilted on the KL? Does the error persist even after cold boot?


    Especially A1 is often the case if the robot is configured to be wall mounted but actually is floor mounted.


    Too many possibilities without knowing more details about what situation you actually have there.


    Fubini

  • Fubini


    There was a problem with transformation of the Linear track, basically there was no standared transformation for linear track. when i changed the linear tracks transformation into standard the problem did not occur after that. so possibly robot could have been wall mounted configuration, which is weird as the robot was never ordered like that from KUKA.


    But hey i am having problem making the linear track as asynchronous axis.


    1) First thing i tried is disable transformation and activated asychronous axis for E1. After safety configuration, i always end up having following errors:

    KSS12032 Position deviation motion controller<>safety controller

    KSS00404 Safety stop


    this says there is some mismatch in configuration between safety controller and machine data and suggest me to update the safety configuration.


    i figured out the difference was with $ET1_TFLA3.A and $ET1_TFLA3.C

    i did safety configuration to match them yet the error stays.


    2) Another thing i tried was enable coupling of the linear axis and making the linear axis asynchronous, and disabling the transformation. this helped me to get rid of position deviation error but the safety stop error was not cleared.


    i believe the reason lies within transformation of linear track and robot. but i could not figure out how to get proper configuration. or it could be completely different things.

  • You mean your robot is mounted on a linear track and you want to decouple both? Kinematically coupled axes like KLs can not be made asynchronous. How is the KL configured in r1/$machine.dat? Is it of type #ERSYS? Then making it async will not work. So what exactly are you trying to achieve here? Normally KL is for use cases where you extend your robot from 6 dof to 7 dof by the KL. So basically setting ERSYS-mode tells the system to treat robot and KL as a unit with some specific redundancy handling.


    Maybe thios helps on how the KL is calculated



    Fubini

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners