Correct shut down on KR C1 and HDD clone

  • Hi all,

    Let me start by saying I'm new to the Kuka world so be gentle!

    I bought a 1998 KR30 with cabinet running win95! It brings me back to my childhood...


    But my question is how does one shut down the computer? I can't get out of the Kuka software and have resorted switching the power off in the cabinet. This can't be good.


    What am I missing here?

  • Just switching off the power is the way. But what should happen is that the computer stays on for a minute on battery power so it can save all important data and then shutdown.

    Every problem has a solution, that isn't the problem. The problem is the solution.

  • Yeah, on any KRC1, upon shutting down the main power disconnect, the controller should keep running on the batteries for 30-60sec or so (it can vary). IIRC, on the KRC1s, the screen would go dark immediately, but if you have the cabinet door open, there should be a small power LED that stays on until the controlled shutdown is complete. Also, the small DC-powered blower fan inside the swing-out computer rack should keep running until the controlled shutdown is complete.


    KRC1s didn't support reboot or shutdown from the pendant, just the main power switch.


    The reason for the controlled shutdown is b/c the robot keeps parallel copies of certain data (Mastering, serial number, runtime, etc) on the controller HD and on the EEPROM chip on the RDC card in the base of the arm, and the controlled shutdown (on the batteries) is the time the robot uses to update the EEPROM. If the batteries are dead, this update won't happen, and you'll lose Mastering.


    The main reason for this dual parallel copying is to preserve the critical data in the event of a replacement of the RDC card (or whole robot), or the hard drive (or whole controller).

  • There is no battery on the EEPROM, You can get problems with the EEPROM memory because there is a maximum amount of write's availalble. With a machine of that age that is a risk.

    Every problem has a solution, that isn't the problem. The problem is the solution.

  • The batteries should be replaced every three years, by the book. And if the controller has been powered off for a long time, the batteries will be dead anyway -- they are only intended to retain power for ~60sec after main power loss, so they don't need a long charge retention.


    One side effect of this is that, if the controller has been powered down for more than a month or two, or if the batteries are brand new, the controller should be left powered up for 12-24hrs to ensure the batteries are fully charged before the controller is shut down. (the charger is slow, as the expected use case for robots is to be powered up 90% of the time year-round)


    As the batteries age, eventually the controller should start throwing "Akkumulator" or "PM Voltage" warnings, indicating that the batteries are no longer accepting a full charge and need to be replaced soon.


    Aside from the batteries, the stock advice for anyone buying an old KRC1 or KRC2 is this: IMAGE THE HARD DRIVE!


    KRCs run two OSs in parallel: Windows for the user interface, and VxWorks for all the realtime mission-critical stuff. They communicate through a virtual network interface (Note: NEVER TAMPER WITH THE WINDOWS IP ADDRESS SETTINGS for the "VxWin" adapter, set to 192.168.0.1). Windows gets installed first, then VxWorks, rather like a Host and VIrtual Machine.


    The problem is, while the installer for KSS (KUKA System Software, which includes VxWorks) should be available on the D: partition of the robot's hard drive, the installer for Windows is only on the bootable CD-ROM that should have come with the robot. But these CDs are usually lost with 2nd-hand robots, and the CD-ROM drives are likely to have mechanically failed (rubber drive belts), so if Windows were to become corrupted, you could be in a bad spot.


    So, removing the hard drive and connecting it (use a IDE-to-USB adapter) to a regular computer, and using ACronis or CloneZilla or something similar to make a complete bit-level image of the HD (both partitions!), you can re-create the HD even if the original catches on fire. And as long as you take regular backups (Archives), you can use those to bring the robot back to exactly the state of the last backup, from even the most catastrophic HD failure, simply by restoring the image and then restoring the Archive.


    Note: Robots that old may have mechanically failed FDDs (again, rubber drive belts), so archiving program files may need to be done differently.

  • and also do not forget the ribbon cables to hdd, fdd and cd. I had a lot of problems with those.

    If you think a hdd could be faulty always change first cable, then hdd (problem: knive blade contacts)

  • Thank you all for such informative replies.

    I did indeed image the disk as soon as I got the robot but it seemed too easy. And it was. My image is not being seen!

    So my HDD is not being seen is really what I mean. May I elaborate as we are on this topic?


    Strangely the existing set up has me a bit confused. The drive, which is a copy according to the post-it note on top of it, is in the master (end) position on the IDE cable yet it has no jumper on the 'drive select' near it's power socket. And so it is set as slave?!


    To confuse me further, on start up there is no master drive found but windows boots regardless without any other drive being shown to be found.


    Also! in the Bios the empty Master position is set to 'Auto' and the Slave/Secondary is set to 'User'. I tried to find out exactly what these settings signify but my search results are all a bit contemporary.


    I think this question is really a hardware/BIOS issue. There are quite a few variables which are eluding me.


    P.S. My 'new' HDD is actually older and smaller and the same brand, Seagate Barracuda.

  • Hm... it's been a looooong time, but IIRC, a "normal" KRC1 had the CD-ROM and the HDD on the same (Primary) IDE cable. The HDD should be the Master, and the CD-ROM the Slave. I don't remember ever seeing the Secondary IDE used.


    Back when you could still get bootable Norton Ghost on 3.5" floppies, the way I imaged a lot of KRC1s was to open the case, move the CD-ROM connector to the "new" HDD, then boot from the floppy and do a direct drive-to-drive clone. Then re-connect the CD-ROM and close up.


    Your screenshot of the BIOS... is that with the original HDD in place, or the clone? B/c it seems to be seeing the Slave, but not the Master.


    It's been a long time since I did IDE anything, but ISTR that some IDE cables had certain wires swapped at certain connectors, which let you get away without using the M/S jumpers on the drives. I'm not sure if the KRC1s ever used that or not, but it might be worth looking at the cable.

  • So normally, the Primary Master and Slave are set to Auto in BIOS.

    And on KR C1 the HDD was Primary Master, and the CD-Rom primary Slave. Take pictures of your current BIOS Settings, remove the CD-ROM and the Floppy, check the Jumper on the HDD and start the PC. Check BIOS and by selecting the primary Master you should get a sub-menue with more details. If you don't see your HDD check cable, check HDD compatibility to Win95, replace HDD if necessary.

    At least that is the way I would do it. Once you got your system running, you can add CD-Rom and Floppy as needed, but more likely they are fried already.


    And

    << To confuse me further, on start up there is no master drive found but windows boots regardless without any other drive being shown to be found.>>

    means Windows is starting of your cloned Slave HDD

  • Thank you both for your replies.

    I've been away from the robot the last couple of days but will get back to poking around tomorrow.



    @SkyFire, I suspect my system had been tweeked a bit and unfortunately none of the IDE cables were attached when I opened the swing out cabinet.

    I think this will be a process of elimination..

    The screen shot shows the configuration as I received it. This is the only way I can get it to boot at this moment.

    And yes the (original) HDD is in the master (end) position on the IDE cable! The HDD has no jumpers so I suppose it is configured as slave.

    Possibly importantly there is nothing else on the cable. Does this allow jumper to override the IDE cable position?

    There is another IDE cable floating near the back of the CDROM floppy area. It is not plugged into either of those drives but it looks like it may have been. I didn't see where the motherboard end is. There must be another IDE header in there in the dark.


    I must check to see if this HDD is FAT16. The physical disk is 160GB but it looks only like 1.99Gb when one views it in my computer via an IDE to USB adaptor.


    I will check for and try other IDE cable to see if it changes the scenario.


    It seems this 'User' setting is a manual set up method in the bios. Surly it could not be that the technician who installed this drive simply did not have a jumper and so set the Bios to boot from this USER defined fake 2GB drive???


    Also I have two Sealed Lead Acids on the way. The ones in the cabinet were reading 1.1 V after 6hrs of the unit being powered. I assume they are defunct.


    Thank you SKyFire. I will keep you posted.

  • Hi Florida!

    Thanks for your reply also.

    Maybe the bios does not have 'find' the slave drive as it is defined under the USER parameters. I mean to say, during boot it reports looking for the Primary Master but there is no message regarding the slave, which it happily boots from. Would this sound correct?


    I think I will stick a jumper on this mystery drive and see if it become a master in it's current position in the end of the IDE cable. At least this will clarify the primary master/slave question. It should get auto detected I assume.


    I will also check the compatibility of my personal clone. It looks the same overtly but now I wonder if there a Format issue or some physical thing with the drive that WIN95 does not like. It is small and older so I assume this should not be an issue but we'll see.

    Cheers!

  • As of this evening I solved the Master/Slave mystery. It seems that the jumper on the HDD does indeed override the position on the IDE cable. I installed a jumper on the old drive and left it in the original position on the IDE cable and it is Auto-detected as master during boot.


    I have started the Clonezilla route to make a copy of the original drive but this evening I found my old IDE desktop can't boot from USB so I will have to make a CDROM boot disk tomorrow and hope the CD rom drive is still functional. This is on a random desktop not the cabinet computer BTW.


    Tomorrow is another day!

  • most of the time I have seen ribbon cables going straight thru.

    In this case the selection of master or slave was always done by setting jumpers.

    Master/or single for HDD and slave for CD


    If there are jumpers I always would set them (in the proper way)

    Sometimes the hdd would work without proper settings - most of the time - NO

  • Success! I've got a clone working on the robot at last.

    The final process was as follows:

    I removed the original HDD from the cabinet and plugged it into an old desktop with i686 processor and IDE capability.

    I put a new 160GB HDD on the slave plug on the ribbon cable. It is important that the capacity of the new HDD is the same or bigger than the original physical drive.

    I then booted from the CD drive with Clonzilla i686 version on the disk.

    I used the 'local disk to disk' option, carefully checking the names of the HDDs.

    The rest was simple and worked perfectly following the on screen instructions.


    On the install back into the cabinet I rewired the original CD as master HDD as slave but it failed to boot. I was gutted! Then I decided to remove the jumper which was on the 'cable select' option.

    Reboot and BINGO!


    Thank you all for your assistance on this matter. I'm sure I'll be back but for this evening I will plug in the power to the arm and see if it moves...

  • RobotRobert

    Changed the title of the thread from “Correct shut down on KR C1” to “Correct shut down on KR C1 and HDD clone”.

Advertising from our partners