• I have a 2004 model R2000ia 165F RJ3iB with no door switch. I cannot clear these faults (SRVO-105 DOOR OPEN OR E-STOP) and (SRVO-021 SRDY GROUP 1 AXIS 1 through 6). I replaced the Servo amp, E-STOP unit, mode switch, operator panel board (on door), teach pendant and cable, board behind buttons (on door) and still get the same faults. I also had an electrician check it over and spoke with FANUC. If anyone has any information that could help would be greatly appreciated!

  • Whenever you buy a new controller, the board above comes with factory jumpers, which you take out and replace with your door or e-stop wiring. To make sure it's not a wiring issue, you unplug the e-stop / door wires going into the board, and replace with a jumper. This will "fake" out your safety system and pretend everything is good. If you are still getting an issue after doing this, you know the issue is on the board. If you are not getting the error after you do this, then you have an issue with your door / estop wiring (maybe loose connection, short, etc).

  • Thanks for the responses. I ended up having to fly in a technician with a new E-STOP unit and servo amp, after installing these parts the faults finally cleared. We then swapped in my old spare parts until we found a combination of E-stop and servo amp that would not generate faults. Out of 4 spare E-stop units and 3 servo amps only 1 of each was useable. I had tried swapping in these old spares before but must not have had the correct combination to make it work. If you have an older robot like me, keep a spare E-stop unit and servo amp handy or you could be down for a while. This same problem happens at least every other year for the last 10, very expensive and frustrating!

  • I'm having the same set of symptoms right now, but my faults clear easily. Only problem is, they clear when I close the door, or replace the door circuit with jumpers. That's obviously not an acceptable solution, as I need to turn the servos on to teach the robot with the doors open, and the final cell needs to function this way as well, for touching up points, backing the robot out after a crash, etc.

    Am I really looking at swapping out hardware to fix an issue that should be a system setting in the software, or a dip switch somewhere on a board? Every other robot I've worked has allowed jog with the fence open, but a Tech we had here to look at the problem (who also sold these robots to the customer) said that having the fence closed in order to jog is normal... two other Fanuc installations done recently within the same section of the same factory happily allow jogging with the fence open though...


    • Helpful

    with the older robots the aux contacts on the redundant estop unit fail, these can be replaced with off the shelf replacements. if they are faulty you will get SRVO -21 alarms, big issue on RJ3 controllers. Also occurs on RJ2 where the coils in the redundant contactors oveheat and stop the contactors operating.

  • Thanks for the replies, I had no idea there were any responses, I didn't get any notifications.

    We found that someone had made an attempt to rid the robot of the T2 feature that had messed everything up. Removal of a couple of wires on the selector switch caused the system to not supply power to the correct circuits when switched , despite displaying the T1, T2 mode correctly on the UI. :/ The joys of purchasing old used robots with no manuals...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now