VKRC1 to KRC1 conversion

  • Ok, after looking around I've found that changing the software and the keyswitch on the KCP should do the trick. Also the KRC1 uses X11 connector, but I have the XS2 on my controller. The XS 2 is already bridged to bypass the security gate open error. So what will happen if I go ahead with the update?

  • This post is taking a turn. This will be a blog about making a VKR125/2 TJ with a VKRC1 controller to do milling jobs, possibly with a 7th axis rotary table. I hope there will be people who can help me out in making this thing work, and also to have step by step instructions for others who would take on a task like this.

    This is how it went this far:
    1. Bought a used robot from ebay
    2. Wait for it to arrive, in the meantime ensuring my brother that I'll do everything to make the robot run, without prior knowledge of how they work, ok, maybe some from reading up on the forums, but somehow omitting the warnings, that KRC1 and most of all VKRC1 controllers are a difficult task.
    3. The robot arrives and in a few minutes, by help of a tractor, we load it onto the porch where we covered it for the night. The next day we find out that our lorry doesn't fit between the legs of the pallet that it arrived on.After numerous ideas of how to get the robot in the shop, we carved out the legs of the pallet. Finally we can start the robot up and make some moves.
    4. Connect the robot to the controller with the DATA cable and the harting cable to the X20 socket. Connect the KCP to the controller via the X19 socket. Connect to power. Start up the controller.
    5. Windows load screen freeze.. restart... VxWorks load screen freeze... restart... this a few times, and it's ON. Loads of errors, all in German. Change the language to English from one of the menus.
    6. Switch to manual mode. Chose jogging the robot by status keys. Set the movements to separate axis control. Push the dead man switch. Try to jog A6. Nothing happens. Active commands inhibited. Emergency gate open, and other notifications pop-up. So, without prolonging this post to much this is how we got it to work:

    1. Bridge the XS2 plug. We have done this by cutting the wires from the bottom connector and connecting them as is shown in "circuit.jpg" attached file. In hindsight this is not such a good idea, because if I want to convert it to KRC1 then I'll need to change the wiring to match a X11 connector, so if you do this maybe put name tags on the cables. (All the files listed in this post are from the forums, and some are downloaded from web-archive of the kuka site.)
    2. I've taken apart the PC of the controller and cleaned it and put it back together. Applied some contact spray on the connections, carefully removing dust and buildup.
    3. Found an old 5 pin PS/2 keyboard which you can connect to the PC. The port is located on the top of the case. When VxWorks starts keep pressing the SHIFT key to enter Windows. There should be an installation folder on the D: drive for VxWorks. I've reinstalled it with the least drivers. So until I don't need Profibus, DevNet and the like, it wont give me configuration errors. Also select your robot type and mounting type.
    4. This time VxWorks loads up fast. We made a CD with the KEYFILES folder to enter expert mode. (keyfiles are attached, and also found on one of the forums). Expert mode is needed to load programs into the R1/Folgen folder. Entered the robot serial number, and it worked. The robot can be jogged.

    So this would be it for now. We have a long road ahead of us. First I would like to convert the controller to a KRC1 and beef up the hardware as much as I can. As I understood, it can handle 256 Mb of RAM (maybe 512?). Also I need an installation of KSS that my hardware can run. Have to check the processors specs.

  • Hello, mbalazs

    I think You want to convert this robot to KRC1 to use some kind of software tool that is specific to KRCs, right?

    Because, if not, you can try to write your own milling routines with VW_User, I think.

    Enviado de meu SM-N910C usando Tapatalk

  • massula: Hello! No, and I'm not sure what you are referring to, but please tell me what software you are talking about.

    We have successfully anchored the robot to the floor with ancient Egyptian techniques, moving and lowering the robot 1 cm at a time using levers.

    Now if anyone could help me out with kr125/2 CAD files, like .mtd or .step would be great :smiling_face:

  • Mbalazs, unfortunatelly, I don't have these CAD files.

    But in the software side, I think I can help a bit.

    But I need to know why You want to convert this robot to a regular KRC1.

    And what is the KUKA software version that came with the robot?

    Enviado de meu SM-N910C usando Tapatalk

  • Thanks massula

    The reasons I want to convert it are, for one, I would like to have the additional modes besides T1 and AUT EXT, and I would like to have the extended support that gets a krc1 controller from the community. It seems to me that there is more knowledge on krc1 s. Also I would like to get to a point where I can run the robot from an external PC in near realtime.
    As for the sofware I have a V 3.3.5

  • Today we've tried out a .src that was generated with the help of KUKA|prc /grasshopper/rhino, all trial versions. It run without problems in T1 manual mode, but couldn't get it to work in auto mode, because VKRC's have auto external mode only. After a little search on the forums on how to get a VKRC to run in auto mode I've found this, by tommylight, to be the most promising: https://www.robot-forum.com/ro…r-tips/msg77057/#msg77057

    This will be the next step we'll take.

    The error we get when switching to ext aut is: mode inadmissible E2

    Edit: another project would be to connect the controller to a PC and use CWRITE/CREAD to control the robot. I have an MFC card and an INTERBUS card. Which one would be better to use? Does CWRITE/CREAD setup differ in VSS from KSS?

    Edited once, last by mbalazs ().

  • Mbalazs, You can't have AUTO (or EXT) and E2 at the same time.

    So, while in AUTO, you should unplug/cut E2/E7 jumpers.

    If You want to control the robot from a PC, you should go with MFC, but I've never used CWRITE/CREAD with VSS.

  • I've cut the E2/E7 jumpers and it still doesn't work. The message is : HCU Active status required. Also I have a Check safety logic. Emergency brakes during timeout occured, that I can't aknowledge. Does anyone know what can cause this?

  • Ho un problema simile con un VKRC1 con X2 che genera automaticamente un errore di sicurezza per l'operatore, vorrei chiedere, se sei stato in grado di risolvere il problema e se mi può dare qualche suggerimento su questo grazie.

Advertising from our partners