iiwa_stack ip configuration issue

  • Hi everyone,


    It turned out that our KUKA Windows OS was corrupted, and we had to restore the image files. Thankfully, I found a very helpful WIKI for configuring KUKA and ROS online. There was just one issue while following their instructions to set up the IP of the KUKA and the Sunrise Workbench 1.13.


    I used a separate Windows laptop to configure the Sunrise Workbench via port X66 on the KUKA cabinet, and the KONI port is connected to another ROS PC. However, there seems to be a problem with the connection between the Sunrise Workbench and the KUKA cabinet, which makes the configured IP always highlighted in red during the installation process in the Sunrise Workbench. I wonder if anyone has a similar issue or has any suggestions/insights in case I did anything wrong.


    I have set the static IP and subnet for those three PCs:

    • The Sunrise Workbench laptop's static IP is 172.31.1.150, and the subnet mask is 255.255.0.0.
    • The KUKA cabinet Windows PC's static IP is 160.69.69.69, and the subnet mask is 255.255.0.0.
    • The Roscore in Ubuntu PC's static IP is 160.69.69.100, and the subnet mask is 255.255.255.0.


    When I pinged the KUKA cabinet IP 160.69.69.69 from the ROS computer, I could receive a sequence of responses. However, the KUKA robot's PC with the default IP 172.31.1.147 always gave a time-out response when I pinged it from my Sunrise Workbench laptop. The IP was also highlighted in red after I clicked "install" in the StationSetup.cat. I'm not sure if this is caused by my IP settings, but I followed the WIKI to set up everything. I also tried to disable the wireless adapter and firewalls on my Sunrise Workbench laptop while synchronizing/installing the packets, but they still couldn't communicate. If anyone has any suggestions or potential solutions, I would really appreciate it!

  • in order for nodes to be able to communicate, they need to have compatible network settings and those three are simply not compatible.


    1. subnet mask must be the same on all of them

    2. LAN address must be the same on all of them

    3. node address must be unique on all of them


    in your case:

    1. masks 255.255.0.0 and 255.255.255.0 are not the same. mask determines how IP address is viewed (where the split between LAN address and node address is)

    2. LAN address is first part of IP address (as determined by subnet mask) and 172.31.x.x, 160.69.x.x and 160.69.69.x are not the same. this is part of IP address that corresponds to set bits in subnet mask

    3. node address is also determined by subnet mask (this is the lower part of IP address, corresponding to mask part with zeroes). but while this part of IP address for the three nodes is unique, (x.x.1.147, x.x.69.69 and x.x.x.100), the size of fields do not match due different subnet masks.


    nodes with mismatched network settings may still be able to talk if additional resources are available and correctly configured (bridge, router, ...)

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hi Panic Mode,


    Thank you very much for your insightful suggestion! My current issue with JAVA communication seems to be occurring between my Sunrise Workbench computer and the KUKA robot via port X66. By default, the KUKA robot has its own static IP address: 172.31.1.147 with subnet mask 255.255.0.0, and my Sunrise Workbench laptop has set a static IP address of 172.31.1.150 with subnet mask 255.255.0.0. These two devices seem to follow the communication rules you suggested, but please feel free to correct me if I have missed anything. However, when I proceeded with the installation process for the first time, I still got a red error message.

    Error with IP address 172.31.1.147 - KUKA Robot Forum - Robotforum -  Support and discussion community for industrial robots and cobots


    Thank you,

    Dylan

    Edited once, last by dylan96 ().

  • ok so now you have compatible network settings (hopefully this is assigned to LAN port and not to your WiFi adapter or one of virtual ports).


    but... those are just the settings...


    for connection to work, more is needed. for example you also need a known good network cable and it need to be connected to correct ports. if that is also good, you should be able to ping robot KLI from your laptop.


    to check it, just open command line on your laptop and type at the prompt


    PING 172.31.1.147


    if that is also good, then (in theory) using SWB to transfer project should work too. it is unfortunately impossible to tell if that is really end of it or more troubleshooting steps are needed because number of things could still go wrong and each step needs verification.


    for example it is conceivable that robot controller was already told to use different network settings. or that something with the Sunrise is not right and needs new image, or that image being loaded is corrupt or that recovery stick is corrupt or USB port is busted (intermittent) etc.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hi Panic Mode,


    A very strange thing just happened to me. I was able to successfully ping the robot and install the packages in Workbench the first time, but once it rebooted and I started to add other packages and synchronize the settings in Workbench, the robot couldn't be pinged and connect with the Workbench anymore. This is very strange. Have you ever experienced a similar issue before?


    Best regards,

    Dylan

  • hmm... that is odd. i would check the project to verify that applied address is the same. normally 172.31.1.147 is the default IP and one can change it when deploying project. but as i recall this should be a deliberate action by the user.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Super strange! However, even if the IP setting changed in Workbench, I think I should still be able to ping the robot with 172.31.1.147 from my other computer as long as its static IP is set correctly, right? I'm using IP: 172.31.1.150, and subnet: 255.255.0.0 in the Sunrise Workbench computer. But it just can't receive any response from the robot when I ping it after the first time installation in Sunrise Workbench :frowning_face:


    My guess is after that first time successful installation from the Sunrise Workbench, it changed my laptop's network setting somehow and broke the communication. I did try changing to another computer with Sunrise Worbench and repeat the process, it can ping the robot in the beginning and install packages successfully the first time. After that, it just disconnected, no responses anymore when I ping or synchronize...

    Edited 2 times, last by dylan96 ().

Advertising from our partners