Disable EtherNet/IP on YRC1000

  • Hi all,

    I recently set up my YRC1000 with a Allen Bradley PLC, and was using CIP Safety to externally stop the robot. However, I now want to disconnect my PLC from the controller, but every time I either unplug the ethernet cable or turn off the PLC, I receive "Alarm 4911: Safety Fieldbus Comm Not Built," preventing me from being able to move the robot no matter which mode I'm in. How do I reset my robot to no longer look for the safety fieldbus?



    • Helpful

    In Maintenance mode, in SAFETY security level, go to SYSTEM, SETUP, OPTION FUNCTION. Cursor down to Ethernet I/P (CPU board). Press SELECT on DETAIL. Cursor down to VIRTUAL COMM and press SELECT on SAFETY to change the setting to VIRTUAL.

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

  • ....by chance, is there a way to get around this same '4911' fault on DX 200? I went into Safety Mode but the path above for YRC isn't the same as DX 200.

    Cheers! :top:

  • Found the path in MAINT Mode (SAFETY Level), just under OPTION BOARD instead of OPTION FUNCTION. CP1616 is identified as NOT USED now. Profisafe Virtual Comm is set to VIRTUAL although it always seems to revert back to SAFETY after I reboot back in Maint Mode or after a Flash reset. Long story short, we are trying to move 2 DX 200 MH 180 robots to our repair location from their old cell but need to reposition one of the robots before travel to teh shop (currently sitting in HOME position). The ethernet cables were cut rather than disconnected prior to the move and we received the Safety Fieldbus Comm Not Built alarm after we powered up the forementioned robot without ethernet. The moment we depress the DMS on pendant, this alarm pops up. Thought there would be an easier way to disconnect Safety Fieldbus rather than getting a new cable made but I am still getting this alarm. Tried firing up normally under Safety Password and under Safety SIG Board Allocation, changing all the relevant SFBIN Inputs to NOT USED on a whim but no luck there either. Tried different jumpers in Safety (MXT) card too but same fault. Anybody have any ideas on how to simply get robot power and control for us to move robot into a good transport position while disabling SAFETY FIELDBUS??

    Cheers! :top:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now