Resurect a kr150L150 with KRC1 [OVERCURRENT ERROR AXIS 4]

  • Hello everyone !

    I am french so excuse my not perfect english.

    First of all, thank you all for this amazing community, it already helped me a lot in rescuing my new (old) robot.

    As introduction : I work with wood and am passionate by technology (programming, electronics, mechanics...) but I don't have any experience with industrial robotics.

    I have the project to use a robot to do some wood carving/milling for making some carpentry assemblies and other stuff involving a spindle attached to the robot.

    So, 2 weeks ago I bought an old kr150L150/2SP with a KRC1 controller and KCP. The robot was not used the 10 last years.

    What I all already did on it:

    - backup the original HDD (clonezilla with IDE to USB adapter)

    - change the big capacitors of the motherboard so it POST again

    - install a new (old) HDD, the original one made annoying sounds during backup

    - partitioning, formatting and clean install of Windows 95 and KSS 4.1.7 following the Kuka manual (more or less, I did't use a CD but copied the install stuff on the D partition)

    - get the right MADA folder to use by asking Kuka with the serial number of the robot (they answered within 2 hours! nice)

    - get the 6 axis to move in manual mode

    - get the robot down the pallet and bolt on floor

    - turn an aluminium dial gauge adaptor to make the mastering

    - mastered axis 1 - 2 - 3

    And now I am stuck.

    In fact the next day a made the first movements, as I wanted to try again, I got an "over torque on axis 4" error just after pressing a movement button (axis 1 if I remember) and having bad sounds in the robot. I checked the hardware stops (not in cause) and after 2 or 3 trials it worked again correctly.

    Some days after : same thing.

    And yesterday I got an "overcurrent on axis 4" error and this time I got to restart the whole krc1 to reset that (if someone have a faster solution to reset it...).

    After that, it restarted to work correctly so I could master axis 1 to 3 and as I wanted to move 4: "overcurrent"...

    What I did yesterday :

    - made a try with motor 4 powercable disconnected -> "got over torque error" / can this damage the PM ??? I hope no ;(

    - swaped cables of motor 4 and 6 -> error still on axis 4

    - measured resistance of motor coils and brake in the connection box -> seems OK (similar to the other motors)

    - took out and opened PM6-600 and checked the output short relay opened correctly -> seems OK / not understanding for what purpose this relay is, if someone have an explanation...

    - swaped axis 4 and 5 connectors on PM6-600 -> error still on axis 4

    - reprogrammed the current limiting EEPOT according the kuka manual (with swap of the programming jumper) -> not sure something happened since the UI tells nothing...

    Now, whatever axis I try to move, I directly get the "overcurrent on axis 4" error without any sad sound in the robot.

    I now decided to ask for help since I feel stuck with this problem.

    So everyone is informed : I don't have any access to Kuka spare parts to make swap tests. I am equipped with some electronic tools : oscilloscope, protocol analyser. I am ready to put hands in the PM6-600 since I don't want to spend the price I have bought the whole robot to replace this unit.

    Thanks to everyone that read until here and that could give me some tips to move on.

    Wish you a good day. Tobias.

  • AD
  • axis over current indicates problem in one or more of:

    1. with motor,

    2. internal cable harness in the robot arm

    3. robot power cable (X20-X30)

    4. cabinet motor interface (drive to X20)

    5. drive (PM-600)

    troubleshooting is supposed to narrow it down....

    for example if you unplug motor connector for that axis directly at the drive (PM-600), do you still get over current fault? if so problem (at least one) is internal to PM-600.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • This is the fourth PM6-600 I know of that throws overcurrent errors specifically on A4, regardless of any motor and cable swaps, and if I remember correctly, most forum posts asking about this problem refer to A4 as well. Makes you think, ain't it?

    When testing, remember that:

    - KRC1-era robots control motor brakes in two groups of A1-3 and A4-6, can't open them individually and need to energize all motors in a group to be able to move just one, as the motors have to hold the axes in place when brakes disengage

    - encoders have to be swapped when doing motor cable swaps, this is best done at the RDC (robot base, where the thinner cable from KRC goes in), otherwise the robot will go bonkers for a split second, then e-stop due to excessive position error

    - it is safest to swap A4 and A6, both have no mechanical limits to exceed by accident

    - A1-A3 are influenced by gravity and/or the counterbalance as soon as the brakes are released, but A4-A6 aren't, so you can leave a motor disconnected during jog testing of the other two (technically speaking, they are influenced, but the force is so low it can't backdrive the harmonic drives...)

    In any case, it looks like you already ruled out any cabling, motor or drivetrain problems by swapping stuff around and/or leaving the A4 output completely disconnected and still getting the error. (BTW, no, you won't damage anything by leaving outputs unconnected)

    On mine, which did the exact same thing and resisted the exact same attempts at fixing it, I swapped the power PCB along with the IGBT packs - I got two untested PM6-600 units very cheap on an auction site and cannibalized one of them. This helped, ruling out any problems in the logic board (on top of the power board) or the IGBT driver cards (in the middle). Before I found the donor units, I started probing stuff, both off- and online. What I managed to figure out is that the current sensing transformers on A4 looked fine, so it had to be one of the auxiliary components in the sensing circuit. This might be different for you. Then again, with this being yet another A4 overcurrent, I suspect a design fault in the power PCB causing a consistent, repeatable problem.

    Now, remember, poking around in a powered, half-disassembled PM6-600 while it's connected to the robot isn't the safest thing to do even with personal protection equipment. Don't even think about trying it without *proper* PPE. You can and most likely will die if you do this. There's no galvanic isolation from the mains input in a PM6-600. That huge capacictor bank in the middle is charged up to ~550V DC (thankfully, it does discharge very quickly when power is cut). It will kill you a hundred times over without even noticing any extra load and keep running in front of your slightly smoldering, spasmodically twitching corpse. At minimum, buy certified insulated gloves. They're surprisingly cheap for how much safety they offer. SECURA ELSEC gloves should be readily available in France, for example. Use multimeter and scope probes with insulation running up to the very tip, to avoid shorting stuff. Get a grinding face shield (the ones designed to stop shrapnel from an exploding angle grinder disk, not the flimsy COVID things) and a welding apron, for when you *do* short stuff and get a splatter of the molten probe in your face. Figure out how to power and ground your oscilloscope to safely measure mains circuits, so you don't fry it. You can bench-test devices like this if you know what you're doing (guys at KUKA had to do it somehow), but it's no joke. Be safe.

    And before you go any deeper, just look on eBay or whatever local French auction sites there are for cheap PM6-600s as replacements or part donors. They do show up.

  • this is why i suggested as probably quickest and safest tests is to just disconnect A4 motor directly at PM600 and see if the problem is still there.

    of course disconnected axis will not be able to move but thisshould help distinguish if the problem is in the PM600 or not.

    and if the same overcurrent fault is still shown (even with no cable or motor for that axis connected to PM600), then problem is in the PM600 itself... so spolution is to replace or repair the PM600

    but if the fault is NOT due to PM600, everything else should be able to function (enabling drives, jogging other axes) and ... there will be no overcurrent fault displayed any more (other faults may still be there). in this case check the wiring, is the internal wiring between PM600 and X20 ok? check for corroded, deformed, pushed out contacts, on each section. check if the motor connections to PM600 are in correct order for that robot type. brake circuits are jouned check brake circuit resistance with and without affected motor. it must be lower when all three motors are connected, disconnecting any of the three motors in the group means fewer brakes are connected in parallel so measured resistance will increase. if there is no change, brake circuit is not ok so replace that motor.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hi and thanks a lot for your quick and detailed responses.

    I really appreciate your testing advices and safety warnings. I don't think I will make any measures with disassembled and powered PM. I hope I can find the problem juste by measuring components offline ?:/

    I really suppose the PM600 is in cause since the test I made by swapping axis 4 and 5 connectors on it immediately triggered the over current fault still on axis 4. To be sure I juste made the unconnected axis 4 cable (but shorted cable position pins) test and still same fault.

    I also measured the resistances of the motor coils directly at the PM connector (disconnected from the PM of course) and it seems consistent between axis 4 and 5 (about 2.1 ohm on each coil).

    So it sounds similar to enleth's problem and I also suspect the current measurement circuit. What I find interesting is the way the problem became gradually badder : over torque faults sometimes to over current every time. I am very curious to know how the torque is measured. Because if it is with the same current sensing circuit, this errors would be consistent and there progressive graduation would perhaps indicate a slowly blasting component. A capacitor ?

    Do you think there is some possibility to find detailed schematics of the PM-600 ?

    Thanks again for your help. Tobias.

  • Hello,

    this afternoon I measured resistance on the current transducers legs and found out that one of the axis 4 ones had open circuit between + and - and between M and -.

    This wasn't the case on the other transducers. So I suppose I do have a track.

    I will replace this unit and let you know.

    Have a nice day. Tobias.

  • Torque and current are directly related on synchronous servo motors, so the current measurement is in fact the same as torque measurement. What you found looks like it could be the cause.

    I'll try to dig up the PCB from my old broken PM6-600 and check the A4 transformers. Which one of the two is broken on yours? They should be labeled I11 and I12, I think. I'm suspecting there might be something causing an intermittent open circuit between the transformer's secondary and opamp inputs on the logic board. Some current transformers are susceptible to damage from operating with no load on the secondary. I'm not sure if that applies to the type used in PM6-600, though. EDIT: this might be a bit more complicated, as those are active transducers (LEM LE 55,…_datasheets/la_55-p_e.pdf ) but the internal schematic suggests they could still be vulnerable to high voltages being induced in the secondary with the output disconnected.

    PM6-600 schematics are available online if you know where to look. I have them, but I'm not sure what the forum policy is for uploading things that certainly weren't meant to be published in the open and probably got leaked at some point.

    Edited once, last by enleth ().

  • Hi,

    thanks for the confirmation about torque and current. I didn't mention it yesterday, but the transducers indeed have internal electronics. I opened the doubtful one and measured the coils (there are two in series) and one seems open. Why did this happen ? I don't know and I hope it's not another problem that triggered this failure. BTW, it's the most bottom transducer that is involved, I did't see any label for it on the PCB.

    Now waiting for the new transducers. I'll let you know if I reach something.

    enleth : about schematics, would you accept me to contact you in MP for that ?

  • Hi!

    So, some days ago I changed the faulty current transducers and tested again and....... same error ;(||.

    Yesterday, I studied the PM6 schematics and found out that there is a IUBER fault signal not coming from the current measuring circuit but from the IGBT driver boards. This signal is generated form the IGBT driver chip by measuring the desatauration voltage. I did not exactly understand how this work (data sheet of the driver chip -> BUT I just measured the IGBT the way they tell in this video (

    ) and found out that 1/6 of the output is shorted.

    Seems that I have to change this component... but I still have a lot of questions :

    - Can this fault damage the current transducer ? The faulty IGBT is on the middle line, the one that do not pass through a transducer...

    - Can this fault have damaged other components ? Or is the design of this PM6 unit robust enough ?

    - If it's the same problem that enleth described why is this frequently affecting axis 4 ? Because of it's position on the heatsink ? :/

    - And last but not least : where will I find this IGBT (6MBI25LB-120) since they seem to be no more produced. Would someone have spare or salvaged ones and be willing to sell one or two ?

    Wish you all a good Sunday !

  • Hi !

    I received and mounted a new (but used) IGBT (ordered on RGB Elektronika) and ....

    the robot works again ! Hiiiiihaaa !

    So I could terminate the mastering and make the first manual "linear" movements. Already impressing me a lot... :huh:

    I am a bit confused about the spring effect the arm does when a movement stops suddenly (about some millimeters). Is this normal ? Or a problem of play in the gears or in the counterbalancing ? Anyway, I will make some tests when I will gets hands in programming and perhaps start another thread for this.

    Thanks again for your help.

  • Hi, The Robot is bolted on ground. Although the concret thickness doesn't meet the kuka recommandations...

    Nothing is attached to the robot yet.

    It's seems to be related to the stiffness of the robot, but since I don't have any previous experience with robots, I can't judge if this is just normal.

    Perhaps I should move on with programmed movement tests.

    I let you know.

  • Sudden stops when jogging manually are jerky and springy because the robot has no way of anticipating the need to decelerate before a stop. Doubly so when you let go of the dead man's switch on the pendant while the robot is in motion - if I understand KRC1's logic, this is a category 0 stop as the drives contactor opens and motor brakes slam shut with no advance warning whatsoever. The arm will get jerked - and that's an actual term in physics - by inertia and there's nothing you can do about it, several hundred kilos of steel and aluminum swinging on a long stick can't be stopped instantly and can't be perfectly rigid.

    You can start being concerned if you see the same problem with programmed movement.

  • Hi, thanks for this explanations.

    As you said, with programmed mouvements the acceleration ramps are really smooth and I don't notice any jerk.

    I will see how it works when I'll get a spindle attached...

    BTW : I had another issue last week : the cabinet suddenly stoped working and the breaker had tripped. When rearmed I just got a huge spark in the PM6 power supply...=O

    Luckily it was only the over-voltage protection varistance just after the rectifier who caught fire and probably got shorted. Apparently this components get aged.

    I took advantage that the PM6 was open for 5th time to change to 2 big capacitors of the power supply. Not sure if this had any sense ?

    Everything is back to normal for the moment.

    Have a nice day. Tobias.

  • tmuthesius I just had the same thing happen to my KRC1. Did you find out what caused it? And were you able to repair it? I don't have a schematic for that board, but I am suspicious that a pair of dead batteries (computer backup power) might have caused too high of a current flow. Looks like that board generates the 27V rails that charge the batteries


  • hmmm.... how did you get clue like that? reason dead batteries are called 'dead' is because not enough juice left in them and they cannot deliver high current. when batteries get old, internal resistance increases and acts as a current limit. this causes large voltage drop too.

    but this high internal resistance is not just there when drawing current from battery, it has the same effect when trying to charge battery.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Yes, typically batteries fail high impedance, but not always (loose lead plates and internal corrosion can cause low impedance failures)- but seeing how there are two in series, you're most likely correct that the impedance is high and unlikely to cause a failure in that direction. Alternatively (again, just stipulating - don't actually have a schematic) a high impedance battery on a current controlled charging circuit could cause a rail to go beyond expected voltage. (Yes, it's a total BS guess- but i'm looking for reasons why [what i think is was a MOV] the component failed). Time and heat can also dry out electrolytic capacitors, but they look fine externally. Power supplies often fail because of inappropriate or damaged loads attached to them, so that was my first suspicion. Open to alternative ideas as well.

  • you are correct, batteries can fail to low impedance too but this is far less likely as even cells within one battery are in series. don't think i have ever seen one but... i have seen plenty of batteries that fail to high impedance.

    yes that looks like is is/was an MOV. can you post more pictures? top and bottom of the PCB, and some nearby components including their rating/values? collected dust could lead to problems too. Alu capacitors are least stable type of capacitors, they lose electrolyte and capacitance values becomes lower, can short as well. even dry capacitors like paper etc. decay over time as the dielectric decays, but that is on a significantly longer time scale.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hi, sorry for my late replay.

    I my case, the component that caught fire was a varistance (mounted in // after the rectifier) intended to catch high voltage spikes from the main (if I understood this well).

    I read somewhere that this components have a limited lifetime because of the stress caused by high voltages and often end in short circuit failure.

    In my case (and regarding your picture, I would say that it's also your case), I am assuming this failure caused the one or two thermistances mounted in series just between the rectifier and the varistance to blow up because of over current.

    I changed all 3 components and everything worked again.

    Not sure if I am allowed to send direct links to Farnell here, but I the case you are't able to read the components values, this are the one I ordered :…57213?CMP=i-bf9f-00001000…13006?CMP=i-bf9f-00001000

    Hope this can help.

    By the way, here at the workshop, we managed to interface the robot with rhino + grasshopper + kukaPRC and to make him draw something.

    Here is a little video of this :

    At the moment I am doubtful about precision, but I will write a more detailed message about this ASAP.

    Have all a nice day.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now