Manipulating KUKA KRC4 safety values with PLC through El6695-1001

  • We're trying to manipulate the safety data in KUKA KRC4 with an OMRON NX PLC with Kuka el6695-1001 as a bridge. The communication with FSoE (EtherCAT) is working and we're able to display desired outputs from the PLC as inputs on the KUKA SmartPAD.


    The problem is that the pre-assigned values from the PLC does not update the reserved safe inputs on the KUKA KRC4.

    Edited 2 times, last by iOdden ().

  • AD
  • iOdden

    Changed the title of the thread from “Manipulating KUKA KRC4 safety values with PLC through El6695” to “Manipulating KUKA KRC4 safety values with PLC through El6695-1001”.
  • "The problem is that the pre-assigned values from the PLC does not update the reserved safe inputs on the KUKA KRC4."


    that is still very non-specific...which value(s) specifically?

    do you have safety configuration using FSoE actvated after project is deployed?

    which side of the bridge is connected to KRC4 and which one is connected to PLC?

    are you using correct DTM (one from Kuka)?

    are you seeing red or gray banner on smartPad? any messages?

    what messages you see on PLC side?

    did you map the safety signals on PLC side and use them inside safety task?

    is PLC safety task turning on reserved bits as required per SafeOp manual?

    do you see those bits on robot side (in the diagnostics)?

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • - "is PLC safety task turning on reserved bits as required per SafeOp manual?"

    This is what we're trying to figure out, trying to set the reserved bits as required per SafeOP.

    I can see the reserved bits in diagnostics, but the values does not update/match. (attachment)


    The KRC4 is connected to the primary, and the PLC is connected to the secondary.

    I assume the connection_ID should be the safety ID which is found in WOV? (attachment)


    The DTM file for the Kuka is correct.


    The messages I'm receiving on the SmartPAD:

    Safety communication established

    KSS15003

    Ackn.: Safe device communicarion error {device}

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now