Advertising

SRVO-050 Collision Detect Alarm

  • I purchased a used FANUC ARCMATE 100IB WELDING ROBOT WITH RJ3IB control about a year ago with hopes of getting our feet wet with some automation

    Last time I used it I was able to run a simple movement program but had to hold the deadman switch on the pendant in order for it to work. The controller didn't have the key switch for selecting auto/ 1/2. Then I got busy again and the machine was set aside. I found a key switch recently, installed it and fired it up and had the battery alarm error on group 1 axis 3. I replaced the batteries in the base of the robot. 3 of them were low voltage (1.4V) 1 battery was completely dead.

    I got the battery alarm to clear but continued having a motion alarm, Motn-049. It sounded like I needed to master and calibrate. I tried but it didn't seem to be working. I later realized I was nowhere near the 0 deg on any of the axis when I was trying to do this. I now found a manual on this site that can walk me through it.
    I continued trying to get past the calibration issue. At 1 point, I rotated axis 3 to its hardstop. It threw an error and I was able to reset and jog it off. I messed around a few more hours but eventually shut the system off and went home for the day.
    The next day I fired it up to try again and I guess I took 10 steps backward.. Now, I cant move anything. I'm in Joint mode and any axis I attempt to move causes axis 3 to drop 1/2" and I get a collision error. I think it's a srvo-050 G:1 A:3. It doesn't matter what axis or direction I try to jog, J3 keeps moving negative each time.


    Any idea what may be causing this?


    Also, alot of the documents I'm looking at cite doing a cold restart when changing variable. However, I don't have that as an option under my function button.
    Is there a proper way to restart this unit vs just disconnecting power to it?


    Thanks in advance.

  • AD
  • I think cold start only shows up under the function button when you have booted up with a controlled start. Also, I've only cycled power for variable changes. I don't recall doing any that specifically required a cold start. Which variables are you looking to change?

  • Are you getting any other alarms besides the SRVO-050? Check the history [F3] in the alarm menu.

    Some ideas to check:

    Check the all connections regarding axis J3, could be dropping due to a missing phase if it happens as soon as the brakes release. This is common when the RM1 connector at the base of the robot is not fully seated.

    If it takes a few seconds before the it alarms, the brake may not be releasing and as the robot tries to hold position, it starts to fight the brake and eventually alarms. It might drop slightly due to some weakness in the brake.


    A short cut to a Cold Start is to hold in/down the Fault Reset when powering up until it mentions cold start on the TP screen during boot up.

  • Skooter and Hazard, thank you for your responses. I must not have my notifications set correctly because I didn't see that either of you responded till I logged back in this morning.


    Hazard, I was trying to get the robot mastered and the maintenance manual I'm using says to "perform a cold start" after several of the procedures such as releasing brake control


    Skooter, I just powered the unit back up and will give a look at the alarm history. When you mean "release the brake" when exactly does that occur. I push the deadman in on the TP and I hear a click. I can push the Shift key in. As soon as I touch any of the Joint buttons, positive or negative (J1, J2, J3 etc.) is when I get the SRVO-050 alarm with actual negative movement in J3. There isn't a time delay like it's pushing against the brake

  • So I inspected the connections at the base of the robot and re-seated them.

    I power up and allow the control to boot. The active alarms are:

    1) SRVO-003 dead man switch release this one isn't an issue

    2) INTP-348 (SGLSTEP2, 32) Write I/O I'm not sure what this is

    PRIO-104 Device is off-line

    3) SRVO-002 Teach Pendant E-stop, not an issue here

    4) SRVO-001 Operator panel E-stop, not an issue here

    5) SYST-043 TP disabled in T1/T2 mode


    All of the above alarms go away when I reset the e-stop, press reset on the TP, or squeeze the deadman.


    This morning, the first time I pressed a joint movement button I received the same SRVO-050 alarm. I reset it and tried again. This time I was able to move in the postive on J3. After a few seconds however I received a new alarm SRVO-310 ABC unexpected motion


    I can press reset but when I squeeze the deadman, I hear the contactors in the control box engage and then it sounds like a second contactor clicks and the error reappears. I can't get any motion at this point

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now