Using EthernetKRL for Realtime Communication

  • System Specs:

    KRC4 Controller with KR 6 R700 sixx manipulator

    WV5.0 build V5.0.9

    EthernetKRL V2.2.8.155


    I am currently trying to utilize EthernetKRL as a real-time interface to communicate my robot's position back to my external system. I am able to run my program in the submit interpreter for about 5 seconds before I get that my ethernet connection has been disconnected. I was hoping that the issue was just a memory error but it seems as though I am clearing my buffer.


    Error: EKI00010

    Ethernet is Disconnected.



    Any ideas or advice is much needed.

  • Place your Ad here!
  • that configuration is rather strange. i

    when EKI runs as server, then no client side settings are to be specified in config.

    also EKI is not a real time interface. that would be RSI.

    connection is created and closed by client, not server.


    looks like you are working on both client and server simultaneously. it is easier to battle one thing at a time.

    i would suggest starting with sample program that KUKA provides and do not change it until you get client side working.

    once you get smooth communication, then add more tags etc.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners