[SOLVED] C Controller - Only KAWASAKI logo comes up on startup

  • Hello dear friends

    I'm a newbie with KAWASAKI robots and It's almost 2 years struggling with two second handed robots each have a C40 controllers (1999). I just did the programming stuff and wiring External IO etc... We use these for "pick & place" in a really moisturized dusty industrial environment!!!

    These recent days we had issues with IO signals, a friend of mine (who is an Elec Eng) said boards are dirty, full of dust, so we removed main board and IO board and made them clean [boards were off the controller for 2 days].
    When we put them back, on teach pendant we've seen a KAWASAKI logo followed by

    TP_Version : version T00L0K3J 99/11/19 20:29

    also with a keyboard.

    I've searched the whole forum, seen this post the most close to the issue:

    But I have no lead for this, would someone please help me?

    Reza Nili

    P.S. :
    AS Software Version: 300EK1J
    I do have a backup from the whole system before removing those boards (the "sample.as" file)

  • AD
  • Welcome to the forum.......... :beerchug:

    It looks like you have lost memory due to the removal of the CPU board.
    - This board requires permanent power source in order to retain memory.
    - This battery is attached to left side of 'rack' as indicated on the attached image.
    - Removal of the CPU has obviously disconnected this power source and lost memory.
    - It is also possible AS/SV may be corrupt to.

    Firstly, before anything major, you say you have a backup called sample.as
    Could you post this (you will need to change extension of file to .txt in order to post here)?

    We could either:
    - If you know the backup is definitely valid, then a re-initialisation and reload of the backup should return it.
    - Or carry out some further checks, will require laptop, KRTerm/KCWin and null modem cable.

  • Thanks for your reply dear Kwakisaki! :beerchug::coeuranime:

    Here's the attachment, the AS file.
    I've also tried catching its console with KCWin to use commands like LOAD But it only prints out, and doesn't accept sending characters... I don't know if I made my point clear or not!!


    • backup.as.txt

      (22.74 kB, downloaded 43 times, last: )
  • Quote

    I've also tried catching its console with KCWin to use commands like LOAD But it only prints out, and doesn't accept sending characters... I don't know if I made my point clear or not!!

    Ah, ok, I don't suppose you got a 'picture' of what was displayed, or can remember anything that was displayed?

    Right, looking at the backup, it doesn't appear that there's much in it as far as programs are concerned.
    - Would I therefore be correct that this robot is not currently being used as any type of production robot?

  • I don't have a pic right now but I remember it was just like its normal startup, I mean those lines that prints out when you turn the controller on.


    it doesn't appear that there's much in it as far as programs are concerned.

    I removed programs from the bottom, to protect the factory's privacy rights (so this won't make me fired by management :icon_wink:)


    currently being used as any type of production robot?

    So then... Yes they are in the production line, waiting for Mr. Kawakisaki's instructions to become revived! :icon_rolleyes:

  • Quote

    I removed programs from the bottom


    Ok, so there's little risk at this point and I therefore assume you can load them back in after then.
    Attached is a procedure I've just written by memory, so cannot 100% guarantee total accuracy of exact buttons/screens.
    I have access to a C Controller, so when I get chance (as these are now obsolete) I will make small video of initialisation and post it as a sticky in the manuals, tools and software section for future.

    At this point, you may aswell give it a go and see how it prevails, I'm expecting positive results.

    If you struggle at any point, then post back results, including any screenshots of errors, displays seen.
    Good luck....... :top:

  • Thanks, I'll do this in the couple days and will update this topic.

    Questions Sir... I read the PDF attached, you said FDD or PCMCIA will be required... Will be possible to run KCWin in step 14 (seems that controller OS will be booted)? And by FDD do you mean the device provided by Kawasaki that connects to RS232 serial port?

  • No problem, I'll hopefully have a video done on Friday as a reference.
    - I've been meaning to do one for abit, so with your issue, it's given me a 'kick'.

    C Controllers could either use FDD (Floppy disc drive.....Can you remember them) or the PCMCIA as a 'local' medium for immediate backup/reloading of data without the need of a laptop.

    But, yep, even though the Controller will be in an inoperable state after the initialization, the RS232 port on the front of the controller will be active.
    If you have ethernet on it, this will not be active but I can see from your backup, you don't have the ethernet version of CPU.
    So, you should be able to effect a reload via the software on RS232 that way also.
    - That way will be slower than PCMCIA due to the baudrate of the serial connection being at 9600.
    - But will work just the same.

    At the command prompt:
    >LOAD sample.as and enter.

    As the backup is of the robot, then during the reload, just answer/agree with any question that appears.
    The backup also contains the zeroing data of when the file save was taken, so as long as no mechanical disconnection has occurred with the motors/encoders then the zeroing should be all set too.

  • You're welcome.
    Kawasaki do not have a 'documented' procedure that I can find easy to use, so what I've done is to 'try and minimise' confusion by including some 'checks' as you go along.

    Part 1:
    Is just a generic re-initialization procedure which could be used to completely empty the controller at any time.

    Part 2:
    Is just a generic reload procedure, which could be used at anytime.
    For example if you accidently deleted some programs from the controller and you had a backup before.
    You could use the procedure to just load in over the top (not always the best way, but will work).

    Part 3:
    Is just confirmation recommendations.

    However, when I am using a full backup to restore information, say for a reason I can't quite bottom out.
    Then I would reinitialize and reload, as opposed to just reloading.
    But I would only ever reinitialize as a last resort and would try to effect a resolution without the reliance of a backup.

  • Problem Solved

    I just did what you told to do in the instruction PDF and it did work! you just saved a production line man!! :merci::beerchug:

    Also I did the "load file" procedure with KCWin way... everything was fine.

    I hope this topic will be helpful for others.

    Thank you
    Reza Nili

  • :partyband:

    Excellent, glad it's all worked out for you and thanks for feeding back the result.
    I'll pop this on as a 'locked and sticky', as it is an easy read, with a good example of how to post and the final result (thanks to you).

    Glad we could help...…..

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now