120P with RJ3 Need Your Help

  • Okay, I'm a newby to this forum that is looking for help in getting a Fanuc robot operational. Just a bit of FYI, I've been around the Fanuc CNC stuff from the old level 6 controls up to the brand new stuff. So, I do know my way around those, but I'm new to the robots. Awhile ago my boss picked up a P120 paint robot with a RJ3 control from an auction. This robot was in full operation with a paint line that was operated by 2 PLC's. I have all the old PLC stuff removed so we're back to the basic robot.


    When the robot is powered up, it boots up normally but when we get to the alarms, I get an INTP-315(PATRACK, 1572) Built in Exectue or INTP-315(PALTSTAT, 135) Built in Execute alarm. I'm not sure what these are let alone resetting them. Any ideas?


    The other alarm is LNTK-023 BAD TRACKING HARDWARE and SRVO-082 DAL(TRACK ENCODER ALARM). These alarms are because the paint track encoder is not connected to the RJ3. I have no idea where the encoder is or even what type of encoder the control is looking for. I did a bit of googling and found that the encoder can be set up in the control. Here's the steps to get there:


    1. Press Menu
    2. Cursor down to System, then press enter.
    3. Press F1, cursor down to Variables and press enter.
    4. Cursor down to Variable #75 $ENC_STAT and press enter
    5. Cursor down to Encoder #1 --- this is the track encoder settings --- and press enter
    6. Cursor down to #14 that says $ENC_EXISTS=TRUE.
    Here's where the problem is because if I try and change this variable to false to turn the encoder off, I get VARIABLE/FIELD WRITE PROTECT alarm. Does any one know how to get past the write protect alarm? Any info will be helpful.


    Don

  • Place your Ad here!
  • it its telling you there's a write protect it sounds like to me theres a setting that is preventing you from changing it. for example if you go into the details page for a specific program you can turn on or off a feature labeled write protect and it prevents programs from being altered until it's turned off. I use it to prevent people from changing my programs. At least that what it sounds like to me. I could be wrong but if Im not then you should simply have to turn that feature off. as for where it's located for the variables, i'm not sure.

  • Have you tried writing and executing a .tp program to change the parameter? It worked for me (different variable) on a past project. It would look like this:
    ENC_STAT[1].$ENC_EXISTS=0
    To get the instruction, INST>MISC>Parameter Name>$...=...
    Make sure the syntax is right and try executing it.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners