Buying a Kawasaki zx200s with missing cables

  • I found a good deal on a Kawasaki zx200s, cheap enough I could make my money back parting out/scrapping. I would like to purchase it. it would be my first robot really just excited to learn about it and i figure no better way to do so then getting a old machine running. I do have a background in metal working and machining and mechanics and a understanding of basic electronics so i am not completely ignorant aswell as a old shop that has 3 phase power and a forklift/machinery to move the bot. It comes with the robot, teach pendant and the controller, has not been ran in years, the guy who i am getting it from is a old timer that said that when he purchased it years ago all of the cords to plug everything were missing he got sick/life got in the way and lost the ability to finish the project. Is it realistic to think I could either find the cords used or make my own myself? What are some things to look for? Are the manuals available?

  • Place your Ad here!
  • MOM

    Approved the thread.
  • Just mentioning ZX200S is not really ideal, could do with knowing the Controller type too?


    Based on this, I could post the relevant documents but would not recommend making them yourself as they are heavily shielded.


    You would be best to locate a second hand dealer who has umbilicals.


    Here in the UK a popular second hand dealer would probably be able to sort you out (but it will likely carry a cost).

  • We’ll I picked up the robot

    D32f A901 is the controller model number

    Serial z0439

    Zx2000395 is the robot serial number

    Zx200s

    If you have any manuals or anything that could help me in this project please let me know. I’m driving 6 hours home from Michigan with it right now once I get back and unload it will try to figure out a better idea of exactly what cables I am missing. The controller states 460v aswell would it be possible to make it to run on 240v 3 phase? If not I can run the 460v have it in my building but would be easier 240v

  • You should have stopped off in Michigan at KRI (Kawasaki Robotics Incorporated) and tapped them up for information and cables and asked them about running on reduced supplies, I'm sure they would have assisted and you may have even got some freebies out of them.


    Kawasaki Robotics (U.S.A.), Inc. | Kawasaki Heavy Industries


    I would still get in contact with them anyway as that maybe the fastest way to get a solution as your in the US.


    The following screenshot is an image of the range of umbilical part no.s that I have for D32.


  • A quick google looking for those part numbers came back practically nothing, I will try Kawasaki in the morning hopefully they can help. Are the wiring diagrams available for those plugs? I understand it’s really not preferred to make cables but it may be my only choice, if the cables are not able to be found/cost multiple $1000s it’s not practical for me to invest that much into a robot that I still do not know if the boards are corrupted/fried etc etc atleast just for testing. Does Kawasaki sell/give out the manuals? I think would really help with setting up/trouble shooting

  • Well before you do anything else, you need those cables and power.

    Not much point in reading manuals if you can't get it powered with the correct hardware.


    I'll never endorse, recommend or support anyone to make their own cables especially where the umbilical's are concerned between Controller and Arm and then have to troubleshoot self induced problems with incorrect shielding, grounding, capacitances and impedances caused by the nature of making your own cables up.


    Attached is D Series Troubleshooting Manual which contains the references to the umbilical connections for D4x and D3x Controller and Arm configurations.

  • well I got the cables, actually ended up buying 3 robots, 1 zx200s with a d controller and 2 zx165u with what I believe are C controllers, they have a round plug for the teach pendants and the pendants are very simple only a few buttons. Have not messed with the zx165u but have put power to the original zx200s, I got it to boot pendant turns on seems it was previously used for spot welding. It throws a error low encoder battery, I changed the battery with 2 lithium ion batterys I bought at the store but they were only 3.2v not 3.6 still throws error and says no motor power when trying to do jog anything, ordering new batterys tonight. Is there a way to reset everything to factory defaults that you would recommend.

  • Is there a way to reset everything to factory defaults that you would recommend.

    Yes, there are many procedures available which are similar (not the same) between C and D controllers, but your post is confusing as to which controller you are asking for.


    You should really take a backup of all controllers and verify they all work before doing anything else.

    There also may be some useful functions and code to learn from too.


    The simplest procedure so that you don't lose functionality is a software reset.

    a. For C controller - Menu/Function/100 System Initialize.

    b. For D controller - Aux Function 0805 Initialize System.

  • I was searching for the cords and came across a guy who offered to sell me 3 more similar robots for scrap weight. 1 zx200s D controller and 2 zx165u C controller I bought them up figured it was better then buying any spare parts individually and I could resell extra parts after. They came with cords and 6 or so teach pendants and some are missing parts. Today I wired up the zx200s and d controller I first bought that I posted the model numbers for above. After messing with it I got it to boot. It seems that it is set up for spot welding. I had a low voltage encoder battery error. I replaced the battery with a 3.2v batterys I bought from the store, It still threw the error, so I ordered the correct 3.6v battery will be shipped to me soon. I was unable to jog the robot at all, not sure if this is related to the low battery error but it was saying something along the lines of motor power is off. Other then replacing the battery what do you recommend I do from now? How do I take backups?

  • I also tried to hook up one of the C controller robots and the controller would power up but I was not able to get anything other then a black screen. I need to mess with it a bit more it may have something unplugged.

  • How do I take backups?

    You learn by researching the forum and the manuals or undertake some training.

    Go here and download the range of terminal editors I and other members have kindly provided.

    Use either KCWin32 or KRTerm applications and the guides I have added to them:

    Kawasaki Online Terminal Editors - Manuals, Software and Tools for Kawasaki Robots - Robotforum - Support and discussion community for industrial robots and cobots (robot-forum.com)


    Kawasaki alarms appear in 2 forms on the D controller:

    a. Warning is Yellow box.

    b. Error is Red box.

    c. Errors have several layers of reactions and resettable and non-resettable conditions.


    Warnings are usually resettable and will allow continuance.

    Errors (dependent on the error) may not reset, reset and clear, reset and clear and return.


    In the case of encoder warnings, usually you can reset and turn motor power back on.

    In the case of encoder errors, motor power will not be permitted to turn on as it is unsafe.


    If you have an encoder warning, you can reset and apply motor power.

    So as long as the controller remains ON, you can re-zero and move it.


    Attached are 2 simple zeroing procedures for C and D controller before you ask how to rezero.


    As far as the C controller:

    a. You may have a faulty pendant backlight, harness or pendant.

    b. CPU is not starting up or faulty.

    c. AVR power supply issues.


    Further investigation will be required as to ascertain where the problem may be.

  • You can't just delete the 7th axis, you need to remove ALL relative user location data first.

    Only do this if you don't mind wiping all the programs (user data).


    So at editor prompt type in SYSINIT/U to remove user data.

    Then use ZROBOT command to setup robot model information and go through each stage.


    Before you carry out, make a backup and take a screenshot of Aux 0804.

    This contains the robot model variant you have to set in ZROBOT.

    Serial No. is user definable.

    You should not need to change the robot model but during the ZROBOT process, you need to ensure this matches your current model as per 0804.

  • Okay so I have been trying to connect the past few days. The IP adress on my controller is 136.100.2.2 and subnet mask is 255.255.0.0

    I changed my lan settings to those numbers and when I try to connect I get a error. Any advice here? I tried to change the ip adress on the controller to the default ip listed in the guide still did not work.

  • Is it possible that the Ethernet cable I used is not a cross over cable? There is a difference correct, I have been trying with just a cable I found in my house.

    This is one of the main causes of not being able to establish a peer to peer connection.

    A cross over cable is required for peer to peer connection.

  • Still having issues bought a cord

    My ip on my controller is 136.100.2.2

    Subnet mask 255.255.0.0

    Should the ip on my computer tcp/ipv4 be the same? Or do I need to put something different there? Should I change the ip on my robot?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners