delay of movement when switching motion groups

  • Hello,


    I am working on a new application with extended axis configuration. A seventh axis for a servo gripper. The main application is the palletizing and cell logic process, counters, register manipulation and pick and place of the workpiece. Inside there, we nest our custom program depending the workpiece. What I experience is this: When robot picks the workpiece, moves to home position and calls the sub program dedicated for the workpiece, there is a slight delay before the robot starts moving. More or less a second or maybe less. I cannot figure out what causes this delay, as there is no custom logic or calculations involved before the first move command.

    The main program (palletizing program) is with Group Mask 1 because I dont need to use 7th axis as much, and If I have to, there is already a list of programs I have created all with Group Mask 2 that just manipulate 7th axis, such as external_0.tp for 0 degrees, external_45.tp and so on and so forth. Although, this is not the case for the workpiece process subprogram which is of Group Mask 1,2 because in there, I NEED to be exact when using 7th axis.

    Can this be the reason why there is a delay when entering and exiting the subprogram ? Because there is also the same delay when I finish the subprogram and return to the main routine. Is there a work around this delay ?

  • AD
  • There can be a slight delay when changing frames or groups. I think it would be less that a second. More like the delay between 2 fine moves.


    Are there any WAIT statements or code that iterates (loops) a lot?

  • There can be a slight delay when changing frames or groups. I think it would be less that a second. More like the delay between 2 fine moves.


    Are there any WAIT statements or code that iterates (loops) a lot?

    No waits no calculations. I jumped them deliberately to check if this was the case. The delay is still the same and the only difference is that from a single Group Mask program I call a Group Mask 1,2 program. Everything else is the same. Also the delay is the same when exiting the subroutine. One other thing to note is that on group 2 (servo gripper) the Continuous Rotation function is enabled. I don't know if by entering a program with a motion group that uses Continuous Rotation function the motion planner does any magic to calculate or store a zero value for that axis.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now