Process Sync Instructions

  • Hello all,

    Wanted to try these Process_Sync instructions and cut the flag handshakes out...I got 2 robots and a positioner. Robots weld a pipe in the positioner. Robot 1 and Headstock (group 3) are a coordinated pair.

    I call Main_Routine, in that job I RUN R1_Weld and R2_Weld. Robot 1 and Robot 2 run jobs have Sync_Sched[1] in them (saying what I believe is "Sync Robot 1 & 2"). Then Robot 1 and Robot 2 move down to weld position. Robot 1 PR_STRT[1] at weld position. Robot 2 INPOS[1] at weld position. This is where the robots wait in position (RUNNING) for something to let them move on. Robot 1 should move on to a CALL job that rotates the pipe, but Robot 1 never moves on. I have tried swapping Robot 1 and 2 with PR_STRT and INPOS commands, I get the same effect (they stay running on their motion line). I also tried putting a WAIT of 5 seconds before the INPOS robot gets to the INPOS motion line, also didn't help move the master robot move along.

    I've been trying to debug using the Process Sync Status page, but this page doesn't ever seem to change or update. Attached a screenshot of what I got on this page.

    Has anyone tried using these Process Sync commands and have any idea what I could be doing wrong? I asked FANUC support, but unfortunately the support agent I got to didn't have any experience with Process Sync. Perhaps I should just abandon and go back to the old handshakes with flags (boring & tedious).

    Thanks for any help that may be provided!


  • Alright, figured it out...Something I don't believe they didn't cover in the Multi-Arm Manual or the ArcTool manual under the Process Sync section (go figure)...

    You will need to setup MASH first! Menu -> Setup -> MASH. I set Group 1 as #1 and Group 2 as #2. Then you RESTART THE ROBOT!!! (I thought this P_Sync still wasn't working then I restarted)...voila now you can use the Process Synchronization instructions. :wallbash:

    Also to note: You will not need to enter a hostname or change any of the suffix letters (which I have NO idea what those are for) if both robots are on the same controller. Lastly, I figured this out when I tried inserting a MultiArm Sync instruction. Yelled at me saying "Gotta setup MASH!" and I'm like...what's MASH? Then it clicked...Figured out how to setup Process Sync when failing trying to see what MultiArm sync is... Come on /rant

Advertising from our partners