RobotStudio Issue (Rapid)

  • Hello all!


    I have the following problem while programing paths and actions: I want to drop an object at the end of a path (and that is what I have programed in RAPID) but the object is released before reaching the final point always (see figure). I have detected that if I reduce the velocity and the value of z parameter the robot drops the object nearer to the point but never at it.


    Someone could help me?


    Thanks!!





  • AD
  • Hi,


    If you provide a portion of the program, we are able to better help.


    That being said, what is the zonedata for your drop position? Is it a z0, or fine?


    Additionally, do you have sensors / signals that you are using to check you don't have the part attached any more?

  • You'll have to have a "fine" value of the zone or atleast z0 to reach the position without aproximation.


    Code
    MoveL DropPos,v500,fine,tool0 (This is a "Stopping" movement without aproximation-distance)
    
    Or atleast:
    MoveL DropPos,v500,z0,tool0 (This is a continious movement but also without a aproximation-distance)


    A tip is before you activate the signal for dropping the object, you could use "WaitRob\InPos" to make sure that the robot has physically stopped before doing any drop-actions. :)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now