I need help with installing Yaskawa Motoman DX100 software

  • Greetings,


    I am new to the industrial robot scene.

    I am currently working for the first time ever (my first job) at a company that uses Yaskawa Motoman robots.

    I don't know how to instakk software in a Yaskawa Motoman DX100 robot and I have trouble finding the software that I want to install. I even struggle to find a good tutorial or even a basic tutorial about the installation.

    So far, the robot's system start just with Windows CE on the programming pendant YRC1000. And the Windows start with an error that says "Controler <-> Pendant Connection Failed".

    What are the steps to install the software? And where do I find the software?

    I don't know the name of it, but here is a current pictures of the software that I talk about, I just want to be able to install and open it like this on another pendant ;)


    I would feel really grateful if you could help me.


    Best regards. :)

  • Hi,


    The problem is that I am not in charge of the company where I work at and Yaskawa asks for payment in exchange for help, so I would have to ask for permission of my boss to spend some money.

    Isn't there any possible free way of helping solve my problem? (I want to find out about this before we possibly contact Yaskawa)

  • Why do you want to change system software? The only time it is needed is if a bug is found or someone wants to take advantage of new features. Admittedly, DS2.05 is older software. Are you getting some type of alarm or message? A simple phone call to Yaskawa could help you troubleshoot the problem.

    Alcohol: The cause and solution to all life's problems

  • Oh, my apologies for the misunderstanding that I created: what I was saying in the beginning is that I don't have any software installed, not even this older one. The very first picture at the beginning is from a fully working robot and not from a "empty" one (if you get what I mean).

    Like I said before, the robot to solve has just Windows CE, nothing else.

    And it has an error as well. Here is the picture of the non-working robot:


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now