IRB 2000 Problem Solving

  • Hi Everyone


    Sorry about the duplicate but I posted most of this in the manual request section of the forum.
    Skooter has been helping, thanks a lot.


    I will summarise the work so far in getting my IRB 2000 working and then continue posting as I hopefully get to the bottom of the problem.


    I first posted:


    I have an IRB2000 with an old S3 controller and also looking for as much documentation as I can get. I am looking for wiring diagrams and service manuals if possible. I have searched about and most of the links on this forum seem to be quite old and expired.


    At the moment every board on the controller has a red error light including the CPU. Not sure where to start?
    I am trying to confirm what pins on X3 should be strapped to ensure that the external safety interlocks are disabled at the moment until I get it working.


    Another thing I noticed is the NiCad battery pack seems to have leaked and I assume its not working.


    Looking for details on what I should be looking for on the various test pins on the VME bus boards, voltage or oscilloscope waveforms?



    Skooter helped out with manuals and guidance:


    IRB2000s were built from 1987-93. I like to call the M87-M90A "Old S3" and the M91-M93A "New S3". Because of the major changes between old S3 and new S3, please supply the model year designation (M87-M93A) or the serial number.


    Whenever resurrecting old equipment, always verify the power supply as some of the main components in them deteriorate with age.


    Since it has a DSQC215 CPU, it's either an M90 or M90A controller with an external axis. The M90 power units are YB560101-Gx, the M90A are YB560101-Lx. There was an M90A/2 but I don't remember what changed.


    Make sure the 3-position mode switch on the CPU is in the RUN position.
    Check the voltages at the test points on the front of the DSQC211 power supply. I remember the 24V was always high which was normal.


    I tried posting a Product Manual for the M90 IRB2000 but the forum gives me an error. It is a 6.8MB PDF.


    Try searching 'M90' in only the ABB section & Manuals ... child board of the forum. There are other similar posts.



    I will now start posting the steps I have been taking.


    Once again thanks.

  • Place your Ad here!
  • A bit more work with a multi meter and oscilloscope :


    We see the power supplies all looking ok with maybe a bit of noise on 24 volts. 500 nanosecond ring at 2 volts every 20 microseconds.


    5 Volts is 400 millivolt noise peak to peak.


    5 volt RVM has spikes of 4 volts above.


    The battery has been removed until I get a replacement, not sure this will stop things working?


    All cards are red led.


    The teach pendant shows “prog unit communication fail”


    The DSqC 210 has only one green led. Do all of them light up in normal operation?

  • Capacitors:
    Go with the next higher voltage for the tantalum - seen those bad more than once but just can't remember exactly why they shorted.
    Get the 105C deg temp ratings if you can. Capacitor life goes up the further you are from the derating temp.
    Pay attention to ESR of the caps you replace them in the switching sections of the power supply. Changes can effect the resonance, thus the efficiency. Big changes and can keep it from resonating which equals no output.
    Check the date code when you buy capacitors. Make sure someone isn't selling you something that has exceeded shelf life.
    Almost all new capacitors are smaller in size than the almost 30 yr old ones that originally came with the unit. Go up in voltage to get the lead spacing and ESR you need.

  • Hi,
    I also have an IRB2000 with S3 controller (M93) that I was planning to refurbish. However, it was a short project as (to my surprise) the machine works :icon_smile:


    I have most manuals and schematics on paper but have not yet scanned them. Happy to send some specific pages if required.


    I am now seeking some information regarding the 'Superior Computer' link (serial interface) and it's protocol. Some others mentioned the S3 SPORT software from http://www.ppm.no I have successfully connected with their demo software but
    I have contacted them without success.


    A serial terminal (eg putty) works when connected to the 'printer' output, but not when connected to the SC interface. It appears the controller is expecting some initialisation sequence or handshaking.


    Any information/documents/tools would be greatly appreciated.

  • Welcome to the forum. Since your needs are different than MK768780 even though the robots are similar, I suggest you start a new topic so your questions can get answered specific to your needs. Download the 'PC as a Service Tool' from the manuals section and consider purchasing a used working S3PC.

  • So the order has gone in. We have purchased all new electrolytic capacitors, film capacitors and a new tanlylum cap. A new nicad battery as well.


    Should be about 5 days then we can work through the soldering and hopefully things start to work :-).


    I’ll keep you all informed.


  • Welcome to the forum.


    Thank you. It seems like there a few very knowledgable people in here.



    Since your needs are different than MK768780 even though the robots are similar, I suggest you start a new topic so your questions can get answered specific to your needs.


    Apologies, I have now created a seperate thread: https://www.robot-forum.com/ro…e-(superior-computer-link)



    Download the 'PC as a Service Tool' from the manuals section and consider purchasing a used working S3PC.


    Wow, I didn't know those S3PCs existed, a bit heavy for shipping to Aus. The 'PC as a Service Tool' documents exactly what we had tried (and it works) by using the 'printer' interface straight into a serial terminal. Thanks.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners