• Hello everyone
    I'm trying to connect my fanuc controller (RJ3ib) with ethernet but I can not get them to communicate

    I know I have to have a crossover cable
    but my question is:

    Is it possible to make a ping with a cable that is not crossed ?
    With the ping I will know if I have the communication even though it is a non-crossover cable?

    I tried to ping and I get the error "host not reachable"
    Does this mean it's the cable? or is it because I have to have some data or wrong parameter?

    I have introduced my ipv4, subnet mask and IP address of the controller in rank with the pc

    What is wrong?

    thanks to all

  • Hi Jonatan

    Yes you can ping the controller using any ethernet cable (straight or crossover)

    You only need to define the IP and subnet mask for the controller

    There are two ports available, so you have two up addresses in separate networks

    Usually one is used for the local (station/cell) network
    while the other is used for the plant/factory network

    You are probably configuring one port but connecting to the other one???

    Sent from my iPhone using Tapatalk

  • First of all, thanks for answering,

    do you mean that the configuration of the controller through the teach pedant can be changed to two ports?

    when I enter the parameters of IP, mask subnet, in my controller there is no possibility to change to another port because it only has one

  • Additionally, you need to check the firewall of your computer, if it is opened, please close it.

    do you mean the port?

    I've been looking at how it is checked if the port I have open or closed but I have not come to check

  • in RJ3iB use ethernet cross cable, only one ethernet port for this type of controller

    example of configuration:

    TCP/IP 1/11
    Node name: ROBOT1
    Router name: PC1
    Board address: 00:E0:E4:F1:23:45
    Subnet mask:

    Host Name Internet Adress
    1 ROBOT1
    2 PC1
    3******** ************

    Need reboot of controler


    SETUP Tags JOINT 100 %
    Tag S1:

    1 Comment: ****************
    2 Protocol name: FTP
    3 Port name: ****
    4 Mode: *************************
    State: UNDEFINED
    5 Remote: ********
    6 Path: ****************************
    7 State: START
    8 Remote: ********
    9 Path: ****************************
    10 Error Reporting: OFF
    11 Inactivity Timeout: 15 min

    reboot the controler or change current state "undefined" to "defined"and to "start"

    Edited once, last by pyrioun ().

  • Thank you! With your example I have noticed an error that I had made.

    They sent me a document on how to do this and had done it the same as in the document but it would not have the same software version and in the router name it was the ROBOT IP and in the host name part there was only the IP of the PC. In summary it has been solved by putting the name of the PC in the router name and in the Host name the IPs of the ROBOT and PC with the same names

    Now another problem arises, when I want to save the All Off Above in cmd I enter
    ftp> open IP_Robot
    Conectado a IP_Robot.
    220 R-J3 FTP server ready. [FANUC 7D80/B2]
    500 Command not understood.
    Usuario (IP_Robot:(none)):
    230 User logged in [NORM].
    ftp> prompt n
    Modo interactivo Desactivado .
    ftp> mget mdb:*.*
    200 Type set to A
    200 PORT command successful.
    150 ASCII data connection.
    > R:Error de E/S
    226 ASCII Transfer complete.

    and after several lines the last line
    ftp: 349 bytes recibidos en 0.02segundos 20.53a KB/s.

    when I go to my directory where I saved the AOA there is nothing saved

    what's going on? What is the error and how is it solved?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now