AD controller teach mode power on

  • Hello!


    We have JS40 Kawasaki robots with AD controllers. One works good in production line. We have got one for spare, it works in automatic mode only. In teach mode the 'motor power' does not switch on -- no error messages. We checked the teach pendant the boards in the controller -- everything.
    What configuration or hw fault may produce this strange behavior?


    Thank you!

  • Place your Ad here!
  • AD controller needs a teach pendant dead man switch (trigger) to enable motor power in teach. Try to hold the switch and then turn on motor power. Maybe trigger is defected?

  • Hello!



    On the 7 segment display:
    controller on teach mode: P.
    controller on auto mode: P
    auto mode power on: A
    auto mode cycle on program running: 8
    Leds on 1GE servo board:
    auto mode power on: three green led: power on, rgso, break are on.


    In teach mode the seven segment display shows P. and does not change regarding to power on and trigger buttons. On the 1GE servo board the power on led is blinking as the orange power on lamp as far as I press the power button and the trigger switch.


    Is there any configurable 'external trigger switch' that disables the power in teach mode?


    Thank you.

  • Hello!


    I suspect someone mixed the wires of the safety circuit -- emergency stop and safety fence. Can you send a wiring diagram about it?


    In the document you sent I can't identify the elements. Is they all wires/switches or some logic?


    On the external I/O connectors we have 3+2 shorts for ext-estop and safety fences. Is it enough? In RPT/RUN mode if I broke any the motor power is gone off.


    Thank you.

  • I may have posted the incorrect circuit, here's another couple attached.
    Can you post your AD Controller version and also current TB2 connections - there seems to be many versions of AD Controller.

  • On the picture 'capure1.jpg' the 'Panel RUN/HOLD' switch always gets the 24V. There is only a short 24V pulse on K6 contacts in TEACH mode.


    Where can I find the switches before K6 contacts on 1DP and 9ZA boards and what do cause to be disabled they?


    Thank you.

  • I am sure the plate should either be on the top of the Controller or on the Door......but it maybe that old it has rotted off.


    Quote

    On the picture 'capure1.jpg' the 'Panel RUN/HOLD' switch always gets the 24V. There is only a short 24V pulse on K6 contacts in TEACH mode.


    That doesn't quite make sense, if you only get a 'pulse' in Teach Mode.....what is the result in Repeat Mode?
    - If that is stable in Repeat Mode, then I would check K2 Contactor and auxiliaries.
    - Can you definitely confirm TB2 Configuration/Jumpers are correct, and could you check
    - You say there are no errors produced, can you verify this.


    I have attached a couple of docs for additional.
    - Could you also verify all switches of S2/S3/S4 are off on the 1GE board.

  • Switches on 1GE board were all off except S2/1. I switched it off -- nothing changed.


    On 1DP board:
    SW1 all ON 8 pcs
    SW2 all OFF 4 pcs
    SW3 1-6 OFF, 7, 8 ON
    SW4 all OFF 4pcs
    SW5 1,4 ON, 2, 3, 5-8 OFF


    Thank you

  • Yes, I thought that would be the case with the switches/settings.....
    - S2/1 on the 1GE should remain on, as I think from memory that is allocated towards the Encoder battery.


    The last attachment I sent (90206-1019) is the complete circuit, I think you will have to trace the circuit back and check/verify the voltage path from Teach Pendant, Operation Panel to TB2 and to 1DP board.
    - There must be a break in the circuit somewhere, because if the trigger request was getting through and K2 was failing to come in, then I would expect to see errors.
    - It is as though the trigger request is not getting through, which suggests there must be a break in the circuit somewhere along those lines.


    Recently, I assisted in a similar problem on a D Controller, that ended up being a setting within software, however I am unsure if this is the case here....however.
    - Can you do a complete file save and attach the file in a post here....you will need to adjust the file ext. to txt in order to post it.
    - I'll have a look over it and see if there maybe a setting problem instead.

  • Hello!


    Here is the content of this CPU board. (We have two sets of working(?) boards but 1GE servo board.) All work the same -- no power in teach mode. I downloded the backup from the working machine to the other 9ZA board -- works the same.


    We have another 1GE board the daughter board on it was for another arm not JS40. We changed it but does not work. I downloaded the JS40 servo software from floppy to the board.
    Is there any factory programmed IC on this board specific to the arm or the controller?



    Thank you

  • Thanks for the backup, looks ok to me, nothing appears out of sorts/corrupted etc....
    - Downloading from the good 9ZA to the suspect one, has obviously confirmed that too.


    When replacing 1GE, then the appropriate servo software requires installing aswell as exchange of the 1GM from the old 1GE is required - or else errors will occur......so I would doubt the 1GE is causing your issue.
    - Obtaining the servo software would be pretty impossible due to the age, but if you need it, you would have to contact KHI directly, unless people have versions they can provide.


    You've mentioned that this robot can run in Auto no problem, which means the servo software/1GM/Power Block configuration is matched.
    - This also proves the 1GE, 1DP, Operational Panel and Power Block integrity including the Emergency Stop and LS lines.
    - Therefore there must be a break in the circuit somewhere.


    Can you 100% verify the integrity and configuration of TB2 Interface, Teach/Repeat Switch and also CN10 and CN11 (1DP connections)?
    Have you also tried to supply the External Motor Power On jumper via TB2-D3 and TB2 DB4?

  • Hello!


    I replaced the cables on 1DP CN10 with a connector of all shorts (with or without 22-23 ext-power) eliminating the TB2 connections I think, and nothing changed -- no power in teach mode. It seems that the control does not sense the deadman switch. I checked the connections of deadman switches and current flowing to 1DP board on CN11 4-11,12. The other line goes to the pendant board I can't check, we swapped three teach pendant all worked the same.


    We swapped the 1DP board with the working robot and works fine. (I think it remained there.)


    When we swapped the 1GE board some error about JT8 (!!) brake occured that can be cleared. We changed back this card.
    The question factory programmed IC I mean the two big 'Kawasaki' chip on the 1GE board. Is they specific to the controller or the arm?


    We have three disks with servo software for the JS40 arms.



    Thank you

  • I'm a little lost with this now...... ???


    Quote

    We swapped the 1DP board with the working robot and works fine. (I think it remained there.)


    Are you saying:
    a. by transferring the 1DP from the working robot to the suspect robot - it finally works.
    b. by transferring the 1DP from the suspect robot to the working robot - you proved the 1DP from the suspect robot is working.


    Why are you swapping the 1GE board?.....this has no relevance to the issue with the deadmans.
    I am pretty sure the Eproms you're referring to contain the servo firmware and these could be transferred between 1GE as long as the Arm/Power Block and 1GM are compatible....
    - But I can't be 100% sure due to my memory of this being so old.........
    - I am sure, that the servo software can be reloaded to those eproms in order to update them etc.


    If there was a problem with the 1GE, I would expect errors on startup or during motion (especially in repeat).....and not any issue with deadmans/trigger not being registered.


    I'll try and track down some further information regarding the 1GE eproms and let you know.

  • Hello!


    With swapping 1DP I mean:
    >> b. by transferring the 1DP from the suspect robot to the working robot - you proved the 1DP from the suspect robot is working.


    As I wrote: It seems that the control does not sense the deadman switch -- or something disables the power in teach mode, thus the flashing power light. Once in swapping boards the power stayed on for about 1 sec in the suspect robot somehow.


    Thank you

  • The only other thing I can recall, S2/S3 and S4 switches on the 1GE board can be used to 'mask' out various signals for troubleshooting.
    Attached is the page referring to each of their functions.
    - S3/7 is for the Teach Pendant Trigger Status.


    I have no idea whether this actually allows the system to ignore the functions/errors.......but I suppose it's worth a shot.


    The 1GE I am sure from shipment contains the relevant software for the Arm, along with the matched 1GM for the Arm and Power Block configuration.
    - If the 1GE was swapped into another Controller, the servo software and 1GM would need to be exchanged to match the new robot arm.
    - I don't know, whether you could just simply exchange the 2 IC's you're referring to instead......again, maybe worth a shot, but could be risky.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners