Fanuc R-30 cpu is depressed :(

  • Finally (after a long day of back n forth from stuck on starup) came to the conclusion that I have a bad cpu board? After changing tp cable and a0a backup, image back, up INIT START. FROZE ON INIT start 2 compete Are R30iB cpu boards inter changable between different size robots. I have r2000 robot's R30iB that can afford down time. The robot that needs new boards (or battery or axis control card)is an r1000. Are these interchagable???


    Sent from my LG-H950 using Tapatalk

  • Place your Ad here!

  • I think CPU can be exchanged between same controller type. Make an IMG backup and AoA of the "donor" robot. If you exchange SRAM/FROM module be sure to have the same size in order for image restore to work.

    Yes i made image and found image from a bit with almost exact programming.
    Fanuc recommended swapping axis control card[connected to fiber optic cable] and 3v battery on board. I tried swapping the access control card and then doing the Init start up but it still would not finish INIT start. Getting stuck in freezing up on "INIT 2 complete" Should I try putting a new battery and try INIT START again? or instead of an upstart just go straight to image restore?


    I am doing all of this from the boot monitor screen because ever since I froze up on the a INIT START complete 2" yesterday It will not finish booting up.



    Sent from my LG-H950 using Tapatalk


  • I think CPU can be exchanged between same controller type. Make an IMG backup and AoA of the "donor" robot. If you exchange SRAM/FROM module be sure to have the same size in order for image restore to work.


    Also what do you mean by same size. This is the only R1000 we have, majority of every thing else with a R30iB controller. does that make a differece.
    Can i restore image back-up instead of doing init start?

  • Also what do you mean by same size. This is the only R1000 we have, majority of every thing else with a R30iB controller. does that make a differece.
    Can i restore image back-up instead of doing init start?


    When loading an image, the controller SRAM/FROM module size will be compared to the size it was when the image was created. Make sure they're the same size (part numbers should match). The SRAM/FROM module cannot be smaller than the image. Going up a size hasn't been a problem for us. Part numbers and sizes below for reference. May not cover all available configurations.


    A05B-2600-H060 A20B-3900-0283 FROM 32M/ SRAM 1M
    A05B-2600-H061 A20B-3900-0284 FROM 32M/ SRAM 2M
    A05B-2600-H062 A20B-3900-0285 FROM 32M/ SRAM 3M
    A05B-2600-H063 A20B-3900-0286 FROM 64M/ SRAM 1M
    A05B-2600-H064 A20B-3900-0287 FROM 64M/ SRAM 2M
    A05B-2600-H065 A20B-3900-0288 FROM 64M/ SRAM 3M
    A05B-2600-H066 A20B-3900-0280 FROM 128M/ SRAM 1M
    A05B-2600-H067 A20B-3900-0281 FROM 128M/ SRAM 2M
    A05B-2600-H068 A20B-3900-0282 FROM 128M/ SRAM 3M

  • Thanks. Idk the cause but loading image fixed it


    Sent from my LG-H950 using Tapatalk

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners