Disable ProfiSafe

  • Good day,
    I have a problem with PROFINET SAFETY.It is


    SRVO-419 PROFIsafe comm. error 1,1.


    When I am in T1 mode it is possible to BYPASS it from MENU->0-> SYSTEM(6)-> DCS(8) ->PROFINET Safety(14) -> Change "ENABLE" to "BYPASS". But in T2/Auto mode it is not possible. If I change it to BYPASS it is changing to ENABLE automaticly. I am using classic S7-315 without Profisafe cards. The only safety thing I am using is DCS which are connected to CRMB2 in fanuc controller (I belive it is standard inputs for safety in every fanuc). Do you have any idea how to disable this error?
    Thanks


    Edit:
    I am using M710-iC-50 Robot and R30-iB Controller. It is welding process.

    Edited once, last by sklimosz ().

  • Place your Ad here!
  • Hi, i have same PROFIsafe error as you had. Can you please tell me if you were able to fix it?
    I thing my configuration in robot is ok, because have normal comunication with PLC working. But when i turn safety to enabled, then i get error.

  • Set the following variables:


    $PNSF_SET.$BY_PWFAIL = 0
    $PNSF_SET.$BY_PLCCON = 0
    $PNSF_SET.$BY_PLCRUN = 0
    $PNSF_SET.$BY_T1ONLY = 0

    Plus need to set another parameter (this sets the PROFISAFE to BYPASS mode):

    Code
    $PNSF_SET.$MODE=2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners