Ethernet IP setup with Codesys and TURCK Tx715

  • I am struggling with setting up Ethernet IP between my UR5e cobot and a Tx715 PLC/HMI from TURCK.

    I already looked at the Ethernet IP guide on the support website for UR.

    I downloaded the .eds file from that article and installed that in Codesys v 3.5.16.

    After scanning for devices on my Ethernet Scanner, Codesys found both my robot and the Discrete I/O gateway on my network.

    The universal robot is select-able as an Ethernet device.

    I placed the robot and BL20 modules in my scanner’s device tree and the eds came with pre-configured I/O mapping for the Cobot.

    Once I download to the device and put the PLC in RUN mode, the BL20's I/O works as intended, but the Cobot doesn't communicate at all.

    It states that the bus is not running and has a small yellow triangle next to its name in the device tree. On the Cobot pendant, the EthernetIP running state is still Yellow.

    I even tried to map the I/O myself on a generic ethernet module for the Cobot rather than rely on that eds file.

    There is definitely IP connection between all of the devices because I can ping all of them and receive a response.

    There must be something wrong I am doing in Codesys, I/O mapping, or maybe the UR Cobot (but there are not too many options there on the pendant).

    Any one else have these issues with TURCK items/Codesys and UR? Any troubleshooting ideas?

    • Helpful

    Update to my Post...

    I have figured out how to get the Universal Robot and my other devices to talk via Ethernet IP.

    The .eds file from the UR support website is not useful for the Codesys 3.5.16 platform. The .eds is meant for Rockwell.

    Even though I knew that the .eds was originally made for Rockwell, the confusing part is how the eds easily loads into Codesys and it can detect devices in the device tree with no issues. The I/O mapping seemed to have no issues as well. That is until I ran the PLC and I was stuck with the Yellow warning triangle as seen in the image above. I tried to salvage using the .eds file by manually editing it in a text editor to better fit Codesys (based on troubleshooting steps I found elsewhere).

    Overall, do not use the .eds file from UR for Codesys systems.

    You will need to make a "Generic Ethernet IP Device" for the robot's adapter in the Ethernet IP scanner device tree.

    You will need to do everything manually from here out. Setup the IP address, add a generic connection, and then do all the mapping manually.

    Here is the mapping link: https://s3-eu-west-1.amazonaws…e/18712/eip-iomessage.pdf

    After you are all done and the connection works like expected, export the mapping to a .CSV file for later use.

    If anyone else has found an Ethernet/IP .eds file that works well with Codesys for UR let me know. Or other troubleshooting steps for the existing .eds file from UR's website.

  • Hello,

    I am working on setting up a Codesys SoftPLC using a Universal Robot and am encountering the same Ethernet IP issues described here.

    Do you happen to have a copy of the .csv file you were able to generate for this project? I tried following the steps you described here and I am unfortunately not having any luck. It especially doesn't help that my program isn't even throwing errors- it simply says that my Ethernet IP isn't running:

  • Thank you very much for responding jvincent ! I am going to try to create another generic connection with the information you shared, it may take some time to reenter these parameters manually (because it seems the "Target Config Size" is locked.) I'll keep you posted.


    jvincent thank you very much for the configuration information- it seems to be connecting! I ran into an intermediate issue where I didn't have the URSim Ethernet/IP enabled which is why I wasn't getting any error readouts.

    Question, have you recieved any periodic timeouts, like this?

    Every 3 minutes or so there seems to be a connection error that automatically fixes itself.

  • Also, if you don't mind me asking- what resource were you following while creating your PLC program in Codesys? I was hoping to go this route to establish a RTDE setup on the Codesys SoftPLC, but I can't find any explicit description of implementing this. Were you using the UR Ethernet IP Guide instead?

  • shamusoc No I haven't been experiencing the intermittent drops in connection that you are seeing. Sorry but I don't think I can help with that at this time.

    And yes I was following the UR Ethernet IP Guide during my setup. I do not use RTDE even though I looked into that while I had trouble connecting via Ethernet IP.

  • The connection issues seem to have worked themselves out over time, so I am all set there. Alright, I've heard that the RTDE can be difficult to work with, so I will look into the EthernetIP guide. Thank you again for all of your help.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now