Robot movements smoothness

  • Could you post a sample of your milling file, with the header and approx 20 lines of code? Depending on motion parameter/zone settings, point spacing, speed, direction etc. this can be solved without diving too far into anything else.

    Taylor Guitars - Robotics Engineer
    - IRC5 IRB4400
    - IRC5 IRB2400
    - S4C+ IRB4600
    - S4 IRB2400
    - Epson G3-351 RC180

  • Place your Ad here!
  • If jogging produces the same problem then the programmed path isn't as suspect (although the points appear pretty close together for the speed). I don't see anything in this that jumps out at me - I've seen in some cases where tool-changing was happening, a tool was activated and either the LOAD_DATA wasn't changed, or there wasn't anything in the LOAD_DATA for that tool.


    Make sure this:
    ; LOAD_TOOL(1)
    BAS(#TOOL,1)



    is activating the right LOAD_DATA. You can also force it out ... I don't have the syntax in front of me so you'll have to look it up but it was something like


    $LOAD_DATA = LOAD_DATA[1]


    or if using Tool 2



    $LOAD_DATA = LOAD_DATA[2]



    and each tool will have to have the specified load data in it.


    When jogging after running a program its possible to still have LOAD_DATA[2] activated while jogging with TOOL1 if changed manual.

    Taylor Guitars - Robotics Engineer
    - IRC5 IRB4400
    - IRC5 IRB2400
    - S4C+ IRB4600
    - S4 IRB2400
    - Epson G3-351 RC180

    Edited once, last by Tyler Robertson ().

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners