Posts by WimJ

    Well I don't mean a controller backup. Just the way to take a backup of the programs, variables, ... .
    But R-J is totally different then R-H. R-H has the bubble memory going on and the crt karel commando's :hmmm:

    Does anybody know how to backup an R-H controller using Kfloppy and the serial port?
    What settings on robot side / pc side and what commando's on the crt?
    I'm just scarred I'll flush the whole thing empty with no backup :waffen100:


    Thx

    I hope you have an all of above backup! Because with the init start you have reset your robot to factory settings. Meaning all programs, all IO settings, all system variables, all frames, ... are set to factory settings. Also in the $ DMR_GRP $ MASTER_COUNT there should not be zero!


    If you have an all of above backup:
    - Restore in controlled start
    - Reset the pulsecoder alarm (RESPCA) and reboot
    - Set $ DMR_GRP $ MASTER_DONE = TRUE
    - Calibrate


    If you don't have an all of above:
    - Put all axis on the zero marks and perform a zero position mastering
    - Calibrate
    - Your robot is masterd now and will be able to move in cartesian frames, all your other settings are lost with the init start....


    You probably had an SRVO-062 BZAL after replacing the batteries (replaced them with power off???)
    This is what you had to do:
    - RESPCA and reboot
    - Set $ DMR_GRP $ MASTER_DONE = TRUE
    - Calibrate


    Wish you good luck!

    Check your payload settings. MOTN-170 means that your payload setting is to close to the max. If this is the actual value, maybe your robot is working in overload conditions. Meaning that your gripper + pallet is to heavy for this robot. Also check collision guard settings and disturbance menu to track the problem.



    Verzonden vanaf mijn iPhone met behulp van Tapatalk

    To communicate labview to fanuc robot you can use the SNPX / RS232 or SRTP / ethernet protocol. With those you can write directly to registers and use this as offset to your frame. If you use a plc, you can use a lot of communication protocols (profibus, profinet, ethernet ip, modbus, ....) Then you write the values in group inputs and transfer these to registers.


    But I don't see why you need this. Just offset your userframe by 8 inch and done.... . You never use the full open during production or maintenance....

    The world coordinate frame depends on your mastering. When you wall mount, you don't change the mastering, so the World frame stays the same.
    If you want an easy frame to move the robot, you can create a jog frame. Why do you want to change the frame?

    I did it before with Beijer Electronics iX developer, connected with roboguide.
    I don't know if it's possible with your HMI software.
    So I connected the HMI software and roboguide to simulate the SNTP connection using the local host ip 127.0.0.1


    I never connected the HMI hardware with roboguide before...
    Hope this helps

    When using RSR, is it possible to see a list of the qued programs?



    Verzonden vanaf mijn iPhone met behulp van Tapatalk

    If you connect your PC with your robot controller by ethernet, you can enter the robot server.
    On this server you can see all the SV files and VR files as txt file.
    No special software needed.

    When you replace a motor, you need to remaster the robot. In a robot with DCS, you'll need to apply the new mastercount to the DCS. So you'll need the DCS code (standard 1111).

    You can also use SRTP (SNPX over ethernet). All you need is an ethernet cable and a HMI supporting SRTP. Most of the Beijer HMI's support it. http://www.beijerelectronics.com/ You can even connect the Beijer HMI software with roboguide. Program everything on pc without having to use the hardware for tests.

    Or use the Frame offset utility.
    Go to MENU, choose UTILITIES, press F1 [TYPE], and finally choose Frame offset menu. This utility allows you to translate positions between user frames.
    Just do some tests with it, and you'll figure it out.

    Be carefull with a limit error. It will post the axis numbers hexadecimal. For example: MOTN-017 G1 A6 HEX means that axis 2 and 3 are on their limit.
    In your case A2 hex means that axis 2 is on his limit. So that won't be the problem.
    Did you reboot after changing the axis limits? Cause you must reboot to make the new value active.

    I'm afraid this is normal. When you move U axis (J3), only U axis will move. When you move W axis (J2), a Fanuc robot will keep the U axis on the same Joint position. So both U and W axis will move. This is a difference between Fanuc and ABB/KUKA. I guess your problem will be in the cables or motors, because you already changed everything else :icon_smile: Please tell us more about your problem, maybe we can help.

Advertising from our partners