June 17, 2019, 05:17:10 AM
Robotforum | Industrial Robots Community

 Unable to boot usb drive

normal_post Author Topic:  Unable to boot usb drive  (Read 281 times)

0 Members and 1 Guest are viewing this topic.

May 22, 2019, 01:36:16 AM
Read 281 times
Offline

andoors2011


Hi,

i'm having an issue with universal robot UR10 not being able to boot. what i did was that i removed the usb drive to take a backup on my laptop but then when i put it back it shows unable to boot from device/choose boot device. is there a way i can get inside the bios and choose the boot device? is there a solution for this issue?
Also, when i connect the usb drive to the computer it doesn't open and it either asks to format the flash drive or it's inaccessible and it shows as a raw device. can someone please help with this issue, i have all my programs on this usb and i don't know how to mount/boot from the usb back.

thanks

Today at 05:17:10 AM
Reply #1

Advertisement

Guest

May 23, 2019, 02:30:29 PM
Reply #1
Offline

matthewd92


You will have to be able to mount a Linux disk. We use Mac for our computers and use ‘extFS for Mac’ to mount the robot disks to our laptops. 

We’ve never had to change anything at the BIOS on disks. We just pulled one yesterday, mounted to my laptop and removed some files and put it back in the robot and rebooted with no issues.


Sent from my iPhone using Tapatalk

May 28, 2019, 01:40:05 PM
Reply #2
Offline

andoors2011


I think what happened is that the disk got corrupted when it was removed while the robot was running. I'm trying to search for some recovery options. I contacted universal and they told me to that i will need to reinstall the image since the usb drive is no longer operational. i even booted into the bios into universal and chose the usb but it still shows the same message and unable to boot. do you have any idea on how to download the program from the motherboard itself? or from the robot because the last program i uploaded to the robot was the latest version.

May 28, 2019, 03:49:41 PM
Reply #3
Offline

matthewd92


That USB stick is where everything is stored, that is the hard drive for the computer.

You can download the robot software image from the UR support site. You will need to have UR send you the calibration file as well for the serial number robot.

If you can mount the disk to a computer you should be able to recover the actual robot urp file and installation from that disk.


Sent from my iPhone using Tapatalk

May 28, 2019, 06:25:11 PM
Reply #4
Offline

andoors2011


Do you have a recommendation for a recovery software? i mounted the usb in a linux virtual machine but it stills shows nothing. I can see the blocks does exist and there're data but i can't read it on the virtual machine neither the pc.

thanks

May 28, 2019, 07:01:44 PM
Reply #5
Offline

matthewd92


I’ve never tried to recover one, we always have backups of the programs and related files we need to rebuild one and so just do that.

When you are on the support site there are some magic files in the download section. One of them is a backup file. You place it on the root of a USB disk and when you insert it into the USB slot on the pendant it will backup all the program files on the robot to the USB. We do this after any program changes so we have a good copy. I know it’s probably a little late for now but good recommendation going forward.


Sent from my iPhone using Tapatalk

May 29, 2019, 02:16:54 PM
Reply #6
Offline

SkyeFire

Global Moderator
Under Linux, you can try photorec.  It was created as a tool to recover images files (JPGs, GIFs, etc) from corrupted file systems, but has expanded to do a lot more.  It might be able to recover some of your files from the UR USB drive, as long as the UR files aren't using any proprietary binary-blob formats.

I would let photorec run overnight on the USB drive, with all the search options turned on.  It'll spit out a massive set of every file it can identify, based on the files' internal byte patterns.  Then you'll have to search through those files to see if you find anything recognizable.

Today at 05:17:10 AM
Reply #7

Advertisement

Guest

May 29, 2019, 07:54:24 PM
Reply #7
Offline

andoors2011


So i did reinstall the image and UR sent me a calibration file. now the robot doesn't move even in manual and i can't find a way of importing the calibration file. I accessed the expert mode and i found kinematic calibration but when i import the calibration.conf file they sent me it say's it's not a valid plate configuration file. any idea why this is happening?

thanks

May 29, 2019, 07:55:46 PM
Reply #8
Offline

matthewd92


You will need to mount the disk to a computer and place that file in the correct folder location.

Did UR not send instructions with the file on how to install it?


Sent from my iPhone using Tapatalk

May 29, 2019, 08:35:09 PM
Reply #9
Offline

andoors2011


they didn't, i checked everything on the robot side and everything looks and seems normal but i can't even move the robot manually, when i try the move tab the robot moves on the teach pendant only but doesn't move physically.


Share via facebook Share via linkedin Share via pinterest Share via reddit Share via twitter

xx
Boot type to cold boot by default and FTCtrl/hibernate problem.

Started by vrahikka on KUKA Robot Forum

2 Replies
3015 Views
Last post June 11, 2013, 05:15:46 PM
by vrahikka
xx
Unable to Jog, Cannot Run Programs

Started by Jestepp on KUKA Robot Forum

6 Replies
424 Views
Last post January 15, 2019, 04:03:28 PM
by Jestepp
xx
Unable to connect to KRC4

Started by Borkr on KUKA Robot Forum

2 Replies
271 Views
Last post January 19, 2019, 12:33:21 PM
by Borkr
xx
Unable to suppress MESSAGEs

Started by USURP_RUR on Fanuc Robot Forum

0 Replies
921 Views
Last post May 09, 2016, 11:01:23 PM
by USURP_RUR