S3 "Prog Unit Communication Fault"

  • Hello all,


    I have faced quite annoying problem trying to run S3-M91A control box for IRB2000.
    Robot origin is unknown, so I do not know if it worked at all in this configuration (hope it did :smiling_face:
    Self check does not pass, pendant says "PROG UNIT COMMUNICATION FAULT", also red led is lit on DSQC230.
    I did some workaround, but no results.
    1) Signal wires are 100% ok.
    2) 24 Volts to pendant is ok.
    3) Differential signals are present on RS-422. I can see DSQC packet to Pendant, and Pendant's reply to DSQC.
    One man told me that they had similar problem on S4, and system restore (from floppies) helped.
    I have attached floppy photo- is it system floppy? How to perform system restore?
    Anybody had similar situation?
    Would be grateful for any ideas.

  • Place your Ad here!
  • When you start the system how many times does the red led flash on the computer board?


    I had a similar fault many years ago and after a lot of board swapping it turned out to be the power supply. The red LED came on and stayed on - didn't do anything. Power supply 5v had gone too to high and the computer system did not like it. Swapped the supply and everything ok.


    The software for the robot is stored on two EPROM's on the computer board, upgrading the software meant swapping the EPROMS to a new pair.
    The only thing you can load from floppy is saved parameters and blocks (which is probably what is saved on that double density floppy).

    BR<br />prnuk2003

  • After power on:
    1. red led goes on and off several times. Pendant's lcd shows "ABB ROBOT SYSTEM SELF TEST"
    2. later, just before I see pulses on RS-422, red led blinks fast for about half second. Pendant's lcd shows "INITIALIZING.." for a very short time
    3. and then "PROG UNIT COMMUNICATION FAULT" with red led constantly lit.


    I tried to disconnect X1 plug from backplane (two wires with RS-422 signals)- power up behaviour remained exactly the same. But continuity was checked one hundred times, wires are not broken or damaged.
    I will check all other voltages (I only checked 24V)


    Ok, as you said, my floppy is just a set of parameters. Do I need a Key Disk (and/or system disk, which are missing) to restore system on cpu? Do I need to do it at all? If hardware is ok and line drivers are not faulty (checked), maybe it is software problem?
    Unfortunately, I do not have spare pendant or cpu to localize problem.

    Edited once, last by rodman ().

  • Today I have measured signals on MC68681, which is UART chip between cpu chip and RS-422 line driver chip on main computer board (attached).
    I see that after every CS (chip select, which initiates read/write cycle), DTACK signal is present (which indicates succesfull data transfer from cpu to uart or from uart to cpu).
    This means that cpu chip says something to pendant and gets technically correct (I mean serial data frame) answer.


    Why do I get "PROG UNIT COMMUNICATION FAULT" ?
    Stupid situation...
    :wallbash:


    I also tried to connect pendant to cpu with short, ~20centimters wires (for RS-422 signals). I connected wires from backplane X1 plug to pendant X1 plug, to eliminate possible problem with original wires. But no result.
    All voltages are ok, 25 volts and 5.1 volts on corresponding power supply pins
    I also noticed that safety card form rack is missing, hope this has nothing to do with my problem..


    There are some jumpers on DSQC230 main cpu board. What are they for?

  • When you say 'safety card form rack is missing' do you mean that you have no safety board (DSQC210 or DSQC252)?


    I am pretty sure this is part of the startup test but without it being there and communicating OK or fail, I am not sure how the computer would behave.
    On some S3 cabinets I recall that you could run the S3 system without the TPU connected (there was a dummy plug for the e-stop).


    Take a pic of the complete rack and cabinet and post it here so we can see how the layout is.


    When you turn on the power hold the INT/EXT axis button on the TPU to see if it will enter the test mode and see if it goes out of test mode when the CPU goes into the fault condition.

    BR<br />prnuk2003

  • Hi,


    The "PROG UNIT COMMUNICATION FAULT" occurs when the teach pendant loses communication with the CPU. The pendant expects communication on a regular basis from the CPU. When it does not receive communications, the pendant displays "PROG UNIT COMMUNICATION FAULT".


    It appears the CPU starts to communicate by sending the "INITIALIZING" message and then locks up. I highly suspect the missing DSQC228 Safety Board is the reason. The Safety Board is an integral part of the control system and it will not allow you to do anything without it.


    Good luck
    Skooter

  • Thank you very much for your useful replies!
    1. Control box photo is attached. Clearly, safety card is missing. According to M91A diagram, D26.172.X1 slot is empty, with many wires coming out from the empty plug(seat).
    2. TPU enters Test mode when INT/EXT axis button is pressed on power on. Three tests are done- keyboard, lcd and joystick, all works ok.
    3. I will check circuit diagram how to bypass safety card. Will tell about progress.

  • Wow that is one really bare system!


    To try and 'simulate' or bypass the board so that the DSQC230 is happy that all is OK would be quite difficult and time consuming to say the least and as it handles the run chain (e-stop,work stop, DMH) and brings in the run contactors, brake relay etc then I would strongly recommend that you take the plunge and fit the correct safety board for this cabinet.
    The system would not be in a safe condition without this board fitted and working.

    BR<br />prnuk2003

  • You are right, I would never allow any person to approach robot with bypassed safety circuits. Even if it is possible to do, I deny to do this.
    How do I know which safety card model is the right one for this controller configuration?
    DSQC210 or DSQC252 or DSQC228 or smth else? For example, can any stickers on cpu board help to identify proper safety card?
    Or any of these will work, just need to properly wire e-stops, contactors, etc according to circuit diagram?

  • Thank you, Skooter!
    Today we got DSQC228 and installed it. Initialization passes OK, but I still can not run robot.
    Top cover of the enabling device on TPU is missing, so I can press each of two microswitches (5 and 6, as marked on the inside of TPU) individually or both. By the way, what is the right way to press them without top cover?


    On DSQC228 these leds are lit (key in TEACH mode): DC, EN, EM, LIM. By the way, could anybody tell me the meaning of DSQC228 leds?
    When I press sw5 OR sw6 with MOTOR_ON button, error code is "536 DMH FAULT 1".
    When I press both sw5 AND sw6, I get error code "536 COMM OFFSET NOT DEFINED 34" and DSQC228 leds DM and SAF light up.


    On DSQC228 these leds are lit (key in AUTO mode): DC, EN, EM, LIM, W, SAF
    When I press MOTOR_ON button, I get error code "536 COMM OFFSET NOT DEFINED 34"


    First I suspected LIM (limit switches). I checked circuitry- continuity is ok on robot(LIM SW.B1 to LIM SW.B2) and all jumpers are in place (LIM SW.EXT1 to LIM SW.EXT7), (INT ES5 to INT ES6). But I still suspect LIM must not lit during normal operation..
    Also I suspect that SAF is kind of safety alarms, and it must not lit during normal operation.
    I checked COMMUTATION procedure in service manual, and it looks like a lot of trouble to perform...
    What else should I check?

  • There should be a plastic flap on top of the two swtches with a rubber piee underneath that pushes the two microswitches simoultaneously. If the time differences between the push buttons being activated is too ig then you get this error. Similar way to how a dual channel estop circuit is monotored.


    The com offset fault is due to the motor parameters not being loaded. Each motor has a com offset similar to the cal offset but these tell the system where the magnetic strips on the commutaor are aligned to the windings. If these are not correctly defined the motor or motors get reduced or no torque even though the system is putting in lots of amps. On the bigger axis then the robot can drop quite suddenly due to lack of torque!


    If you need to auto define the COM offsets then Axis 1 you need access to the brake in the base of the robot. For axis 2 to 4 it is quite easy (you can see the com mark withour removing too much) but 5 and 6 you need to remove the wrist to lign up the mark on the brake to the mark on the motor body then reassemby then commutate - not moving the motor at all until you have commutated!


    You might have the com offsets written down on a sticker near the SMB board under the gearbox cover then you can manually enter the figures one by one or try to load the parameters from the disc. Here you will get all parameters loaded, unfortunately you don't have a choice unlike the S4 system.
    Either way you are not guaranteed that the written down or disc tored parameters are up to date.


    If you had any I/O boards fitted when the parameters where last saved then you will get a missing board error.


    I have attached a document for the 228 board for reference.

  • Thank you Prnuk2003!
    I can finally run robot with joystick! :cheer:
    I have decided to enter comm offsets from robot plate, not from diskette, and it worked fine.
    It was also necessary to enter motor types for axes 1-3.
    Now the only warning present is "13 ROBOT NOT SYNCHRONIZED". I believe synch procedure is described in S3 Installation Manual. I would be very grateful if somebody can send me this document to vitalijrodnov@gmail.com

    Edited once, last by rodman ().

  • I dont have an IRB2000 installation manual but I have posted a link to an IRB3000 product manual as it contans the calibration steps and how to check/ change the cal offsets.


    Confirm the cal offsets with those written down near the SMB. If you had no com offsets then you may also need to enter the cal offsets manually


    After that - line up the six calibration marks the update the counters (Manual/scan/param/resolv/count/update all counters? yes)


    Save the parameters to a new double density disc as you go along just in case (tricky to locate).
    Initialise(format) the disc from the TP otherwise you will get a disc memory fault.

    BR<br />prnuk2003

  • You guys here saved me a lot of nerves and, most importantly, TIME!
    :merci: :merci: :merci:


    Just curious- is any modern floppy disk drive able to read double density floppies? I tried to read robot's floppies on several personal computers with no results.
    Also I've heard of a "trick" with sticking piece of tape on high density floppy to use it on robot's floppy disk drive. True?
    I know that there is a usb/sd "fdd replacements" on the market, but for simple tasks/short programs it is not necessary investment..

  • Hello Rodman
    S3 always used DD discs. People used HD discs and had some 'success' but they had a bad habit of not storing everything without errors. You only found out it was corrupt when you needed to open a block or parameters then you get the dreaded disc memory fault.
    To read a DD S3 disc you needed a very old PC running DOS and ABB OLP software (to understand the ARLA programming language format) - basically only the S3 controller could read its own disc.
    When I program S3's now I save to four discs just in case the drive chews one up then I have lost only one life!

    BR<br />prnuk2003

  • The red "F" LED is a failed address problem. Looks like you've lost your parameters. Try reloading the parameters from the floppy disk. Check the I/O Type in the parameters, you should have an 8 for I/O boards 1 - 3.


    Good Luck,
    Skooter

  • Thanks!
    i have not a disk. i checked i/o type in the parameters. i have an 8 for I/O board 1-3. I changed the value of them, the red light is off, but the fault has occured " 504 WRONGLY PLACE OF I/O BOARD". I reset them to zero value, the red light is on.
    How to setting the parameters for I/O board correctly ?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners