PNS program started even though I am using "other" to start remotly

  • I recently started working for a different employer. In house controls guy. They have a view Fanuc robots which were programmed terribly (100s of lines and jmp lables all over the place).

    They were also using the PNS method to start the robot. I switched that over to "other" the only method I have ever dealt with.


    Everything works fine unless there is a fault in the line - then the robot starts PNS001, a recovery program from the original integrator. It even seems to start while another, correct, program is running. How is that possibel?

  • Place your Ad here!
  • Also, if you have the other method selected, and any of the PNS bits are high, it will overwrite whatever you have in the OTHER setup as your program with a PNS.


    Make sure your PNS bits are low when the start signal comes across.

    Check out the Fanuc position converter I wrote here! Now open source!

    Check out my example Fanuc Ethernet/IP Explicit Messaging program here!

  • Also, if you have the other method selected, and any of the PNS bits are high, it will overwrite whatever you have in the OTHER setup as your program with a PNS.


    Make sure your PNS bits are low when the start signal comes across.

    That worked. It still bothers me. Is there an actual use case for this or is it an oversight on FANUCs part to allow PNS bits to override the "OTHER" start method?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners