S4C+ power problem

  • Our school recently got an old IRB4400 with S4C+ M2000 controller. There seems to be several of the 24V supplies missing, including the one to the CPU. (Measured at the contacts at G1) It has been in storage for some years, storage conditions unknown. When I first powered it up, there was a red LED on the PSU (AC OK) but no lights in the CPU, after a few attempt to power on with or without the harness plugged in, I got the green light, but still no CPU lights. Now it's back to red and there are no 24V to cooling, SYS or computer.

    Are there any info available to help troubleshooting the PSU electronics? Since we don't know the condition of the rest of the cabinet, we are somewhat reluctant to spend a lot of money on a replacement PSU.

    Fingers crossed

    Geir

  • Lemster68

    Approved the thread.
  • Yes, I downloaded all of skooters M2000A post, and that was helpful for finding the pins. Although mine is M2000, but close enough 😀, However there was nothing on the internals of the PSU itself. Do you think it would be possible to jury-rig a couple of industrial power supplies to check out the rest of the system?

  • M2000 manuals found >here<. It's an old post but just added circuit diagrams.

    Much better off fixing the power supply. It has a serial bus that reports status to the computer.

    The circuit diagram on pg 204 only shows a block diagram but you can see the 5 separate 24V supplies.

    Approx. 80% of repairs on these is replacing the old electrolytic capacitors and fan.

  • Had a chat with our friendly robot shop, he said a new PSU was at $3000, but he had an old untested unit I could have for free. Yes pleeease 😀 Got the new unit this morning, checked it out, fitted it and the controller booted up with only the expected warnings. Just need to wait for the charge... Funny thing is when I tested the old PSU in the lab, all voltages were OK 🤯 Closer inspection of the circuit board revealed a lot of crud all over the components, so I guess it had a valid reason to be unreliable :smiling_face:

  • Next problem, there has been an undocumented mod to the braking circuit. Now there is installed an interface relay on the brake release contactor, but there is missing a 24V to the circuit. Where is the best way to get this, the customer power at XT31 or the brake power?

  • Funny thing is when I tested the old PSU in the lab, all voltages were OK 🤯

    Have to load the outputs to properly test.

    Next problem, there has been an undocumented mod to the braking circuit. Now there is installed an interface relay on the brake release contactor, but there is missing a 24V to the circuit. Where is the best way to get this, the customer power at XT31 or the brake power?

    Should already be wired, the External Brake Release 24V needs contactor K3 ON. Need more info on the 'interface relay' wiring.

  • Hmm, as soon as I fix one problem, another is queuing up :smiling_face: I think I got the braking release contactor sorted, but have not been able to engage the brake release function. On the TPU I got the 20032 message and 10036:Rev counter not updated. Normally I would jog to the ref positions and update the revcounters, but now I can't jog, the position part of the TPU jog display is flashing. K1 and K2 are activating, but no attempt to start the motors. Yesterday It would attempt to start the motors but give a torque warning because of the missing 24V to the brake release contactor (K3). There also are a couple of battery messages, but that may be because I disconnected to measure the voltage, 8,2V on the SMB and 25 on the main battery.

    Any suggestions?

  • When the deadman is pulled, K1 & K2 will engage but K3 does not until you move the joystick.

    M2000 Circuit Diagrams page 404 shows the 24V Brake path through the contactors.

    At power on, there should be 24V Brake at: K1-14, K3-21, K3-22, (K3-53)

  • Yes that's what I would expect, but when I move the joystick nothing happens. I measure no voltage at the brake contactor (A1 and A2) Yesterday when I did the same, the motors tried to run but could not because of the brakes. I think the clue is the flashing position display, but haven't found a way around it.

  • Yes, the part of the display with the angles for the joints is flashing, never seen that before.

    Edit:

    On the other robot with S4C M97 controller the position display is blank when unsynchronised.

  • The flashing positions let you know the those numbers may be invalid. Once the offending rev counter(s) are updated, they go back to normal.


    With ohmmeter, verify K3 coil is wired: A2 (-) should be 0 ohms to the controller chassis. A1 (+) should measure continuity to the Panel Board connector X8-10 - wire # is 294.


    With voltmeter it is tricky to do by yourself. If you don't have clip leads, best to have someone else to try to jog robot while you measure. With the deadman enabled and K1 & K2 engaged, monitor K3-A1 when the joystick is moved. It should have 24V with reference to the controller chassis (0V).


    Also, do not move the robot if K3 does not engage - besides releasing the brakes, K3 also bypasses the two 10 ohm in-rush resistors allowing full power to the DC-Link (rectifier). Moving the robot too much when K3 is not engaged tends to burn up those 2 resistors.

  • Since the last time I have measured the voltage to K3 A1 when joystick activated - 0V. I also placed the robot to ref. positions manually by using the brake release on the base and did the sync, so now the display has stopped flashing, but still no jogging. Doing the X-start did also not help. Logs do not show any messages relevant to not jogging.

  • Just to verify:

    when you try to jog, the key is in the Manual (teach) position?

    K1 & K2 engage with the deadman?

    all appropriate Panel Unit X1 thru X4 jumpers are installed?

    X1: 3-4-5, 7-8, 9-10, 11-12

    X2: 3-4-5, 7-8, 9-10, 11-12

    X3: 3-4, 7-8-9, 10-11-12

    X4: 3-4, 7-8-9, 10-11-12

  • Yes, the leds for all the safety inputs are lit. Usually when it does not move and any of those are open, or any other faults, there should be error messages but I have none.

  • OK, today I ran the TPU in test mode, and one of the axes of the joystick had a permanent deviation that was not possible to calibrate :smiling_face: Do you think it is possible to use the TPU from a S4C M97 controller for testing?

    EDIT:

    Took the TPU in and opened it up, there was some corrosion on the small connector on the joystick, cleaned it with some alcohol, cut off the connector, cleaned it too and reterminated. Tested, and the robot moves :smiling_face: I got a "joystick error, joystick disabled" message on the TPU display so there might still be some issues with this connector, but it was OK after a reboot. Thanks for the help guys, really appreciated :thumbs_up:

  • The joystick needs to be in its null (center) position when self testing at power up. Double check the rubber seal around the joystick stem and make sure it is not deformed or push down too far.

    Any 3HNE00313-1 teach pendant will work right off the shelf, these were used from S4C M97 thru S4C+ M2000A.

    For the 00313-1 pendants, joystick failure is the most common failure excluding physical damage to pendant/cable/connector.

Advertising from our partners