Trying to get a C30 to boot, only getting a black backlit screen...

  • Hi Everyone,

    I recently got a C30F-A002 attached to a FS06N welding robot from a trade school. It appears to be in beautiful shape and only has a few thousand hours on it, but when I power it up it only boots to a blank screen. The backlight comes on, and it appears that the lcd is showing straight black. I originally thought it might be the MFP so I found another one and got it and it reacts the same way. I got some new batteries made for the cabinet and the robot, in case that might be the problem but it still is doing the same thing. After booting if you touch the right top or right bottom corner of the screen it does beep, but that is all of the response that I can get out of it. I have messed around with the contrast knob and that doesn't seem to be the problem.

    Where would you go from here?

    Might it be a display board inside the controller or something?

    Can it lose its software after being off for a long time and be dead unless it is reloaded?

    Thanks for any help or insight that anyone might have!

    Info about this specific machine:

    AS Software: 33010KFE

    Servo Software: A1B0F-F025

    MFP Software: T3010K4E

    Model: C30F-A002

    Serial# 0080

    It is attached to an FS06N welding robot

    It has a 50817-1182R04 Teach pendant (batwing style)


  • Place your Ad here!
  • Nation

    Approved the thread.
  • Ok. So.

    Just doing more digging, the 1HP (Power Sequence) board has all four green power lights lit, meaning good power. But the bottom red LED (for ERR) Is also lit. I am assuming the list of things that could cause this is pretty long?

  • Welcome to the forum............. :beerchug:

    On C30 controllers the MFP is a stand alone video unit.

    However, this also requires the correct information transmitted from the CPU board.

    In some cases, the CPU does not start correctly and prevents the MFP from booting up, although the backlight may be on.

    In this case, I would connect a PC to the serial port (on the outside of the cabinet) in the first instance.

    Use KRTerm or KCWin32 application(s) and try and get online and obtain a backup first.

    Check out here to obtain the applications:

    Kawasaki Online Terminal Editors - Manuals, Software and Tools for Kawasaki Robots - Robotforum - Support and discussion community for industrial robots and cobots (

    This will:

    - Indicate if it is the CPU board (1GA/1HA) board is the problem or not.

    - If it is not the problem, you will have a valid backup, to allow some further risk free testing.

    This is what I would do first, before anything else.

    See if you can obtain a backup and report back the results.

    If there is any problem getting a backup using this method, post screenshots from the PC of KRTerm/KCWin32 screen.

  • So, I overnighted a null modem serial cable.

    Using KCwin32 I only get the blinking cursor, when I hit Enter the cursor stops blinking.

    However, if I start KCwin32 without a cable plugged in it doesn't say anything about not being connected...

    I looked at my settings in Device Manager, and they match what I have set in KCwin32. I also use the same laptop to RS232 in to a machining center I have, so I am pretty confident that the port works.

    In any case, I am assuming that the CPU card has given up. There are ballpoint pen marks on the dip switches for 1,3,7,8 or whichever the four are that you have to set to load new software, so I am assuming it was probably going out for awhile...

    The machine does have the red ERR led lit on the power distribution board, would that be caused by the cpu card being sick, or would an error with that card prevent the controller from posting?

    All four green voltage led's are lit on the 1HP card, both green led's are lit steady on the 1GA/1HA and there is one green led blinking on the card in Slot 1.

    If it makes the most sense to just blindly throw a CPU card at it, I can do that, just trying to make smart choices instead of firing a parts cannon at it...

    Thanks so much for all the help!!!


  • Using KCwin32 I only get the blinking cursor, when I hit Enter the cursor stops blinking.

    However, if I start KCwin32 without a cable plugged in it doesn't say anything about not being connected...

    I looked at my settings in Device Manager, and they match what I have set in KCwin32. I also use the same laptop to RS232 in to a machining center I have, so I am pretty confident that the port works.

    In normal situation if you have correct cable connected to front connector and PC and just open KCWin32 and then power up the controller, you should see information displayed in KCWin32 during bootup and then command prompt where you can type in commands.

    a. If this occurs, you can simply type in SAVE backup and file save is saved in KCWin folder.

    b. If no information is displayed, then CPU has failed to start.

    In any case, I am assuming that the CPU card has given up. There are ballpoint pen marks on the dip switches for 1,3,7,8 or whichever the four are that you have to set to load new software, so I am assuming it was probably going out for awhile...

    Correct position for firmware upload via PCMCIA card is 1,3,5,8.

    What happens if you set dipswitch 1 ON and the rest to OFF (standard for normal operation)?

    a. Does MFP light up and display any information like Kawasaki Logo or Green keyboard.

    b. Does the same thing happen - no display.

    c. Do you receive any information during bootup on KCWin32 screen.

    d. If KCWin32 shows information, try entering SAVE backup to create file save.

    If at this stage, no change has occurred, we can assume either CPU board is bad, or memory/AS corruption and therefore any old information stored in the CPU board is gone for good.

    You may as well attempt hardware initialization procedure to see if you can kick her into life.

    a. This removes ALL existing data and returns it to a default EMPTY controller.

    b. This does not affect firmware.

    c. If this procedure produces life, then CPU and firmware is likely to be ok.


    Only carry out the attached procedure if you are not bothered about losing information as this procedure (if hardware is good and no firmware corruption) will render the controller in operable, but should at least bootup.

    If this still not yield any results, then the next step is a replacement CPU board, which will then require the correct firmware to be loaded to be compatible with MFP firmware.

    Firmware versions that were installed from factory should be written on label inside controller door, if these are still available then replacement CPU board could be prepared assuming you have compatible PCMCIA cards (<32Mb).

  • I did not try logging in to KCwin32 before starting the controller, I will try that first.

    (I have been doing most of my troubleshooting with the '1' dip switch flipped and the rest off.)

    I have actually been trying to get help from Kawasaki on this machine, but that has proven super difficult. The guys are ok, but they are so overwhelmed with work that they forget what is going on with the machine, etc.

    SUPPOSEDLY. Supposedly I was just sent a copy of my software, which i put on a 32mb pcmcia card to try to reload the software, but then the MFP won't boot, so therin lies the problem.

    I will try firstly the KCwin when the machine is starting to see if it shows any signs of life, then secondly I will follow the instructions that you had linked below your post to see if I can kick it awake. Lastly, if it IS a CPU card I believe there is one in the usual spots that isn't incredibly out of line price-wise, so if all else fails hopefully the control still isn't scrap.

    ...gosh, the darn thing looks so nice and clean, I never anticipated it putting up such a fight!

    Have a great weekend!


  • You don't need to log on using KCWin32.

    Just have it connected, settings correct as per my guide and the application open before you power up.

    If the CPU starts correctly, you will see information as it boots.

    If you don't see any information, then the CPU has failed to start.

    (This is a standard way of checking for initial signs of life on all Kawasaki controllers).

    There are 3 firmware revisions for a Cxx Controller:

    a. TP is loaded directly to the MFP using PCMCIA. (This must be compatible for the AS revision).

    b. AS is loaded directly to the CPU using PCMCIA.

    c. SV is loaded directly to the CPU using PCMCIA.

    The firmware revisions loaded from factory will be written on a label inside the controller door.

    Those CPU boards are usually knocking around the 'auction' sites and also here in the UK, I know a company whom are likely to have these knocking around too.

    These are the better versions to have as they have integrated ethernet:

    KAWASAKI 50999-2383R23 ROBOT CIRCUIT BOARD 1HA-12 | eBay

    ...gosh, the darn thing looks so nice and clean, I never anticipated it putting up such a fight!

    She's just keeping you honest and providing some troubleshooting training as you start your journey.

    You'll not be disappointed when you finally wake her up.

  • Holy Cow!

    So, I made a huge mistake not having KCWin not plugged in when booting last time. There are signs of life!

    Here is what it says,


    And then


    I searched around and cant find anyone talking about an AC Fail Process Error. I tried to change my phasing but that didn't work.

    Also, I tried to do the SAVE thing, but it won't respond to the keyboard once it gets to that *Start Up* screen.

    Where to now? I am somewhat stumped past starting to push in contactors... I think all of my fuses are good...

    ...also, super sorry, I tried to insert the photos but it is only putting them as links. Not sure why that is...

  • Do not worry about AC Fail Process Error......This is normal and no problem.

    There is no electrical AC check made, this error is related to previous shutdown from AVR.

    Please check CPU board and report back SW2 and SW3 switch positions?

    Be careful, when you remove CPU board as you will disconnect RAM battery, so ensure you only remove it for max of 10mins to check and put back in or data corruption may occur and if battery is nearly low too.


  • I would bet that the ram has already lost its data, as the batteries that plug in to the brown connectors were both dead in this system, and I very well do believe that I have had the CPU board out of the machine for more than 10 minutes when looking at it before, not knowing there was volatile memory on it.

    Anyway, going to check that now.

    I'll be right back...

  • Ok.

    So, on the 1GA board, SW1 is unpopulated. SW2 is the 8 position dip switch in which #1 is on, and the rest of the switches are off.

    On the Handheld controller both switches are set to off.

  • I asked about SW3 on the CPU board, it is a very small black square with 4 switches on it near the rear of the board where it connects to the backplane?

    Have you tried pressing enter in the terminal window of KCWin32 after it boots to see if a command prompt appears as your screenshot is showing a communication connection?

  • Based on that information, I suspect there could be firmware corruption on the CPU.

    This would be the best route to explore from a financial aspect as if you can obtain the firmware you would need to locate suitable PCMCIA cards (<32Mb).

    Unfortunately I do not have those firmware revisions you listed in your first post, only much earlier revisions.

    Any chance you could try and reach out to your local Kawasaki distributor and see if they can supply those revisions?

  • So, I have got the following files from Kawasaki tech support:






    Are they what I need or do I need something else?

    They sent over a procedure that involved holding your fingers on all four corners of the screen of the MFD to make it load the software from the pcmcia card (I got one off ebay a couple weeks ago, it is 32mb but it is a no-name brand... not sure if the controller likes it, but it does read and write to my computer) but I could not make it respond, however I was not watching via KCWin, only the MFD display.

    How should I proceed, and do I need any different software?


  • Hmmmmm......Apologies, I have overlooked one slight issue, we need the MFP to be functional in order to install the firmware to the CPU board....... :hmmm:

    Ok so at the moment we have the firmware and an MFP that appears to be dead, although the backlight is coming on.

    So let's try the procedure to install TP firmware to the MFP and see if the bootloader.

    I'm assuming the procedure Kawasaki supplied you will be the same as I have.

    Try the initial steps of the TP firmware procedure then (without any PCMCIA card in:

    - Emergency Stop in.

    - Teach Lock to ON.

    - Set SW2 no 1 to ON (this switch is located in the rear panel of the MFP next to the PCMCIA slot).

    - Power on and immediately press all 4 corners of the pendant for a good 30 seconds.

    What happens when you do this, does the screen actually appear, even if it's just white background?

  • I will try this again when I get to work in a bit.

    Here is a twist, I bought a second mfp and it does exactly the same thing, not that two couldn't be broken the same way but do they always fail to a black backlit screen? Makes me think there is something to do with the control itself.

    Which files should be in the root of the memory card when doing the tp software install on the mfp? The Kawasaki instructions don't specify if there are files that should or should not be included. And also the Kawasaki instructions don't say the e-stop should be pressed. I have tried this a million times and every time I made sure the e-stop was not pressed as I thought the controller might not run if estop was pressed.

    That right there might be the solution to all of this. I need to finish my coffee!


  • Ok. So, now the screen on the MFP actually starts to boot something that looked like some vertical green bars on the left and maybe a blue header and white background but it just very quickly flashes (more like grows from the middle of the screen) and then goes away. KCWin now is reporting AC Fail Process Error = 00000000 which is different than before.

    By "try the initial steps" I put the pcmcia card in with tp_load and the other two files that start with T and set the e-stops to in, and teach lock to on, control to teach and run (instead of repeat and hold) and flipped the switch on the machine while holding all four corners for a minute, then restarted and did what you said (the same thing, just without the card in)

    After the fast flash on the screen, which it did not do before, then it goes back to the black screen and KCWin is locked up.

  • All I asked you to do was the following:

    Nothing about KCWin.

    Can you post an image of what the screen looks like?

    What about the other MFP?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners