getting started with KRC4 compact, on a kr10 r1100 sixx

  • and how come the address changed for the controller in WOV, but not on the pendant?

    how do i get to the mapping screen i still just have the picture of the contrlller and the arm. but

    do i still need to activate the controller by double clicking the krc4 on the left?

    Edited 2 times, last by dieselxj ().

  • do i still need to activate the controller by double clicking the krc4 on the left?

    Yes. In the project structure under hardware please double-click on KR C4 to activate the controller.

    Could you share some screenshots? It would be easier to follow and to support. I'm not in the office at the moment and therefore, I can't go through it myself.

  • i got impatient, i double clicked the controller icon on the left margin , activated it and the screen split to what i had lasst night, i selected field buss on the right and highlited the em8905, and kcIO on the left.

    and now i have a error

    2:33:01 PM Error in DTM EtherNet/IP: IP source address configured in the DTM is not available on your system. To be able to go online, please correct this in Settings user interface.

    and nothing is green connected on the right?

  • did it work

    it looks ok on my end

    my network dongle connector has switched from flashing white on the one side to solid orange onthe other side that seems bad

  • am i ready to deploy ??

    or should i save under a new name and then try and deploy. and will they deploy to all the programs or just the one i worked on in wov.

    the Wov project i am currently working on is/was NOT a active program on the control pendant

    Edited once, last by dieselxj ().

  • am i ready to deploy ??

    Basically yes. But you have to correct the error to be able to load the project on the controller.

    I'm not sure about the "Error in DTM EtherNet/IP" error. Unfortunately I'm not familiar with EtherNet/IP used in combination with a KUKA controller. Open the EtherNet/IP tab in the project structure to see if there is something wrong or missing.

  • ok i will try thanks

    what about saving

    i looked up the orange light and that just says data is moving

    also is there a way to see if it iis still a active alarm. the time stamp is a hour old

    no sign of a problem on the left margin in the tree ( under ethernet)

  • activate gives me a pendant request to acivate project? so if i say yes, it will move the project from project IN WOV to a program on the pendant? ????

  • i i clicked pendant yes. and now i get a pretty lengthy pendant request about project managements and changes on the pendant. it will take too long to photo and upload so here is what i got

    global 3 actions

    configuration 28- changed, 0 add 0 delete

    transfer 1 change 0 delete 0 add

    ethernet IP " " "

    kuka controller bus 1 change 0 add 0 delete

    KRC 2 change 0 add 0 delete

    machine data 4 change 0 add 0 delete

  • no going back now looks like i got reboot but i don't see a new program i guess i will see if i have a air on and off

    ok no program activation. do i need to disconnect the computer or close wov?

  • deploy step transfers project to KRC. there are already several projects but only one can be active. you can activate another project using smartPad - this is convenient when falling back to a good project when changes made in Wov do not work.

    so step "activate" will simply dethrone previously active project (not erase it or overwrite it - unless file name is the same). and if things go sideways, you can simply activate project that was active before (unless overwritten).

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • well that was a super fun and educational exercise . i feel like i learned a fair amount, had a little scare when nothing would move after the reboot, but i remembered there is a little safety switch that need to be toggled after a power up

    so i power cycled again and the robot does not seem to be any the worse for the process, but i still can not get the pneumatic valves to work correctly. I can i think hear them activate, but they are not changing all 3 b side valves are open and passing air from air 1 on the base. even when the valves are selected off.

    All of the A side valves never pass air even when activated. i manually selected all IO 7 thru 12 and still no air passes thru the " A " side. i am pretty sure i can hear the valves clicking but no air passes execept thru the b side . also all the b side valves are connected all the time.

    i can see the IO 7 i selected in the program is activating, on and off in the program but no air flow.

    thanks Panic mode, thanks DS and thanks skyefire for all your help and patience.

    panic mode i think i follow what you are saying, but i do not see the name of the project anywhere on the pendant????. and A " cell " program that seems to be stuck in a endless loop like it has a error. I can see it has a line 8 and then line 9 says loop and the program runs but never progressses past linie 8. i am not really concerned about that at this point.

    I am much more interested in getting a air valve to work

    does anyone have any thoughts on the air valves. if i understand correctly from the base there is air 1 which i going to the valves in the arm and then air 2 which is always on and comes out at the little port above and to the left of the 6 actuated valves ( a1,2 b1,2 c1,2) is this correct?

    do the valves ever get sticky, do they need air tool oil???????

    all the caps and corks were installed when i received the unit. I don;t think they were ever used, but i dont; know

  • i still don't understand how the IO 's are identified other than what is in the manual. are the valves assigned to a hard value as default, in the arm or the controller? and then what i did just told the other half where they were:???

    Now i wish i had also tried to select a actual IO with a low voltage output to run a external relay. Those electrical IO 's are just next to the air manifold on the arm correct?

    all the air valves are supposed to be shut when the power is off correct? there was some question about that earlier in that i think DS said the valves stay in their last position at power down???

    can strong vacuum help unstick the valves???

    i can definitely hear the valve relays clicking , when i manually activate them in the io display. but no change in function. to oil or not to oil that is the question?

    Edited once, last by dieselxj ().

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now