KCP Could not set IP address KRC4

  • I have a KR30-3 with a KRC4 8.3.17 which has recently started showing "Could not set IP address" error. I have looked at other threads and tried disconnecting and reconnecting the smartPAD but without any success. I have also disconnected and reconnected the ethernet cables in X65 and X66 and rebooted but no change.


    The error started occurring when a USB stick was inserted into one of the two USB ports on the front of the KRC4 cabinet. These have always been a bit dodgy and temperamental and could sometimes caused an Ethercat error (KSS13021) to be caused if the USB stick was waggled around too much upon insertion, but that could usually be cleared with rebooting the system entirely.


    This issue is worse now though because at least with previous errors I could use the interface on the smartPAD, but now this isn't possible and I'm stuck after booting. I have a feeling that maybe the dodgy USB ports have somehow knocked some other connection out?


    A side issue is that I'm trying to open the cabinet to connect a monitor to the KPC and cannot seem to unlock the front door? Am I missing something obvious here? I'm not using the supplied key but have just turned it using a screwdriver is maybe the issue? But the whole locking system seems to come out and the front door doesn't budge either way.


    It's very likely we need to get the cabinet serviced properly, but in the mean time, are there any fixes that could be recommended?


    0IrQqNl.jpg4bWqg13.jpgbOnw67F.jpgQbG5ggA.jpg5ruOFoT.jpg

  • Fubini

    Approved the thread.
  • it is labeled as "robot 2" so there must be a "robot 1" somewhere.


    if you suspect the problem is with the smartPad (usually the cable), you can try swapping smartPads and see what happens.


    you can also connect external monitor and see if there is a clue on the controller.


    you can also collect KRCDiag and send it to KUKA.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • The SmartPad got lost and could not automatically set IP addresses. In addition to the Windows IP address, it needs IP addresses in a Shared memory network and two System bus networks (real-time and non-real-time).


    Look at these settings on the SmartPad robot 1

    But I don't advise you to change anything yourself :smiling_face:

  • Turn off your controller, open the door. If the door mechanism fell apart, good luck with that task.


    Use a monitor to troubleshoot the internal PC. Might be a software issue, might be bad RAM. Requires PC troubleshooting skills, maybe a mouse, a keyboard, but for sure a monitor.

  • Thanks for the replies.


    I managed to get the cabinet open and connect a monitor and everything was fine. Have now swapped smartPADs with robot 1 and it works fine on robot 2.


    I have asked KUKA for a quote on repair/exchange for the smartPAD and they have quoted over £3000!?


    Can anyone recommend any intermediary steps for trying to fix it? I can't seem to find the settings you are talking about de_Arce?

  • You can try to fix it yourself, but in this case all the possible risks fall entirely on you :smiling_face:

    I can tell you what and where to do if you are willing to take the risk

    Or you can contact Kuka and they will fix it :smiling_face:

  • What does this mean?

    The not working Smartpad is working on the other cabinet, or the Smartpad from the working robot is also working on the robot where the other Smartpad doesn't work?

    The setup is:

    - robot controller 1 (RC1) with smartpad 1 (SP1)

    - robot controller 2 with smartpad 2


    SP2 is the one with the error.


    I unplugged SP2 from RC2, and unplugged SP1 from RC1.


    I plugged SP1 into RC2 and both SP1 and RC2 work absolutely fine.


    I plugged SP2 into RC1 and SP2 shows the same error on RC1 as it did for RC2.


    I hope that clears things up.

  • so you have narrowed the issue down to a faulty smartPad. the next question is if there is something that you can do about it. on newer variants (SmartPad2) KUKA offers cable as a replacement so users can swap it out by themselves if needed. on earlier variant there was nothing that could be serviced by the user - not even the cable.


    in most cases damage to smartPad is broken LSD screen (which tend to be obvious) and broken cable (because people abuse it, step on it, pull on it when it is badly twisted etc.).


    in some countries KUKA offers repair service. in that case you can contact KUKA with problem description, and get RMA number to ship them your defective smartPad for repair.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Advertising from our partners