• gTpsMVpHi guys,

    as seen in attachment,we are having issue with this message after the cpu battery was removed before robot got installed and powered up. We are trying to install the firmware USB on a brand new robot and this is preventing us from even booting into bios. The controller is R-30iB and has never been booted before, but as I said, the cpu battery was removed while controller was off. Normally we just boot into bios and recover image from other identical controllers, but as my team informs me, for some reason it's not possible in this case. Anyone can advise how to proceed or at least saw this message pop up before?

    thanks in advance

  • AD
  • kwakisaki

    Approved the thread.
  • Hi frederiksensome,

    It looks like the TP wants to update its firmware.

    Try the following:

    - Connect the TP to another robot (current software version) and boot this robot.

    (...automatic firmware update...)

    After the firmware update of the TP, connect it again to the other/original controller.

    - Or try another TP on the controller.

  • Hi, thanks for the responses, my team tried what u suggested and its possible to boot up the controller with teach pendant from other robot,but when using its teach pendant on another robot the same error occurs. And no, its not even possible to boot BMON, otherwise it would possibly be an easy fix from the start. Seems to me like the teach pendant automatic update when doing the firmware update got screwed and now the files are corrupted somehow. Do u know if there is any way to get the pendant into default state as it is when shipped we can do on-site?

    • New
    • Helpful

    Hi frederiksensome,


    Do u know if there is any way to get the pendant into default state as it is when shipped we can do on-site?

    I don't know. But:

    Is there guarantee?? --> Ask Fanuc!


    The TP runs WindowsEmbeddedCompact7.

    You are able to compare folders/files of two TP's side by side...

    With powered up TP (not connected to robot, or wrong ip ) your TP will show a black screen. This is the windows desktop.

    Attach a mouse to TP, then do right click.

    --> you are able to browse the embedded windows file system.

    I do not remember the "shortcut" at the iPendant to NOT connect to the robot.

    best regards


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now